Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Our next available supporter will start replying to tickets in about 6.11 hours from now. Thank you for your understanding.

Marqué : 

This topic contains 17 réponses, has 3 participants.

Last updated by Alejandro Il y a 1 an et 9 mois.

Assigned support staff: Alejandro.

Auteur Messages
avril 24, 2019 à 6:47

stephanL-12

Bonjour,

J'ai 2 produits sur mon woocommerce traduits en anglais.
Depuis la dernière mise à jour woocommerce, je n'arrive plus à ouvrir la fiche produit en anglais.
Cela charge dans le vide sans rien afficher.
Avez-vous une idée d'où cela peut-il venir et de ce que je dois faire ?

J'ai également des messages d'erreur lorsque j'accès à mon produit en FR :
Notice: Undefined index: on in /home/clients/net4win/dev/efotix/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 424
Notice: Undefined index: in /home/clients/net4win/dev/efotix/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 424
Notice: Undefined index: in /home/clients/net4win/dev/efotix/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 424
Notice: Undefined index: ion in /home/clients/net4win/dev/efotix/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 424
Notice: Undefined index: ment in /home/clients/net4win/dev/efotix/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 424
Notice: Undefined index: cadre in /home/clients/net4win/dev/efotix/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 424

D'où cela peut-il venir ?

Je vous fournis ci-dessous un accès à mon environnement de pré production.

Merci d'avance pour votre aide.

Cordialement

avril 25, 2019 à 7:27 #3679475

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Je me suis connecté sur le serveur de Pre-prod et je trouve qu'il y a des inconsistences sur les attributs WooCommerce sur WooCommerce Multilingual->Attributs.
Il faut corriger ces inconsistences et synchroniser les attributs (bouton en bas) .
J'ai aussi trouvé un attribut dimension qui a été créé en anglais plutôt qu'en français. Il faut supprimer cette attribut et le recréer en français.

Pourriez vous aussi executer les actions de cleanup sur WPML->Assistance technique->Dépannage.
Et aussi les actions de WooCommerce Multilingual->Statut->Dépannage(lien en bas de page).

Je reste à votre disposition.

Cordialement,
Jamal
Assistance WPML

dimension-en-anglais.png
avril 25, 2019 à 8:33 #3680119

stephanL-12

Bonjour,

Je vais effectuer vos actions mais il y a un souci avec le plugin WPML Translation Management.
J'ai dû le désactiver car cela bloquait la sauvegarde de mes produits en back-office et l'affichage des versions anglaises sur le front.
Cela fait suite à la dernière mise à jour de Woocommerce.
Vous pouvez le vérifier sur mon site.
Avez-vous un correctif ?
Merci.

avril 25, 2019 à 9:15 #3680397

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je viens de vérifier sur votre site. J'ai activé Translation Management et pu sauvegarder un produit en mettant le premier "C" de "contenu" en majiscule. Cela a été bien pris en charge sans erreur.
hidden link

Je reste à votre disposition.

Cordialement,
Jamal

avril 25, 2019 à 11:47 #3681957

stephanL-12

Quand je lance les synchronisations que cela soit sur les attributs ou dans Multilingual->Statut->Dépannage, cela tourne dans le vide et rien ne se passe.

avril 25, 2019 à 1:21
avril 25, 2019 à 5:13 #3684629

stephanL-12

Comme demandé, j'ai migré le site sur blogvault.
Merci d'avance pour votre aide.

avril 25, 2019 à 7:54 #3685543

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Merci pour votre effort, mais malheureusement la copie ne marche pas. Essayer de visiter une page et vous aurez un erreur 500. Voir capture attachée.

J'ai activé le déboggage PHP et je constate les erreur suivantes sur le fichier debug.log
hidden link

[25-Apr-2019 19:08:52 UTC] PHP Warning:  include(/mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-settings.php on line 84
[25-Apr-2019 19:08:52 UTC] PHP Warning:  include(/mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-settings.php on line 84
[25-Apr-2019 19:08:52 UTC] PHP Warning:  include(): Failed opening '/mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/usr/share/php') in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-settings.php on line 84
[25-Apr-2019 19:08:52 UTC] PHP Warning:  require(/home/clients/muwps/dashboard-widget-wpserveur.php): failed to open stream: No such file or directory in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-content/mu-plugins/muwps.php on line 22
[25-Apr-2019 19:08:52 UTC] PHP Warning:  require(/home/clients/muwps/dashboard-widget-wpserveur.php): failed to open stream: No such file or directory in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-content/mu-plugins/muwps.php on line 22
[25-Apr-2019 19:08:52 UTC] PHP Fatal error:  require(): Failed opening required '/home/clients/muwps/dashboard-widget-wpserveur.php' (include_path='.:/usr/share/php') in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/qbyudjvmgs/public_html/wp-content/mu-plugins/muwps.php on line 22

Il fallait que je désactive le caching et que je surpasse l'execution du mu-plugin muwps.

Le serveur migré est aussi unstable et très lent, certaines pages se continue de se charger sans résultat. Les produits traduits ne s'affichent pas.
Le fichier de debug.log ne présente plus rien.

Alors je suis retrouné sur votre serveur et j'ai éxecuter les routines WCML sans succès. J'ai pu ouvrir un produit en traduction, il lui reste plusieurs attributs non traduits. Voir capture attachée.

Je vais me rapprocher de notre équipe 2nd Tier pour solliciter leur aide et je reviens vers vous le plutôt possible.

Entretemps, pourriez vous demander à votre hébergeur de nous fournir un dump de base de données et un fichier zip pour le dossier wp-content. Vous pouvez partager ces informations via un service de partage comme DropBox ou GDrive.

Cordialement,
Jamal

product-in-cte.png
clone-500-error.png
avril 25, 2019 à 9:25 #3685983

stephanL-12

Je vous ai copié le dump et zip dans le dossier supportwpml sur mon serveur auquel vous avez accès.

avril 26, 2019 à 9:52 #3689337

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre retour. Je vais téléchargé les fichiers si la dernière mise à jour de WooCommerce Multilingual ne corrige pas les problèmes sur votre site.
Nous venons de publier la version 4.6.2, veuillez faire une sauvegarde de votre site et procéder à la mise à jour.
Si les problèmes ne sont pas résolus, je continuerais mes analyses sur une copie de votre site.

Dans l'attente de votre retour, je reste à votre disposition.

Cordialement,
Jamal

avril 26, 2019 à 10:49 #3689955

stephanL-12

Bonjour,
J'ai téléchargé la nouvelle version.
J'ai pu synchroniser tous les attributs.

J'ai toujours des messages d'erreurs en haut de page (cf pj), que puis-je faire ?

J'ai également ce message :
Avertissements concernant la configuration
Certains paramètres du fichier wpml-config.xml WooCommerce Multilingual ont été écrasés.
Il est recommandé de vérifier les fichiers de configuration WPML ajoutés par d'autres modules d'extension ou des paramètres manuels sur la section Configuration du contenu multilingue.
La configuration du champ personnalisé _stock a été modifiée à partir du fichier wpml-config.xml !
Que dois-je faire ?

Merci.

Cordialement

Clipboard01.jpg
avril 26, 2019 à 1:13 #3690897

stephanL-12

J'ai supprimé et réimporté toutes les variations.
Je n'ai plus les messages d'erreurs sur le site.
Cependant, bien que tout soit traduit, il est toujours indiqué sur le produit FR de finir la traduction. Pourquoi ?
Les produits EN sont également toujours inaccessibles.

avril 26, 2019 à 1:44 #3691059

stephanL-12

J'ai resynchronisé et le produit est marqué comme bien traduit.
Cependant les produits EN sont toujours inaccessibles.
Cela ne fonctionne que si je désactive le plugin "WPML Translation Management".
Il y a donc un souci sur ce plugin.

avril 26, 2019 à 2:17 #3691509

stephanL-12

Pour l'instant, je ferme ce ticket car j'ai l'impression qu'il y a un conflit entre WPML et un développement sur la fiche produit.
Je voudrais être certain que cela ne vienne pas de là.
Je rouvrirais le ticket si le souci persiste.
Merci.

avril 26, 2019 à 2:18 #3691513

stephanL-12

My issue is resolved now. Thank you!