Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 5.36 hours from now. Thank you for your understanding.

This topic contains 5 réponses, has 2 participants.

Last updated by Andrés il y a 6 mois et 1 semaine.

Assigned support staff: Andrés.

Auteur Messages
avril 8, 2019 à 1:57 #3558363

sofianeH

Je tente de : changer de langue sur la page d'accueil

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : La page d'accueil en français

À la place, j'ai obtenu :Une autre page traduite en FR

avril 8, 2019 à 3:17 #3559609

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et les balises hreflang de votre page d'accueil pointents vers une autre page.

1. Pouvez-vous aller à Settings > General et vérifier que votre page site et home URL pointent vers la même URL ?

2. Accédez à votre base de données.
- Ouvrez la table wp_options.
- Cherchez les lignes pour les clés SiteURL et home.
- Vérifier d'avoir ajouté l'URL de votre site.

3. Finalement, pouvez-vous aller à vos Réglages > Permaliens et sauvegarder vos ajustements à nouveau ? Vous n'avez rien à modifier, simplement sauvegarder.

Cordialement,
Andrés

avril 8, 2019 à 3:38 #3559813

sofianeH

Bonjour,

Merci pour votre réponse rapide. J'ai bien le bon site URL et home URL qui pointent vers la même URL hidden link

avril 9, 2019 à 5:36 #3563127

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML est activé. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement

avril 9, 2019 à 8:51 #3564491

sofianeH

Bonjour Andres,

Je n'ai pas le pb sur mon site de test (hidden link)... J'ai dupliqué mon site de Prod avec WP All In one migration.

Pouvez-vous cacher ou supprimer le screenshot du message précédent svp car on y voit l'URL du site. Merci

J'avais modifié la langue par défaut après avoir publié en Prod, pensez-vous que cela a pu produire une erreur?

avril 9, 2019 à 9:11 #3564733

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Si le problème est arrivé après la migration, il peut se trouver que cette situation a été generé pendant la migration.

Si ce n'est pas le cas, pouvez-vous essayer la procédure antérieur ?

Cordialement