Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 22 réponses, has 2 participants.

Last updated by Jamal il y a 2 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
juillet 12, 2019 à 7:02

agnesL

Je tente de : reprendre la main pour de petites modifications en anglais et en français, sur des pages qui ont été traduites de FR vers EN par ICL.
En principe, je devrais le faire via l'éditeur classique, et c'est ce qui se passe sur la plupart des pages.
Mais pour une raison que j'ignore, et n'arrive pas à corriger, cela ouvre ATE sur certaines pages, et ATE ne reprend pas la traduction faite par ICL.

URL de (mon) site Internet où le problème apparaît : par exemple sur
hidden link

Je m'attendais à voir : le traducteur classique

À la place, j'ai obtenu : ATE
> hidden link

C'est la même chose que les articles de blog.
Et ce, même si je mets "traducteur classuqe" dans les paramètres de WPML.
Il semble que cela a été initalisé comme ça par erreur à un moment, et pas moyen de revenir en arrière. Renveyer la traduction depuis ICL n'y change rien.
(NB: j'ai aussi posé la question à ICL / Valentina)
Cela m'empeche de fianliser mon site.

juillet 15, 2019 à 9:00 #4208645

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Toutes nos excuses pour la réponse tardive, le forum français n'est pas ouvert dans les weekend.

Pour les traductions toujours en cours, ils seront toujours ouvert dans l'éditeur définit quand on les a envoyées en traduction. Après, si vous changer l'éditeur de traduction sur WPML->Paramètres(voir capture attachée), les nouvelles traductions devraient s'ouvrir sur le nouveau éditeur définit.
Par exemple l'article(Transport de valeurs & bijoux) est toujours en cours, elle serait alors toujours ouverte dans l'éditeur définit au moment de création du travail de traduction.
Pour pouvoir l'ouvrir sur l'éditeur classique, il faudrait d'abord, terminer la traduction en cours, puis basculer le site sur l'éditeur classique, ensuite réenvoyer l'article en tradcution.

Si cela ne se fait, il nous faudra investiguer le cas plus profondément, probablement, prendre une copie Duplicator de votre site pour pouvoir la partager avec nos développeurs en cas de besoin.

Cordialement,
Jamal

juillet 15, 2019 à 9:42 #4209295

agnesL

Merci Jamal, je comprends mieux.

En effet, je vois avec les icones que les items qui me posent souci sont ceux qui ont un icone "gear" au lieu de "pencil". Et je comprends que les items marqués "gear" sont considérés comme en cours de traduction, et vont s'ouvrir dans ATE si je tente de les ouvrir, quelque soit le mode de traduction défini dans les paramètres. Il faut donc les terminer pour pouvoir les voir dans le Classic Translation Editor.

Du coup am question devient :comment faire en sorte que ces traductions soient bien considérées comme terminées?
Je trouve ceci: https://wpml.org/forums/topic/translated-pages-stays-in-gears-view-and-doesnot-change-to-pencils/
- C'est un peu complexe, et je ne suis pas sure que ce soit adapté dans le cas de traductions faites par ICL?
- y a-t-il quelque chose que je puisse faire côté ICL? En fait, côté ICL, elles spont déjà marquées "terminées"
- puis-je faire quelque chose côté WP/WPML?
- ou dans PHPMyAdmin?

En fait, j'ai peur que le système se bloque, ou se soit bloqué, parce que j'aurais à un moment ouvert ATE sur une page pendant qu'elle était envoyée en traduction chez ICL. En effet, même après qu'elle a été retournée par ICL dans mon WP, j'ai dans certains cas ce comportement, où c'est ATE qui semble prendre le dessus sans que la traduction ne soit marquée terminée.

J'avais ce souci sur la page "transport maritime". N'arrivant pas à m'en sortir, j'ai fini par refaire une page en français (hidden link), et à la renvoyer à ICL qui 'la renvoyée traduite à partir de la mémoire de traduction. En front office, tout va bien. Mais en back office, rien à faire. Sur ma page "transport maritime" en français (hidden link), la traduction anglaise est marquée de l'icone gear, et quand je l'ouvre, ça ouvre ATE sur la base de la page "transport aérien", c'est incompréhensible! Il semble qu'il y a un truc de coindé dans la base.
Si ce type de manipulation marchait, je le ferais sur toutes les pages à probleme, mais ce n'est pas très pratique à expérimenter car je dois chaque fois demander à ICL d'intervenir.

NB: vous avez je pense toujours mes accès.

Agnes

juillet 15, 2019 à 9:49 #4209359

agnesL

PS: je crois que le neoud du probleme, c'est que même si j'ai envoyé ces rtaductions à ICL, WP/WPML considèrent qu'une traduction est en cours de mon côté avec ATE, et continuent de servir celles-ci Comment s'en débarrasser?

juillet 15, 2019 à 10:11 #4209595

agnesL

PS: j'ai tenté la manipulation suivante sur "transports de bijoux":
- dans Gestionnaire de traductions" . travaux de traductions" (hidden link), j'ai cliqué sur "annuler le travail".
- Du coup, sur ce post, l'icone gear s'est transformé en pencil 🙂
- Mais quand j'édite cette traduction, c'est toujorus ATE qui s'ouvre, sans reprendre la traduction d'ICL
- Si, cependant, je passe les paramètres sur CTE, alors CTE s'ouvre. J'ai alors un autre souci: je suis a 29%, car il me demande de traduire plein de légendes d'images que je ne voulais pas traduire (c'est un moindre mal). Alors que sur les pages traduites par ICL où "ça se passe bien", il ne les inclue pas.

juillet 15, 2019 à 11:31 #4210497

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Agnes,

Alors je me suis rapproché de notre équipe 2nd Tier et ATE pour avoir plus de détails sur le sujet et voila ce que j'ai pu rassembler.

Déjà, pour les medias qui mettent votre traduction à 29%, on soupçonne que les medias n'ont pas été séléctionnées lors de l'envoi du travail de traduction. Donc, il faudrait les traduire sur CTE.

Ensuite, on conseille de faire les modifications des traductions ICL sur l'interface ICL. C'est une fonctionnalité ICL qui vous permet de faire des modifications sur les traductions. Comme ça, vous trouverez toujours ses modifications si vous réenvoyer le même document à la traduction sur ICL.

Finalement, pour pouvoir utiliser les traductions déjà faites sur ICL sur l'interface CTE, on propose la manipulation suivante:
1. Accédez à la page des travaux de traduction de votre compte ICL.
2. Recherchez le nom du document souhaité et ouvrez-le.
3. Téléchargez le xliff pour la traduction.
4. Allez dans WPML -> Gestion de la traduction -> Traducteurs, et ajoutez-vous en tant que traducteur local pour la paire de langues souhaitée.
5.Allez dans WPML -> Gestion de la traduction -> Tableau de bord de traduction, et ajoutez vos documents au "panier".
6. Allez dans le "Panier de traduction" et choisissez-vous comme traducteur et envoyez-vous la documentation.
7. Allez dans WPML -> Traductions, et vous devez trouver le travail pour le doc, choisissez-le et, dans le menu déroulant en bloc, choisissez "Exporter XLIFF 1.2", puis cliquez sur Appliquer.
8. Il va extraire un fichier pour vous, ouvrez-le et vous trouverez un code appelé "Original".
9. Copiez ce code original, ouvrez le fichier que vous avez téléchargé à partir du site ICL et remplacez le code original par celui-ci.
10. Ensuite, accédez à WPML -> Traductions, puis importez le fichier téléchargé à partir du site ICL, après avoir modifié son code "original".

J'espère que cela répond à vos questions. Je reste à votre disposition.

Cordialement,
Jamal

juillet 15, 2019 à 5:37 #4213853

agnesL

Merci Jamal, je vais essayer cela.

je continue d'avoir des difficultés lourdes , à faire des A/R entre ATE et CTE.

Les manipulations réalisées ce matin sur mes pages transport maritime et valeurs ont, je le vois via uin plugin qui historicisent les interventions, créé des custom fields sur ces pages, et modifié tous les médias attachés sans que je ne comprenne pourquoi.

Ce soir, je souhaite modifier la traduction de ma Home, qui n'avait pas été envoyée à ICL (mais faite par moi via CTE je crois).
- J'ouvre ATE (car c'est ce qui est dans mes paramètres), fais la modfiication, mais elle n'est pas prise en compte
- je bascule sur CTE et la la modification est prise en compte.
- Je remarque une erreur sur ma page originale en français, vais la modifier, et là, but avec elementor, qui ne s'ouvre plus (ni sur d'autres pages) - j'y arrive après avoir , et finalement vidé mon cache navigateur, fait plusieurs A/R dans les révisions. Je fais la modification.
- Je retourne dans ma traduction (icon gear), et là ATE s'ouvre... mais non pas sur la Home, il me sert une toute autre page (logistique des événements)! Comme s'il se perdait fans les IDs (à cause des révisions?)
- Je rechange, dans les paramètres, pour CTE: rien à faire, WPML me sert la gear, et la version ATE. Comment m'en sortir?

j'aimerais bien comprendre la logique entre ATE et CTE, pour éviter les fausses manipes, parce que c'est vraiment casse -gueule!

je preds un temps fou alors que je dois finir ce site rapidement maintenant.

juillet 16, 2019 à 8:48 #4217853

agnesL

Bonjour Jamal,

Pour ma page home ci-dessus, je m'en suis sortie en reprenant une révision ancienne, qui du coup m'a permis de retomber sur la bonne traduction dans ATE. J'ai l'impression qu'il y a des erreurs de IDs entre WPML et ATE quand on joue sur les révisions... ou peut-être à cause de changements de slugs.

Ce matin, j'ai un souci sur une autre page, qui relève toujours du même problème entre ICL, ATE et CTE.
C'est sur ma page "fret aérien" qui a été traduite par ICL.

j'ai voulu y faire de menues corrections, plus une correction nécessaire sur la page en français.

--

J'ai reporté à ICL, mais je pense qu'ils vont me renvoyer vers vous, voici le transcript (en anglais du coup)
What I did:
- I started opening the translation on my website (CTE), then thought it would be better do it in ICL
- I did some changes in ICL and "publish"
- I found I had to make a change on the link in French, so I did a change in WP (fr)
- I went again to ICL and edit translation, publish.

Nothing changed in Front office (see "Mathez Transports Internationaux" in the quote), so I tried again:
- in ICL did "resend to CMS"
- in WPML did "synchronize"./ Nothing.
- Tried open in WPML => but then it comes with the icon gear, opens ATE and does not have all translations from ICL!
- went to WPML / translation jobs => could see this job as mine, so did "cancel" (or renounce I am not sure)
=> It is still on ATE, and now I really don't know how to update it 🙁
- If I now change my settings to CTE, I get the pencil icon, I can edit in CTE but my translations are empty!
- In ICL I redo "resend to CM", but nothing changes.

--

En fait j'ai toujours le même souci, pour les traductions faites via ICL, à un moment donné je bascule par erreur dans ATE, et après je ne peux ni récupérer mes traductions ICL dans ATE, ni annuler la prise en charge par ATE (ça reste avec un icone en gear en envoit dessus), sauf à passer dans CTE et devoir tout recopier à la main.
=> Comment éviter cela,
=> Comment le corriger? (me débarrasser de ATE dans ces posts? Comment faire en sorte que ces traductions ne soient plus considérées comme "en cours"?)

juillet 16, 2019 à 8:51 #4217859

agnesL

Pour info, après que j'ai fait "annuler" dans WPML/travaux de traduction, on me dit "non traduit" cf shot , alors qu'il a été traduit dans ICL mais que je n'arrive pas à le récupérer.

juillet 16, 2019 à 8:56 #4217945

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

En plus de l'usage des révisions, je dirais que ces problèmes viennent du fait que la même page a été traduite de deux manières différentes en "même" temps dans le passé.
- Création de la traduction directement sur la page d'édition ou la page liste avec l'icone (+).
- En envoyant la traduction via Translation Management.

J'ai cherché un peu la documentation pour trouver des articles qui peuvent parler des éditeurs de traductions et voici deux articles:
- https://wpml.org/documentation/translating-your-contents/how-wpml-keeps-track-of-your-translations/
- https://wpml.org/documentation/translating-your-contents/page-builders/preserving-existing-translations/

Il faut aussi noter que ATE et CTE traitent les chaînes à traduire de manières différentes, la ségumentation et la traduction. ATE pour l'instant ne fournit pas toutes les fonctionnalitées de traduction que CTE fournit.
Ce que je peux conseiller, et de passer toujours à travers WPML->Gestion des traductions et WPML->Traductions. C'est la meilleure manière pour s'assurer que WPML traitera correctement les traduction. L'usage des icones (+) (pen) (gears) et (spinner) est surtout interessant si vous allez personnellement traduire les pages sans faire appel à la traduction machine(sur ATE) ou aux services tiers(tel que ICL), et quand il n'y a pas plusieurs traducteurs.

Je reste à votre disposition.

Cordialement,
Jamal

juillet 16, 2019 à 9:41 #4218249

agnesL

Bonjour Jamal,

j'ai suivi la procédure en 10 points que vous avez proposée ci-dessus.
je bloque au point 10, car il me dit "ceci est un travail local, il n'existe donc pas de fichier xliff à télécharger".
je peux annuler le travail et et me le renvoyer, mais je suppose qu'il va me dire la même chose, ce sera du local..?

juillet 16, 2019 à 10:04 #4218771

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Pourriez vous attacher une capture d'écran du message que vous rencontrez? Pourriez vous aussi partager une copie du fichier XLIFF que vous avez réalisé?

Je me demande si vous utilisez les contrôles sur la capture attachée.

Cordialement,
Jamal

juillet 16, 2019 à 10:14 #4218831

agnesL

Vous avez raison, je n'utilisais pas ce contrôle, j'utilisais les icones à droite dans la liste des fichiers.
Effectivement, avec cette boite de dialogue j'arrive à importer un fichier XLIFF.

Par contre, je vais essayer plutôt avec un autre document, car entre-temps j'ai renvoyé la page "air fret" à ICL, mieux vaut arrêter de tout mélanger çà nouveau...
FYI ci-joint le fichier XLIFF que j'avais créé selon vos instructions. (ah, je ne peux pas l'attacher, donc voici une image)

juillet 16, 2019 à 10:56 #4219445

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Ok, Laissez moi savoir ce que vous aurez avec l'autre page.

Cordialement,
Jamal

juillet 16, 2019 à 2:09 #4220889

agnesL

Yoohoo!
J'ai pu récupérer, sur ma page "transport maritime", le travail de ICL, et faire de menues modifications dans CTE, en utilisant la méthode en 10 points ci-dessus. Je l'appellerai "la méthode Jamal", et elle m'enlève une sacrée épine du pied!
Je vais essayer sur les autres pages, et j'espère que ça va marcher 🙂
NB : je rajoute un point 0> Mettre "CTE" en paramètrage WPML avant de procéder.

Question: dans le fichier XLIFF issu de ICL, j'ai remplacé le code issu de ICL (1015) par celui-ci de WPML (1047), et je m'aperçois que 1047 correspond au "Job ID" dans WPML/traductions. Je ne pourrais pas "deviner" la suite, et m'épargner une étape? C'est sans doute un hash de vérification...
<file original="1047-fd03993e3b86bd40148da3f1febbe905" source-language="fr" target-language="en" datatype="plaintext">
Ou, mieux, je n'aurais pas moyen de changer dans ICL?

Un immense merci pour votre support.

Le sujet ‘[Fermé] reprendre la main sur les pages traduites après ICL’ est fermé à de nouvelles réponses.