Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

This topic contains 14 réponses, has 4 participants.

Last updated by Alejandro il y a 5 months et 2 weeks.

Assigned support staff: Alejandro.

Auteur Messages
octobre 26, 2019 à 1:27 #4831901

olivierB-59

Bonjour,

La langue principale de mon site est en anglais et Francais en deuxième langue.

Depuis une sous page en Francais, je souhaite faire un lien href classique vers ma page d'accueil Française, hors le lien pointe toujours vers la homepage en Anglais.

Ce problème n’apparaît que pour les liens vers la homepage, si je fais un lien dans un article en anglais vers une sous-page anglaise et que je met à jour la traduction en francais, le liens Francais pointe bien vers l'article Francais.

J'ai essayé la fonction Translate Link Targets mais rien n'y fait.

Merci pour votre aide.

octobre 26, 2019 à 3:48 #4832299

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Pourriez vous décrire comment vous avez créé ces liens? Sur Visual Composer?

J'ai essayé de reproduire cette erreur sur ce serveur de test sans succès. Les liens(post et page d'accueil) pointent toujours sur la langue originale:
hidden link

J'ai traduit à travers l'éditeur de traduction avancée.

Si vous n'utilisez pas Gutenberg(que j'ai essayé) pourriez vous reproduire cette erreur sur ce serveur?

Cordialement,
Jamal
Assistance WPML

octobre 26, 2019 à 3:59 #4832339

olivierB-59

Bonjour et merci de répondre un Samedi.

J'utilise effectivement visual composer, je modifie le liens sur la page en Anglais, puis je passe ensuite par l'advanced editor

Je viens d'ajouter un lien sur votre serveur test : ajout du lien sur page anglaise, puis traduction via l'advanced editor, sur la page FR, le lien pointe toujours vers la version anglaise de la home.

octobre 26, 2019 à 4:01 #4832345

olivierB-59

Ensuite, je met à jour les lien via Translate Link Targets

All posts and strings have been processed. 0 links were changed to point to the translated content.

octobre 26, 2019 à 4:58 #4832453

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Let me check with our 2nd Tier and get back to you. That would probably be on Tuesday.
In the meantime, you can open the translation manually and update your links.

Best regards,
Jamal

octobre 29, 2019 à 5:27 #4850737

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Our 2nd Tier suggested trying with the classic translation editor. The post link was translated and the homepage link was not. So I am still waiting for their analysis and I'll get back to you very soon.

Best regards,
Jamal

octobre 29, 2019 à 8:54 #4851521

olivierB-59

Thanks, i wait for your solution.

I'm surprised nobody had this problem before ?

Or is this only with the new update ?

Regards

octobre 30, 2019 à 9:03 #4853653

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Le ticket est actuellement escaladé à notre équipe 2nd Tier pour plus d'analyse.
Je reviens vers vous dés que possible.

Cordialement,
Jamal

novembre 14, 2019 à 7:11 #4949653

olivierB-59

Hello, how is it going ? Any update ?

novembre 15, 2019 à 6:06 #4951169

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

Jamal is not available at the moment. However, I have checked the status of your ticket and our 2nd tier has found a possible bug.

We will be back when we have any news.

Regards,
Andrés

mai 1, 2020 à 1:05 #6037995

Alejandro
Supporter

Languages: Anglais (English ) Espagnol (Español ) Italien (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi there, we still haven't had an update on this but it's possible that we will release a bugfix for this soon. I'm sorry it has taken so long. back then the latest gutenberg and WordPress versions had a few restrictions that made difficult the development on our end. there have been a few updates back then but there are still a few things to go.

I'll keep you updated.

mai 1, 2020 à 1:30 #6038057

olivierB-59

Thanks for replying, yes it is still a hot topic for me and a pretty serious disfunction in wpml.

To counter this problem I have been using a page that redirects to the homepage, but of course, if I could simply link to the homepage in the future it would be nice.

mai 1, 2020 à 3:04 #6038571

Alejandro
Supporter

Languages: Anglais (English ) Espagnol (Español ) Italien (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Thanks for letting me know, i will keep you updated then.

Regards.

juillet 14, 2020 à 5:53 #6596083

Alejandro
Supporter

Languages: Anglais (English ) Espagnol (Español ) Italien (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

It took some more time than we expected but the problem should be solved in version 4.4.0 which is our next release.

I'll change the status of the ticket so i can let you know when the time comes.

Regards.

août 5, 2020 à 6:35 #6738819

Alejandro
Supporter

Languages: Anglais (English ) Espagnol (Español ) Italien (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

The fix for your issue should be fixed in the beta version of WPML (version 4.4) which was released yesterday night.

I suggest you setup a staging site and update the plugins to the beta versions found by clicking the blue circled icon in this page: https://wpml.org/fr/account/downloads/

Try it and let me know how it goes.