Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 0.50 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Le problème :
Depuis la dernière mise à jour de Jupiter, le logo n'est plus centré.

La solution:
- Éditez le fichier \jupiter6.1.3\framework\helpers\global.php, ligne 393.
- Changez cette ligne :

if ( ! $parent ) {

Par :

if ( ! $parent && $menu_item->object !== 'wpml_ls_menu_item' ) {

Documentation:
https://wpml.org/documentation/theme-compatibility/how-to-create-multilingual-sites-using-jupiter-theme-and-wpml/

This topic contains 18 réponses, has 2 participants.

Last updated by Andrés Il y a 1 an et 2 mois.

Assigned support staff: Andrés.

Auteur Messages
avril 18, 2018 à 12:24

geraldC-2

Hi

If you look at here you will see the normal and actual position of flags :
hidden link
sitepress-multilingual-cms 3.8.4
wpml-string-translation 2.6.3
Theme : Artbees Jupiter 6.1.1
WPML flags are not consider as menu items, logo is in the middle

Now, i did an update to :
sitepress-multilingual-cms 3.9.4
wpml-string-translation 2.7.3
Theme : Artbees Jupiter 6.1.3
On this staging website:
hidden link

You could see that now it consider each flag as it is a menu items, so logo are not in the middle anymore.

Please could you help me to make the logo back to the middle ?

avril 18, 2018 à 12:56 #1674044

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et il me semble que vous avez corrigé le problème. Est-ce que c'est bien le cas ? Dans le cas contraire, pouvez-vous m'indiquer comment le reproduire ?

Cordialement,
Andrés

avril 18, 2018 à 10:23 #1680208

geraldC-2

Comment ca? Non le problème est plus que jamais d’actualité, voyez ici:

hidden link

Pour le reproduire rien de plus simple:
Prenez la dernière version de jupiter, reglez la position du logo de maniere centrale (theme options/header/logo in the middle) et la derniere version de votre plugin

Merci de votre aide

avril 19, 2018 à 6:34 #1682632

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Finalement j'ai pu reproduire ce comportement, cependant je trouve que il est attendu. Comme vous faites mention, votre menu est composé de six éléments et le logo se place just au milieu.

D'un côté, je vous recommande contacter l'auteur du thème car il s'agit d'un ajustement de votre thème est pas de WPML.

D'un autre côté, je voudrais vous demander accès à votre site en production mais je crains que la solution doit venir de l'auteur du thème.

Le prochaine message sera privé.

avril 19, 2018 à 8:13
avril 19, 2018 à 8:27 #1684431

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Malheureusement votre utilisateur n'a pas des droits de administration.

Cependant, j'ai re-verifié le code HTML de votre site en production et comme vous pouvez observer sur la capture d'écran, il existe 7 éléments

  • dans votre menu (chaque
  • correspondent à un élément du menu ). Cela veut dire que le comportement du menu est le même mais votre thème interagir d'une manière different.

    Est-ce que dans votre site de test, pouvez-vou mettre à jour uniquement votre thème Jupiter de la version 6.1.1 vers la 6.1.3 ?

    Cordialement

  • avril 19, 2018 à 12:17 #1687991

    geraldC-2

    Désolé je viens maintenant de vous attribuer un accès administrateur.

    Le site hidden link est déjà avec Jupiter 6.1.3

    Au niveau du code, sur le site de dev et sur le site de prod, les drapeaux sont en effet considérés comme des éléments de menu.
    Reste à comprendre pourquoi c'est au moment de la mise à jour de WPLM que ce problème apparait.
    Je vous propose d'installer sitepress-multilingual-cms 3.8.4 sur votre site de test pour reproduire qu'en effet le logo reste bien au centre.

    J'attend toujours la réponse de Jupiter, je vous tiens au courant dès qu'ils me répondent.
    En attendant je vous laisse étudier ce problème et peut être en trouver une solution

    avril 19, 2018 à 1:31 #1689453

    Andrés
    Supporter

    Languages: Anglais (English ) Espagnol (Español ) Français (Français )

    Timezone: Europe/Paris (GMT+02:00)

    Pouvez-vous me donner une copie .zip de votre thème copier le lien sur le message privé antérieur ? Dans le cas contraire, le téléchargement pourrait prendre l'après-midi.

    Merci de votre aide.

    avril 19, 2018 à 2:16 #1690991

    geraldC-2

    [removed]

    avril 19, 2018 à 3:05 #1693652

    Andrés
    Supporter

    Languages: Anglais (English ) Espagnol (Español ) Français (Français )

    Timezone: Europe/Paris (GMT+02:00)

    Merci pour les détails de contact que vous nous avez fourni et pour nous attirer l’attention sur ce sujet. Je vais envoyer les détails à notre Équipe de Compatibilité des thèmes et plugins, et ils vont contacter l'auteur.

    S’il vous plaît, cette procédure peut prendre du temps car il dépend aussi de la vitesse que l'auteur réponds à nos efforts pour lui contacter. Il serait très important si vous essayez de contacter l'auteur en lui demandant de nous répondre.

    Cordialement,
    Andrés

    avril 20, 2018 à 7:43 #1715765

    geraldC-2

    Voila je leur ai transmis le message, ils savent que vous cherchez à les joindre

    avril 24, 2018 à 6:39 #1780112

    geraldC-2

    Ils n'ont à priori pas de trace de votre contact. Pourriez vous réitérer votre demande auprès d'eux, je pense qu'ils ne l'ont pas vu passer simplement.

    Ils ont fait quelques essais et, comme moi, ils ont la sensation que le souci provient d'une modification dans WPML.

    Je les préviens que vous aller les recontacter.

    avril 24, 2018 à 6:42 #1780155

    geraldC-2

    Demandez à parler à Mohsen c'est lui qui s'occupe de mon problème chez Artbees

    avril 24, 2018 à 6:49 #1780310

    Andrés
    Supporter

    Languages: Anglais (English ) Espagnol (Español ) Français (Français )

    Timezone: Europe/Paris (GMT+02:00)

    Pour l'instant, votre problème est géré par notre Équipe de compatibilité.
    Je reviens dès que j'ai des nouvelles.

    avril 24, 2018 à 6:59 #1780423

    geraldC-2

    Merci.
    Artbees travaille sur le sous domaine staging.charles-frey.fr, ils ont rétabli des versions antérieures de WPML et Jupiter pour voir où le problème apparait. Je tenais à vous prévenir.
    Et aussi vous rappeler de ne pas travailler sur le domaine principal qui est en production.