Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 5 réponses, has 2 participants.

Last updated by Laura il y a 4 mois et 3 semaines.

Assigned support staff: Laura.

Auteur Messages
mai 17, 2019 à 5:37

Jonathan Ménard

When we click on place order, an error message appears « Sorry, your session has expired. »:
hidden link

This issue is intermittent and we know it happened in certain conditions.

The issue happen only on product with category « Wood Glider » that is only available on /en_US section of the website, only when the user is NOT logged in.

We tought the issue happen because of low live memory but we increased it to 2Gb and we still have the issue.

We also have the issue directly after adding the product to cart, when we go to it, it says « your cart is empty »: hidden link

We contacted our hosting support WPEngine, and the WooCommerce support and they think that WPML is responsable of the issue.

The issue began to happen when we installed « Per Product Shipping » WooCommerce plugin.

Our client reported that the last time they had the issue is sunday 15th of May.

This is our live website URL: hidden link

We created a staging environnement to let you do some tests.

mai 18, 2019 à 3:03 #3839129

Laura
Supporter

Languages: Anglais (English ) Italien (Italiano ) Portugais - du Brésil (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

You opened this ticket in the French forum, but we don't have French supporters available at the moment. Please let me know if this is an issue.

You said you have a staging site but I can't see credentials for it, only the FTP credentials. Did you test in the staging site if the issue happens and if it disappears disabling WPML?

mai 21, 2019 à 1:26 #3855513

Jonathan Ménard

Hi,
If this is possible, I would prefer to be transfered to the english support.
Our staging environnement is hidden link and the credientials are WP access I sent in the previous message.

I disabled WPML, then I made two orders, one logged in and one in incognito mode and both work correctly.

We have this issue since few month, we would be very happy to find a solution once and for all.

Thank you for your help!

mai 21, 2019 à 3:42 #3856897

Laura
Supporter

Languages: Anglais (English ) Italien (Italiano ) Portugais - du Brésil (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we can continue in English here then.
As I said in my previous post, there are no credentials for the site. Please add them, I'll enable a private reply.

mai 21, 2019 à 4:00
mai 21, 2019 à 7:43 #3858529

Jonathan Ménard

I tried to disable all plugins and when I enabled just WPML and WooCommerce ML, I had this issue:

mai 22, 2019 à 9:06 #3863409

Laura
Supporter

Languages: Anglais (English ) Italien (Italiano ) Portugais - du Brésil (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I found the issue was caused by WPML Redirect Based on IP Country. Once I deactivated, I could find the product in the checkout. Reactivating it seems to have fixed the issue, I also checked with a VPN from the US. Could you check this too and confirm? Maybe installing other plugins created some kind of conflict and deactivate and reactivate reset the plugin's settings.

About the message, usually deactivating all plugins + theme and reactivating them fixes the issue. If this is not the case, we'll see how to manage it. WCML requires some product taxonomies to be untranslatable, and this sometimes causes conflict with other plugins/themes.