Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 11 réponses, has 2 participants.

Last updated by Max Il y a 6 mois et 1 semaine.

Assigned support staff: Max.

Auteur Messages
février 11, 2021 à 6:40 #8064823

lucasG-7

Autre point très catastrophique avec cette page : hidden link

Les miniatures sont vides en allemand mais en français c'est correct et ça fonctionne très bien !

février 11, 2021 à 6:43 #8064829

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Selon nos règles de support, nous devons gérer un seul incident par ticket, ça nous permet d'améliorer notre service et permet à d'autres utilisateurs de bénéficier des informations exposées.

C'est possible que les images ne soient pas dupliqués dans les pages traduites. Veuillez lire notre guide et vérifiez que WPML est bien configurée pour dupliquer les images: https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/module-traduction-des-fichiers-medias/#:~:text=Les%20options%20de%20traduction%20des%20m%C3%A9dias%20se%20trouvent%20au%20bas%20de%20la%20page%20WPML%20%E2%80%93%20Param%C3%A8tres.

février 12, 2021 à 10:03 #8069219

lucasG-7

Bonjour,

Je vous confirme que les réglages effectués sont correct. Malgré cela, les miniatures sont vierges et on voit bien qu'il y a un problème sur le produit en allemand dans le back-office ici : hidden link

février 17, 2021 à 7:13 #8110611

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Premièrement, merci beaucoup pour votre patience et désolé de vous faire attendre - la file d'attente des billets est très pleine en ce moment et il nous faut un peu plus que d'habitude pour traiter les billets.

J'ai regardé les paramètres et tout semble correct; j'ai activé l'extension WPML Media juste au cas où.

Veuillez mettre à jour l'extension WooCommerce Variation Swatches and Photos jusqu'à la version 3.1.3. La version 3.0.6 est sortie en 2018:

hidden link

Ensuite faites un petit changement sur la page de produit (ajouter un caractère quelque part), sauvegardez, ouvrez la traduction, complétez-la à 100% et vérifiez si cela change quelque chose sur la page de traduction.

février 22, 2021 à 2:03 #8145529

lucasG-7

Le problème est toujours présent !

février 24, 2021 à 2:08 #8164161

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci! Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, j'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter.

hidden link

WPML et WooCommerce sont déjà installés, il faut les activer. Une fois vous êtes sur le tableau de bord du site, installez uniquement votre thème/extension et essayez de reproduire cette situation. Si l'erreur est reproduite, j'escaladerais le ticket à notre équipe de compatibilité.

Note: vous n'avez qu'installer le thème/extension nécessaire pour reproduire votre problématique. N'installez pas une copie de votre site.

février 26, 2021 à 11:27 #8180119

lucasG-7

Monsieur, vous me demandez d'installer le thème sur ce wordpress mais la licence n'est valide que pour un seul site. Idem pour l'extension utile a l'affichage des miniatures.

On se perd complètement dans la solution, pourriez-vous vous recentrer sur le site en production je vous prie.

Votre support est inefficace dans l'état, vous me demandez des choses bien trop complexe à réaliser !

février 26, 2021 à 11:29 #8180121

lucasG-7

Travaillez sur le site en production, des sauvegardes sont faites quotidiennement jusqu'à ce que le site soit 100% corrigé.

mars 5, 2021 à 2:52 #8233087

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

J'ai migré le site vers un environnement de test, j'ai fait plus de tests, et la question est maintenant avec nos développeurs du support de deuxième niveau. Je vous répondrai ici dès que j'aurai des nouvelles.

mars 12, 2021 à 2:00 #8294707

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci de votre patience.

J'ai consulté nos développeurs de soutien et je comprends maintenant pourquoi aucun attribut n'apparaît sous Products > Attributes sur votre site: c'est parce que lorsqu'un attribut personnalisé est ajouté directement au produit, il est spécifique à ce produit (attribut-personnalise.jpg). C'est pas un attribut global; seulement les attributs globaux apparaissent sous WooCommerce > WooCommerce Multilingual > Attributes (attribut-global.jpg).

Je n'ai toujours pas réussi à reproduire votre problème sur notre site de test - même avec des attributs personnalisés. Ici, tout fonctionne bien:

hidden link
hidden link

Veuillez créer un nouveau produit et reproduire votre problème sur notre site de test. Toutes les extensions sont déjà installées. Voici le lien de connexion:

hidden link

attribut-personnalise.jpg
attribut-global.jpg
mars 19, 2021 à 10:09 #8350167

lucasG-7

Bonjour, j'ai ajouté une couleur (noir - m12) sur ce produit hidden link via les attributs.
La couleur est bien positionnée sur la page français mais pas en allemand.
Je ne parviens pas à trouver l'origine de ce problème d'affichage. Tout est bien configuré sur le back office !

mars 19, 2021 à 7:52 #8354459

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Je vois que vous avez posé la même question ici: https://wpml.org/fr/forums/topic/miniatures-des-variations-mal-positionnees-dans-la-langue-traduite/

Si votre problème dans ce fil a été résolu, veuillez le marquer comme "résolu" et continuer avec Andrés dans l'autre fil.