Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 3.25 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Les mises à jour ont correctement été installées. Toutefois, j'ai depuis cette manipulation perdu bon nombre des traductions du site!

La solution: - Faites un backup complet de votre site. - Allez à WPML > Assistance technique. - Cliquez sur le lien de 'dépannage'. - Cliquez sur le bouton 'Effacer le cache dans WPML'. - Cliquez sur le bouton 'Supprimer les entrées fantômes des tableaux de traduction'. - Cliquez sur le bouton 'Configurer les informations linguistiques'. - Cliquez sur le bouton 'Recréer des tableaux de mise en cache de BD de TC'.

Mots-clés : 

This topic contains 10 réponses, has 2 participants.

Last updated by florentC-7 il y a 3 semaines.

Assigned support staff: Andrés.

Auteur Messages
septembre 17, 2019 à 3:40 #4589809

florentC-7

Bonjour,
Les mises à jour ont correctement été installées.
Toutefois, j'ai depuis cette manipulation perdu bon nombre des traductions du site!
Après vérification, celles-ci apparaissent pourtant bien dans le menu "traductions de chaînes" mais les termes restent en anglais sur le site dans sa version française (exemple en screenshot joint)
Pouvez-vous m'aider?
Merci

septembre 17, 2019 à 3:45 #4589853

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à nouveau !

Pouvez-vous aller à WPML > Theme and Plugins Localization, et vérifier de ne pas avoir coché l'option "Assume that the original language of all strings is English" ?

Est-ce que votre situation change ?

Erratum :
https://wpml.org/errata/string-translations-disappearing-on-sites-where-default-language-is-not-english/

Cordialement,
Andrés

septembre 18, 2019 à 11:03 #4595397

florentC-7

Bonjour,

L'option citée n'est pas cochée.
En revanche, il y a des plugins traduis qui n'ont pas de fichier .po
Est-ce un problème?

Cordialement,
Florent

septembre 18, 2019 à 1:28 #4597115

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Florent,

1. Pouvez-vous nommer une chaîne dont elle a été traduite et son origine ( nom de l'extension ) mais sa traduction ne s'affiche pas ?

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,

septembre 20, 2019 à 9:51 #4611109

florentC-7

Voici l'exemple demandé (il y en a beaucoup d'autres!)

septembre 20, 2019 à 9:52 #4611143

florentC-7

Navré, l'image faisait plus de 1Mb

septembre 20, 2019 à 10:39 #4611509

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

septembre 23, 2019 à 11:01 #4622687

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de vos identifiants. Je viens de faire quelques tests dans votre site et je reçois cette erreur :

Failed to load resource: the server responded with a status of 403 (Forbidden)

Or, pour isoler un problème lié à votre serveur, je viens de créer un site de test dans notre serveur Cloudways. Les instructions se trouvent dan le message privée antérieur.

Cordialement

septembre 27, 2019 à 2:43 #4655273

florentC-7

Bonjour,
Le site a bien tête migré via Cloudways WordPress Migrator.
Cordialement,

septembre 30, 2019 à 5:54 #4662381

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Merci d'avoir effectué la migration de votre site.

Or, comme vous pouvez observer, dans notre serveur tout fonctionne correctement. Il semble que le problème est associé au cache dans le votre.

Est-ce que vous pouvez suivre cette procédure :
- Faites un backup complet de votre site.
- Allez à WPML > Assistance technique.
- Cliquez sur le lien de 'dépannage'.
- Cliquez sur le bouton 'Effacer le cache dans WPML'.
- Cliquez sur le bouton 'Supprimer les entrées fantômes des tableaux de traduction'.
- Cliquez sur le bouton 'Configurer les informations linguistiques'.
- Cliquez sur le bouton 'Recréer des tableaux de mise en cache de BD de TC'.

Cordialement

octobre 1, 2019 à 11:03 #4671445

florentC-7

My issue is resolved now. Thank you!