Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur avait des points d'intérrogations(???) sur les sélecteurs de langues

Solution: Il s'agit d'un mauvais encodage au niveau de la base de données. Il faudrait corriger l'encodage sur utf8

Relevant Documentation: https://wpml.org/fr/faq/le-texte-affiche-ressemble-a/

Mots-clés : 

This topic contains 2 réponses, has 2 participants.

Last updated by gregoryC-13 il y a 2 mois et 2 semaines.

Assigned support staff: Jamal.

Auteur Messages
août 2, 2019 à 8:57 #4328291

gregoryC-13

Fait suite au poste suivant https://wpml.org/fr/forums/topic/textes-des-drapeaux-chinois-et-russe-affiche/ ayant été clôturé prématurément pour cause de vacances.

Récapitulation :

Bonjour,

J'ai un problème avec l'affichage du nom des langues dans mon sélecteurs de langues.
Je souhaite afficher le nom des langues dans leur écriture d'origine dans mon menu mais cela m'ajoute des ???

J'ai beau changer et réinitialiser les traduction de langues, cela ne fonctionne pas (voir image).

[Les accès deplacés vers le message privé]

Que puis-je faire afin de régler ce problème ?
Bien cordialement.

août 2, 2019 à 9:55 #4328759

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

J'ai déplacé les accès fournis sur le message privé. J'aurais probablement aussi besoin des accès pour le backoffice WordPress pour vérifier la configuration du sélecteur de langue.

Mais en premier lieu, je pense que la cause de ce problème est l'encodage de votre base de données. Voir cet article qui en discute plus.
https://wpml.org/fr/faq/le-texte-affiche-ressemble-a/

Je reste à votre disposition.

Cordialement,
Jamal

août 2, 2019 à 12:31 #4330017

gregoryC-13

Merci pour cette réponse rapide et efficace.
En effet l'encodage de ma table n'était pas en "utf8" mais en "latin1"
Après avoir modifié toute la base et réinitialiser les langues, le tout fonctionne maintenant normalement.