Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 12 réponses, has 2 participants.

Last updated by Andrés il y a 9 mois et 3 semaines.

Assigned support staff: Andrés.

Auteur Messages
janvier 25, 2019 à 8:47

constantinS-4

Bonjour,
J'ai un gros souci avec les endpoints. En effet mon website utilise la langue française comme langue de base. Il est traduit en anglais et en espagnol.
Le souci que je rencontre est avec les endpoints. Ils sont bien paramétrées en Woocommerce - parramteres- advance et dans Woocommerce multilingual.
Le souci que je rencontre est visible dans WPML - strings. Chaque quelques heures si je vais la bas et je cherche Woocommerce endpoints ils apparaissent comme si ils nécessite une mise à jour. A ce moment le website ne fonctionne plus, impossible a payer une commande (error 404), puisque le endpoint en anglais est utilisé.
Je fait la mise à jour des strings, tout fonctionne, quelques heures après, pareil. Les strings nécessite une mise à jour, il faut les traduire encore.
J'ai même désactivé le plugin de Cache, mais ce n'est pas ça.

janvier 25, 2019 à 9:38 #3128317

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de essayer cette situation sur mon site de test et malgré plusieurs tentatives, les endpoints restent toujours traduits. À ce point, le problème semble lié à votre installation WordPress.

Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML et WooCommerce sont activés. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparaît, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement,
Andrés

janvier 25, 2019 à 10:06 #3128414

constantinS-4

Le souci est que les endpoints nécessitent une traduction chaque "je sais pas combien de temps". Ce n'est pas automatique quand on passe une commande. Peut être si vous essayez de passer une commande en plusieurs langues.
Il vient de le faire sur mon website live. J'ai du remettre a jours les traductions des endpoints.
Ensuite ils me marquent traduction terminé et c'est bon.
Je voit pas comment tester avec les plugins désactivées, puisqu'on ne sait pas qu'est-ce qui déclenche le "truc". Et comme c'est chaque quelque temps, peut etre un souci de cache du server? j'ai aussi ouvert un ticket de ce coté.

janvier 25, 2019 à 10:07 #3128416

constantinS-4

J'ai la clone de mon website live. Voici: hidden link
Vous pouvez vous connecter avec les mêmes identifiants. Et vous pouvez effectuer n'importe quelle modification, puisque ce n'est pas un site live.

janvier 25, 2019 à 10:17
janvier 25, 2019 à 10:17 #3128446

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Justement le but de tout désactiver et ne laisser que WPML et WooCommerce actives et vérifier si le problème vient d'une interaction avec une autre extension et donc l'importance de ce test.

Je viens de vous envoyer un message privé avec des instructions.

Cordialement

janvier 25, 2019 à 10:47 #3128538

constantinS-4

J'ai commencé la migration. Elle sera effective d'ici peu.
Si j'ai bien compris, ensuite vous allez voir que-est-ce qui se passe sur ce site clone?

janvier 25, 2019 à 12:04 #3128806

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

En effet, si le problème ne se produit pas sur notre serveur, vous devez contacter votre service d’hébergement car c'est lié à votre installation.

J'attends votre confirmation pour commencer.

janvier 25, 2019 à 4:17 #3129858

constantinS-4

Ca n'a pas marché, j'ai obtenu une erreur dans la migration. J'ai installé une version antérieure de WPML et j'ai upgradé mon serveur (16 G-Ram etc). On va voir si j'ai la même erreur. Je reviens ici.

janvier 27, 2019 à 12:45 #3132002

constantinS-4

Aujourd'hui l'erreur est revenu, après 12h sans soucis.
J'ai contacté le serveur et ils me disent qu'il n'ont rien vu d'anormal. Que ça doit être WPML.
Je suis sur Cloudways avec serveur dédié.

janvier 27, 2019 à 8:48 #3132492

constantinS-4

Hier soir j'ai terminé la migration vers votre serveur Cloudways. Vous pouvez commencer a regarder de votre coté.

janvier 28, 2019 à 8:42 #3134338

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci mais vos identifiants ne fonctionne pas et votre système ne me permet pas de changer le mot de passe. Pouvez-vous me fournir un utilisateur fonctionnel ?

janvier 28, 2019 à 8:59 #3134440

constantinS-4

C'est a cause de Wordfence que vous ne pouvez pas rentrer. Mais comme vous avez access a SFTP normalement vous pouvez supprimer ce plugin sur cet serveur.
Je pense avoir reglé le souci. En effet j'ai du changer tous les endpoints woocommerce en français (ils était d'office en anglais). Ensuite j'ai du changer tout ça en woocoommerce - paramétrés - advance. Puis j'ai effectué la traduction en "traduction de chaînes" WPML. J'ai du aussi modifier le mode de traduction de links en WPML (j'ai enlevé la traduction automatique).
Depuis que j'ai effectué tous ces changements le website est stable, les endpoints ne changent plus. Donc finalement ce n’était pas un souci de serveur, mais ça venait bien de WPML.

janvier 28, 2019 à 9:08 #3134520

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Parfait, je suis ravi de savoir que votre site fonctionne correctement.
Cordialement