Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 1.32 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Le problème :
J'ai installé WPML avec le theme The 7 sur WordPress. Lorsque je vais sur le site, certain module du theme The7 ne s'affichent pas. Dans la console du navigateur, voici le message que je vois :

Failed to load resource: the server responded with a status of 404 ()
(index):1 Refused to execute script from 'https://www....../wp-content/plugins/sitepress-multilingual-cms/res/js/jquery.cookie.js?ver=3.9.4' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
language-cookie.js?ver=4.9.6:3 Uncaught TypeError: jQuery.cookie is not a function
at Object.<anonymous> (language-cookie.js?ver=4.9.6:3)
at Function.each (jquery.js?ver=1.12.4:2)
at HTMLDocument.<anonymous> (language-cookie.js?ver=4.9.6:2)
at i (jquery.js?ver=1.12.4:2)
at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
at Function.ready (jquery.js?ver=1.12.4:2)
at HTMLDocument.K (jquery.js?ver=1.12.4:2)

La solution:
- Allez à WPML > Langues > Filtrage de langues pour les opérations AJAX
- Décochez l'option à continuation :
x Stocker un cookie linguistique pour prendre en charge le filtrage de langue pour AJAX

Mots-clés : 

This topic contains 3 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 5 mois.

Assigned support staff: Andrés.

Auteur Messages
mai 23, 2018 à 9:08 #2213525

cyrilB-2

Bonjour,

J'ai installé WPML avec le theme The 7 sur WordPress.

Tout est à jour.

Lorsque je vais sur le site, certain module du theme The7 ne s'affichent pas.

Exemple : Image de la bannière, compteur de chiffres ...

Dans la console du navigateur, voici le message que je vois :

Failed to load resource: the server responded with a status of 404 ()
(index):1 Refused to execute script from 'hidden link....../wp-content/plugins/sitepress-multilingual-cms/res/js/jquery.cookie.js?ver=3.9.4' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
language-cookie.js?ver=4.9.6:3 Uncaught TypeError: jQuery.cookie is not a function
at Object.<anonymous> (language-cookie.js?ver=4.9.6:3)
at Function.each (jquery.js?ver=1.12.4:2)
at HTMLDocument.<anonymous> (language-cookie.js?ver=4.9.6:2)
at i (jquery.js?ver=1.12.4:2)
at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
at Function.ready (jquery.js?ver=1.12.4:2)
at HTMLDocument.K (jquery.js?ver=1.12.4:2)

mai 23, 2018 à 10:05 #2213969

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous activer l'ajustement à continuation :
- Allez à WPML > Langues > Filtrage de langues pour les opérations AJAX
- Cochez l'option à continuation :
x Stocker un cookie linguistique pour prendre en charge le filtrage de langue pour AJAX

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Andrés

mai 23, 2018 à 10:49 #2214461

cyrilB-2

Pour résoudre le problème, il fallait désactiver l'option : Stocker un cookie linguistique pour prendre en charge le filtrage de langue pour AJAX.

mai 23, 2018 à 10:56 #2214465

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci d'avoir partagé votre solution. 🙂
Bonne journée.