Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Le problème :
Lorsque je veux modifier les traductions personnalisés pour ne pas copier ce contenu spécifique du francais vers l'anglais, l'option n'est pas disponible. C'est fixe à copier. Comment modifier pour mettre à ne pas traduire?

La solution:
- Éditer le fichier wpml-config.xml que se trouve dans la racine de votre thème.
- Changez la ligne :

<custom-field action="copy">quode_title-image</custom-field>

Par :

<custom-field action="translate">quode_title-image</custom-field>

- Sauvegardez le fichier.

Documentation:
https://wpml.org/documentation/support/language-configuration-files/

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 2.09 hours from now. Thank you for your understanding.

This topic contains 3 réponses, has 2 participants.

Last updated by Andrés il y a 2 ans et 6 mois.

Assigned support staff: Andrés.

Auteur Messages
janvier 8, 2018 à 3:41 #1476620

genevieveC-3

Je tente de : dans mon thème j'ai l'option d'avoir une image pour le titre de la page. Auparavant, je pouvais avoir une image différente en anglais et français. Récemment nous ne sommes plus en mesure d'avoir une image différente. Celle en français écrase l'option en anglais. Nous utilisons le thème Bridge. Lorsque je veux modifier les traductions personnalisés pour ne pas copier ce contenu spécifique du francais vers l'anglais, l'option n'est pas disponible. C'est fixe à copier. Comment modifier pour mettre à ne pas traduire? J'imagine que cela règlerait mon problème.

URL de (mon) site Internet où le problème apparaît : goldenheartwisdom.com

Je m'attendais à voir :

À la place, j'ai obtenu :

janvier 9, 2018 à 6:34 #1477323

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

D'après votre information, votre thème a changé la manière comme gère ce champ personnalisé depuis le fichier wpml-config.xml. Pour obtenir le comportement dont vous souhaitez :
- Éditer le fichier wpml-config.xml que se trouve dans la racine de votre thème.
- Changez la ligne :

<custom-fields>
...
   <custom-field action="copy">quode_title-image</custom-field>
...
</custom-fields>

Par :

<custom-fields>
...
   <custom-field action="translate">quode_title-image</custom-field>
...
</custom-fields>

- Sauvegardez le fichier.

Est-ce que cela résout votre problème ?

Documentation :
https://wpml.org/documentation/support/language-configuration-files/

Cordialement,
Andrés

janvier 9, 2018 à 9:50 #1478749

genevieveC-3

Bonjour,

Merci problème résolu!

janvier 10, 2018 à 6:52 #1478920

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Super ! 🙂
Bonne journée