Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 7 réponses, has 2 participants.

Last updated by Andrés Il y a 1 mois et 4 semaines.

Assigned support staff: Andrés.

Auteur Messages
mars 15, 2021 à 1:03 #8306415

jonathanL-23

Je tente de : Traduire des from "Gravity Form"

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : Cedar variety*

À la place, j'ai obtenu : Type de cèdre*

Bonjours,
J'ai essayé de traduire un form dans Gravity Form mais ça ne fonctionne pas.
- J'ai premièrement créé une "job de traduction" mais lorsque je clique sur "Appliqué" et/ou "enregistré" mes traductions ne sont pas enregistrés!
- J'ai ensuite essayé de faire les traductions via "String Translation" mais encore une fois, même si le string est traduit, les changements ne sont pas appliqués.

*Noter que je vide évidemment mon cache après chaque changement*

Screeshot.png
mars 15, 2021 à 7:02 #8307795

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

La manière recommandé pour traduire vos formulaires est à travers d'un job de traduction. Or, vérifios pour quoi vous n'arrivez pas à enregistrez la traduction de formulaires.

1. Pouvez-vous vérifier d'avoir marqué votre formulaire comme traduit au 100% ?

2. Lorsque vous allez enregistrez votre traduction, il existe une erreur JavaScript dans la console du navigateur ?

Cordialement,
Andrés

mars 15, 2021 à 6:27 #8314115

jonathanL-23

Bonjour,

Sur la photo en pièce jointe, vous remarquerez que je suis à 33% de progression pour la traduction.

Or, même lorsque je termine la traduction entière du document, que tout est coché "traduction complète" et que je suis à 100%, je clique sur "enregistrer et quitté" en lorsque je reviens à cette page, ma progression est encore à 33% et rien n'a été enregistré.

Je n'ai aucune erreur dans mon browser.

Capture d’écran, le 2021-03-15 à 14.24.22.png
mars 16, 2021 à 6:32 #8316965

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre retour.

Or, est-ce que si vous créez un nouveau formulaire cela fonctionne correctement ?

Si ce n'est pas le cas, est-ce que vous pouvez suivre cette procédure :
❌ Faites un backup complet de votre site ❌
- Allez à WPML > Assistance technique.
- Cliquez sur le lien de 'dépannage'.
- Cliquez sur le bouton 'Effacer le cache dans WPML’.
- Cliquez sur le bouton 'Supprimer les entrées fantômes des tableaux de traduction'.
- Cliquez sur le bouton 'Configurer les informations linguistiques’.
- Cliquez sur le bouton: Rectification du classement element_type
- Cliquez sur le bouton: Fix WPML tables collation.

Cordialement

mars 17, 2021 à 11:24 #8337551

jonathanL-23

Lorsque je créer un formulaire, tout fonctionne.
Ce qui ne fonctionne pas, c'est la traduction avec WPML !!!

Comme expliqué :

- J'ai premièrement créé une "job de traduction" mais lorsque je clique sur "Appliqué" et/ou "enregistré" mes traductions ne sont pas enregistrés!
- J'ai ensuite essayé de faire les traductions via "String Translation" mais encore une fois, même si le string est traduit, les changements ne sont pas appliqués.

mars 18, 2021 à 6:01 #8338631

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je suis désolé pour le malentendu. Comme j'ai fait mention, le but de créer un nouveau formulaire est d'essayer sa traduction. Cela nous dira si le problème est lié à vos ancien formulaires. L'avez-vous essayé ?

Aussi, pouvez-vous essayé les options de dépannage ?

mars 18, 2021 à 10:44 #8346805

jonathanL-23

Bonjour,

Oui, j'ai créé un nouveau form et c'est le même problème!
Ensuite, j'ai suivi les étapes et la procédure tel que suggéré, ça n'a pas fonctionné non plus.

Je me souvient très bien que dans le passé, je pouvais traduire Gravity Form grâce à la fonction "String Translation" et maintenant ça ne fonctionne pas : voir la photo en pièce jointe.

Auriez-vous d'autres suggestions pour régler mon problème ?

Capture d’écran, le 2021-03-17 à 20.52.51.png
mars 19, 2021 à 6:25 #8348857

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML et Gravity forms sont activé. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Essayez à marquet votre formulaire comme traduit au 100%.
- Si le problème disparaît, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement