Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 21 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 3 mois.

Assigned support staff: Andrés.

Auteur Messages
juin 25, 2018 à 6:26 #2431724

boulouS

Je tente de : traduire les photos de mes fiches produits

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : traduction fiche produit exemple : hidden link

À la place, j'ai obtenu :hidden link en anglais le visuel n'est pas changé

juin 25, 2018 à 6:57 #2431748

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous me dire la procédure que vous avez suivi pour avoir des images différents dans votre produit ?

2. Essayez-vous d'avoir des différents images par produit ?

3. Est-ce que le produit original a été créé avec la fonctionnalité de duplication de WooCommerce ?

4. Pouvez-vous aller à WPML > Settings > Tanslate posts and pages, et vérifier d'avoir sélectionner l'option:
- Media Translation
x Use the same featured image as set for the content in the original language

Cordialement,
Andrés

juin 25, 2018 à 7:24 #2431794

boulouS

Bonjour Andrès, le site fonctionnait très bien mais je dois faire des changements de photos sur certains produits. Certaines photos de catégories aussi. Bizarrement l'option traduction sur media translation n'était pas cochée je l'ai donc cochée et certaines traductions de photos se sont faites automatiquement. Pour les catégories y a t'il une autre option à cocher ?
Merci.
Cordt.

juin 25, 2018 à 7:33 #2431808

boulouS

Sur certains produits la photo ne s'est pas changé par exemple ici : hidden link la version anglaise n'a pas pris en compte le changement de photo (celle de la version française) : hidden link ?? je ne comprends pas pourquoi ?
Merci pour votre aide,
Sandra

juin 25, 2018 à 9:35 #2432169

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de vos commentaires, Sandra. Or, pour ces produits où le changement d'image n'as pas fonctionné :

1. Pouvez-vous enregistrer à nouveau votre produit original ?

2. Est-ce que le produit original a été créé avec la fonctionnalité de duplication de WooCommerce ?

Cordialement

juin 25, 2018 à 9:42 #2432181

boulouS

En fait il n'y a pas que sur ce produit, c'est l'image principale du produit. Rien ne change quand je mets à jour... j'ai fait beaucoup de changement de photos de produits hier sur le site français et je ne voudrais pas avoir à recommencer sous oublier que les nouvelles photos ne sont pas toujours prises en compte. Quand je vais dans Media translation que je veux mettre la photo à jour je ne peux rien sauvegarder ? sur ce produit par exemple hidden link la photo sur la partie anglaise n'est pas la bonne : hidden link

juin 25, 2018 à 10:35 #2432302

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je ne suis pas sure de comprendre :

1. Est-ce que ce problème n'arrive que sur un produit en particulier ?

2. Lorsque vous mettez à jour votre produit original, l'image de la traduction s'affiche correctement?

3. Finalement, si l'action antérieur résout le problème, cela veut dire que les images ne sont pas à jour car l'option Use the same featured image as set for the content in the original n'était pas marqué au moment de la mise à jour de vos produits.

Dans ce cas, vous pouvez essayer de :
- Allez à vos articles/pages/produits.
- Seléctionnez-les.
- Cliquer sur le menu déroulant des "Actions groupées".
- Séctionnez "Edit".
- Appliquer.
- Puis, sans avoir sélectionné aucune action, cliquer sur le bouton "Mettre à jour".

Cordialement

juin 25, 2018 à 12:02 #2432444

boulouS

Non sur plusieurs produits et je ne souhaite pas remettre toutes les photos intégrées hier... je vais essayer votre procédure.

juin 25, 2018 à 12:26 #2432508

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Il ne s'agit pas de remettre vos images à nouveau mais sauvegarder vos produits originaux car l'option Use the same featured image as set for the content in the original n'était pas marqué au moment des mises à jour.

Aussi, veuillez vérifier que l'option de vos produits que s'affiche sur la capture d'écran est coché.

Cordialement

juin 25, 2018 à 2:30 #2433026

boulouS

Je suis désolée cela ne change rien : ici le produit français avec la bonne photo : hidden link et là le produit anglais avec l'ancien visuel : hidden link et pourtant j'ai bien coché : Show the same featured image in translations

Merci pour votre aide,

Très cordialement.

juin 25, 2018 à 3:38 #2433140

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci Sandra.

1. D'après votre capture d'écran, la traduction du produit a besoin d'une mise à jour ( fleche arrondi ), pouvez-vous la faire ?

2. Aussi, une fois vous êtes sur l'écran de traduction de votre produit, vérifiez aussi que le titre de l'image n'est pas vide comme sur la capture d'écran.

Est-ce que cette fois il fonctionne ?

juin 25, 2018 à 4:05 #2433230

boulouS

Je viens de le faire cf ma pièce jointe mais cela ne change pas la photo !! :((

juin 26, 2018 à 6:11 #2434201

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Sandra,

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

juin 26, 2018 à 8:06 #2434480

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre aide, Sandra. Finalement j'ai pu reproduire cette situation.

Après une discussion avec nos développeurs, nous avons trouvé l'origine du boggue et il sera résolu dans la prochaine version de WPML.

Or, comme solution temporaire, vous pouvez ajouter la nouvelle image des vos traductions manuellement en changeant au éditeur native de WordPress :
- WooCommerce > WooCommerce Multilingual > Paramètres
- Éditeur de traduction WPML
x Écran de traitement de produit WooCommerce natif

Je vous tiens au courant des nouveautés, merci de votre comprehension.

Cordialement,
Andrés

Documentation:
https://wpml.org/fr/documentation-6/projets-connexes/woocommerce-multilingual-operez-des-sites-de-commerce-electronique-en-plusieurs-langues/

juin 26, 2018 à 8:39 #2434609

boulouS

Merci pour votre retour Andrès, c'est ennuyeux quand pensez vous que la prochaine mise à jour de WPML sera en place ? merci encore. Il faudra que je revienne alors au paramètre initial de WooCommerce Multilingual