Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Je veux traduire le header de mon thème Greenfarm.

La solution: - Allez à WPML > Traduction de chaînes - Cliquez sur le lien bleu en bas de page: "Traduire les textes dans les écrans d'admin »" - Cherchez les option de votre thème: "+greenfarm_opt". Sur ce menu, on peut trouver toutes les chaînes associés a votre admin du thème. - Cochez les cases pour toutes les chaînes d'intérêt. J'ai coché l'option "header_layout" ( capture d'écran 1). - Cliquez sur le bouton "Appliquer". - Retournez au WPML > Traduction de chaîne et traduisez la chaîne "Header" (votre header) par "Header - EN" (votre header en anglais)-

Documentation: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Mots-clés : 

This topic contains 16 réponses, has 2 participants.

Last updated by Andrés il y a 2 mois et 1 semaine.

Assigned support staff: Andrés.

Auteur Messages
août 3, 2019 à 9:21

perrineB-2

Je tente de : faire apparaitre le header et le footer dans la bonne langue.

URL de (mon) site Internet où le problème apparaît : bulbesdesafran.com

Je m'attendais à voir : le changement du header français vers sa traduction anglaise, idem pour le footer, lors du changement de langue (bouton) tout en bas.

À la place, j'ai obtenu : pas de changement de langue. Ça reste en français.

Il serait déjà intéressant de résoudre le problème du header. Pour info, il se nomme "Header 2" dans la liste du lien hidden link

août 5, 2019 à 5:09 #4337873

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

J'ai essayé de visiter votre site mais vos identifiants ne fonctionnent pas. Or, pouvez-vous me fournir plus d'information pour vous aider ?

1. Utilisez vous une extension pour la création de votre header ? Si oui, lequelle ?

2. S'il s'agit d'un template creé avec le WPBakery Page Builder, pouvez-vous le mettre à jour ver la version +6.0.5 ?
hidden link

Cordialement,
Andrés

août 5, 2019 à 6:55 #4338299

perrineB-2

Bonjour et merci beaucoup pour ces retours.
J'ai acheté le plugin WPBakery, il est mis à jour, mais le problème persiste. Je souhaite vous envoyer les codes admin mais je ne peux ni répondre à votre mail ni les mettre ici en public (de ce que j'ai compris, tous les membres voient les messages). Comment puis-je vous communiquer les codes? Merci.

août 5, 2019 à 12:36 #4340583

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre confirmation mais je voudrais mieux comprendre votre problème avant d'y accéder.

Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 256M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '256M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

Cordialement

août 5, 2019 à 1:48 #4341043

perrineB-2

Re,
la ligne vient d'être ajoutée sur le fichier wp-config.php
Merci,

août 5, 2019 à 1:52 #4341049

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

août 5, 2019 à 2:14 #4341223

perrineB-2

[removed]

admin:

août 5, 2019 à 2:16 #4341275

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Vous venez de publier vos identifiants. Je vous prie de le modifier immédiatement pour éviter tout risque de sécurité. Puis, s'il vous plaît, utilisez le formulaire fourni.

Vous avez aussi oublié d'ajouter des instructions pour reproduire votre problème.

août 5, 2019 à 2:31 #4341327

perrineB-2

re,
j'ai pourtant utilisé le lien Reply via Secure Form...
Quant à la façon de reproduire le souci, comme évoqué lors de la première description, le souci est actuellement déjà présent : il suffit de changer de langue via le drapeau anglais en bas pour constater que le header reste en anglais (il me semble qu'un terme est traduit automatiquement, mais les termes comme "téléphone" qui devrait être remplacé par "phone" ne bouge pas. Même chose pour le footer, ou là la différence est censée être plus flagrante car il y a davantage de texte. Il reste en français pareillement.
Je retente de communiquer les codes.

août 5, 2019 à 2:43 #4341357

perrineB-2

Désolée de vous solliciter à nouveau mais malgré mes recherches, ni via le bouton reçu par mail "reply via secure form" ni en rajoutant ici une réponse, je ne vois la possibilité d'avoir un formulaire sécurisé avec les codes à remplir. Je suis pourtant bien connectée à mon compte. Je vous remercie de m'aider, j'avoue ne voir aucun indice invitant à générer le formulaire en question...

août 5, 2019 à 4:10 #4341927

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Vous devez cocher les cases des conditions. Une fois vous les acceptez, vous allez accès au formulaire:
hidden link

Pouvez-vous essayer à nouveau ?

août 5, 2019 à 4:24
août 5, 2019 à 4:51 #4342053

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de vos identifiants.

D'un côté, j'ai constaté que votre WP Bakery Page Builder n'est pas à jour, vous utilisez toujours la version 5.5.4. D'un autre côté, comme je n'ai pas des instructions à suivre, je vais me concentrer sur la traduction de votre header.

Or, vous utilisez l'extension Greenfarm qui n'est pas dans notre liste de compatibilité. Cela n'implique pas forcément qu'il n'est pas compatible mais que notre équipe n'a pas effectué les tests correspondants.
https://wpml.org/documentation/theme-compatibility/

Après avoir investigué votre site, j'ai finalement trouvé que vous ajoutez votre header depuis le Theme options > Header > Header Layout. Cette option vous permet de choisir un header créé avec le WP Bakery Page Builder. Vous avez choisi le template "Header 2".
Aussi, une fois on va au Éditeur de Page (WP Bakery) > Templates, on peut voir que le Header a été traduit. Par

Or, pour faire que votre thème prendre en charge cette traduction :
- Allez à WPML > Traduction de chaînes
- Cliquez sur le lien bleu en bas de page: "Traduire les textes dans les écrans d'admin »"
- Cherchez les option de votre thème: "+greenfarm_opt".
Sur ce menu, on peut trouver toutes les chaînes associés a votre admin du thème.
- Cochez les cases pour toutes les chaînes d'intérêt. J'ai coché l'option "header_layout" ( capture d'écran 1).
- Cliquez sur le bouton "Appliquer".
- Je suis retourné au WPML > Traduction de chaîne et j'ai traduit la chaîne "Header 2" (votre header) par "Header 2 - EN" (votre header en anglais)-
Tout à l'air de fonctionner correctement.

Pouvez-vous le vérifier ?

Référence :
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

août 5, 2019 à 5:03 #4342165

perrineB-2

Re,
Je ne suis plus sur l'ordi mais je vérifie dès que possible. Je me suis également fait la remarque pour WPbakery : j'ai bien acheté le plugin, il est installé et reconnu, d'ailleurs on voit l'activation de la licence sur l'extension, mais malgré ça il est affiché qu'il faut la mettre à jour en activant la licence... Déjà activée. Je vais essayer de chercher davantage car je me doute que cela ne rentre pas dans votre SAV.

Ok pour vos retours, j'ai en effet noté que la zone du thème demandant quel header on veut propose un menu déroulant et affiche une sélection d'un header en l'occurrence initialement français, qui propose (dans templates) une traduction anglaise.
Je vais tenir compte de vos instructions de paramétrages supplémentaires et vous tiens au courant.
Avec mes sincères remerciements pour le temps que vous consacrez à ma requête.

Bonne soirée.

août 5, 2019 à 5:21 #4342199

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait ! J'attends votre retour.
Bonne soirée à vous aussi. 🙂