Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Le problème :
Je veux traduire les slides tu thème Caverta.

La solution:
- Allez à WPML > Configuration > Configuration XML personnalisée
- Ajoutez le code:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_caverta-child">
            <key name="0"/>
            <key name="mt_slides">
                <key name="0">
                    <key name="mt_slide_text"/></key>
                <key name="1">
                    <key name="mt_slide_text"/></key>
                <key name="2">
                    <key name="mt_slide_text"/></key>
            </key>
        </key>
    </admin-texts>
</wpml-config>

- Traduisez le slider.

Documentation:
https://wpml.org/documentation/support/language-configuration-files/#admin-texts

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 14 réponses, has 2 participants.

Last updated by josianeH il y a 8 months et 2 weeks.

Assigned support staff: Andrés.

Auteur Messages
décembre 23, 2019 à 2:12 #5185091

josianeH

Bonjour,
Je n'arrive pas à traduire les slider de mon site.
Ils se trouvent en français dans
Apparence
Général options
Home slider or video
Slider

Je vois mes trois slider avec les textes, mais je ne peux les traduire.

J'ai suivi les instructions : https://wpml.org/fr/forums/topic/je-ne-trouve-pas-comment-traduire-les-sliders-et-le-frontpage/
Cela m'a permit de traduire le bas de page, mais toujours pas les textes dans les sliders.

J'ai même tout coché pour mt_slides mais je ne trouve pas la possibilité d'afficher le texte des sliders. (sur la copie écran tout n'est pas coché, mais je l'ai fait après avoir fait la copie écran).

Merci pour votre aide.

décembre 23, 2019 à 3:45 #5185511

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Avez-vous vérifié si vos slides se trouvent dans le menu +mt_slides de votre capture d'écran ?

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Andrés

décembre 23, 2019 à 4:02 #5185613

josianeH

Bonjour,
Ah si. Je viens de les ajouter. Ils apparaissent bien dans les Chaînes.
Cela fonctionne pour le slider 1 et 3, et mon slider 2 que j'ai traduit et validé, reste en français...

décembre 23, 2019 à 4:36 #5185765

josianeH

J'ai même modifié le texte de mon slider 2 en français. Et il apparait toujours avec l'ancien texte dans l'ancienne version dans "Chaîne".
C'est bien modifié dans le front, mais à l'intérieur de "Chaîne" ancien texte en français et toujours pas traduit malgré ma traduction et sa validation.

décembre 23, 2019 à 5:10 #5185895

josianeH

La traduction apparaît bien dans le fichier admin_texts_theme_mods_caverta-child-en_US.mo

décembre 24, 2019 à 6:08 #5188351

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Pouvez-vous essayer de supprimer lxes chaînes problème qui restent dans le panneau de traduction. Puis, effacer votre slider problème (2), le recréer et traduire à nouveau.
Si cela ne fonctionne pas, pouvez-vous partager votre information de débogage ?

Cordialement

décembre 24, 2019 à 12:37 #5189587

josianeH

Bonjour,
J'ai supprimé, recréé, cela fait toujours la même chose.
J'ai regardé dans la base de données, dans le .mo, les textes sont bien traduits. Et ils n'apparaissent jamais traduits pour ce slider.
Je vous ai envoyé hier les informations de débogage.
Comme WPML ne fonctionne pas bien pour les sliders, j'ai mis un texte bateau qui peut être lui aussi bien en français qu'en anglais... ce n'est pas la solution que j'attendais, je suis vraiment déçue.
Cordialement

décembre 24, 2019 à 3:49 #5189893

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Je comprends votre sentiment, mais comme vous voyez, la traduction fonctionne sur 2 de 3 slides donc je pense que nous pouvons trouver une solution.

Par contre, votre thème Caverta n'est pas dans notre liste de compatibilité et le problème peut venir d'ici :
https://wpml.org/documentation/theme-compatibility/

S'il vous plaît, allez à WPML > String Translation et cliquez sur l'option :
x Auto register strings for translation
Est-ce que la situation change ?

Cordialement

décembre 24, 2019 à 4:06 #5189921

josianeH

Je ne veux pas vous embêter un soir de Noël....
Dans la version française, à quoi correspond "String translation " ?
Merci

décembre 24, 2019 à 4:09 #5189923

josianeH

Traductions de chaînes je pense...
Non, je ne vais pas le faire car je vois que cela est prévu pour les sites en construction.
Et je viens de mettre mon site en ligne.
Tant pis.
Merci

décembre 24, 2019 à 4:31 #5190055

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Cette test c'est fait pour identifier s'il s'agit du problème décrit ici :
https://wpml.org/errata/in-some-cases-some-strings-are-not-translating-properly/

J'attends vos résultats.

décembre 31, 2019 à 9:16 #5215203

josianeH

Bonjour,
J'ai fait tout cela. Supprimé, recréé, supprimé et fait les manipulations selon les instructions de votre lien.
Le problème persiste.
Cela ne fonctionne pas.
Ce slider reste toujours en version française.
La traduction est pourtant présente partout, dans l'interface WPML, dans la base de données, dans le admin_texts_theme_mods_caverta-child-en_US.mo
TOUT se traduit sauf celui-ci.

décembre 31, 2019 à 9:37 #5215249

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

décembre 31, 2019 à 5:57 #5216865

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Merci de vos identifiants. Or, il semble que votre thème a besoin d'un fichier wpml-config.xml.
- Je suis allé à WPML > Configuration > Configuration XML personnalisée
- Ajouté le code:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_caverta-child">
            <key name="0"/>
            <key name="mt_slides">
                <key name="0">
                    <key name="mt_slide_text"/></key>
                <key name="1">
                    <key name="mt_slide_text"/></key>
                <key name="2">
                    <key name="mt_slide_text"/></key>
            </key>
        </key>
    </admin-texts>
</wpml-config>

- Désormais, les traductions du slider fonctionnent correctement.
Pouvez-vous le vérifier ?

Documentation :
https://wpml.org/documentation/support/language-configuration-files/#admin-texts

janvier 1, 2020 à 8:31 #5218665

josianeH

Merci beaucoup Andrés,
Cela fonctionne.
Jamais je n'aurais pu trouver cela seule.
Merci à vous et je vous souhaite une excellente année 2020 !