Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Mots-clés : 

This topic contains 7 réponses, has 2 participants.

Last updated by Jamal il y a 1 mois et 2 semaines.

Assigned support staff: Jamal.

Auteur Messages
août 29, 2019 à 10:41 #4480293

romainB-17

Je tente activate strang translation

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : activation du plugin

À la place, j'ai obtenu :technical issue on the website

août 29, 2019 à 12:06 #4480649

romainB-17

Andrès, je ne suis pas sur de vous avoir bien donné l'accès à mon site. Dites moi ce dont vous avez besoin et je vous donnerais tous les accès nécessaires.

août 29, 2019 à 1:11 #4481215

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Je suis un nouveau assistant technique sur l'équipe française et je vais vous aider. Si vous voulez surtout être assisté par Andrès, je peux le lui demander. Entretemps, je vous prie de faire les manipulations suivantes pour nous adier à identifier l'origine de ce problème.

Je pense comprendre que votre site fontionnait bien sur localhost, mais après que vous l'ayez deployé en ligne, l'activation de String Translation pose un problème! Corrigez moi SVP si ce n'est pas le cas.

Généralement, pour investiguer ce genre de problème, nous devrons activer le déboggage PHP pour capturer toutes les erreurs PHP et la trace de leurs origine
https://wpml.org/fr/documentation-6/informations-pour-les-developpeurs/debogage-de-wpml/#activer-la-fonction-integree-de-debogage-dans-wordpress

Ensuite je vous prie de désactiver toutes les extensions non WPML et de réessayer l'activation de String Translation, pour savoir si c'est causé par un conflit de compatibilité avec une extension.
Si l'activation se termine correctement, allez sur WPML->Assistance Technique->Dépannage et "Recréer les tables de cache ST". Ensuite réactivez vos extensions.

J'ai aussi activé l'espace privé pour partager les accès, veuillez ajouter les accès FTP pour que je puisse récupérer le site en cas d'erreurs Fatales PHP. Veuillez aussi faire une sauvegarde votre base de données, pour pouvoir restaurer dans le cas extrème.

Cordialement,
Jamal
Assistance WPML

août 29, 2019 à 2:27 #4481735

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je parlais du déboggage PHP qui consiste à ajouter quelques lignes sur le fichier wp-config.php
https://wpml.org/fr/documentation-6/informations-pour-les-developpeurs/debogage-de-wpml/#activer-la-fonction-integree-de-debogage-dans-wordpress

Vous avez ajouter les informations de Débogage WPML, mais nous aurons besoin d'acitver le Déboggage PHP.
J'aurais pu le faire mais les accès FTP ne fonctionnent pas pour moi.
PS: J'ai rendu vos derniers messages privés pour des raisons de sécurité.

Cordialement,
Jamal

août 29, 2019 à 2:37 #4481789

romainB-17

Je viens de relire ce qu'il faut faire et la traduction vers le français n'est pas très claire. je ne suis pas sure d'avoir fait ce qu'il faut

août 29, 2019 à 3:35 #4482387

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

J'aurais pu modifié cela, mais je n'ai pas pu encore me connecter ni avec FTP ni avec sFTP.
Pourriez vérifier encore une fois les accès FTP.

Best regards,
Jamal

août 29, 2019 à 3:36 #4482437

romainB-17

Bon, il semble que j'ai trouvé. Le conflit était avec Yoast SEO et Yoast Multilingual.
Le fait d'avoir mis les lignes de debug display m'ont permis de m'en rendre compte et en supprimant tous les réglage de Yoast et en réinstallant ca semble fonctionner.

Merci pour l'aide

août 29, 2019 à 4:14 #4482581

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre retour. Je suis très heureux d'avoir pu aider. Si vous pensez que le problème est maintenant corrigé, je vous prie de marquer ce ticket comme résolu.

Best regards,
Jamal