Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

This topic contains 13 réponses, has 2 participants.

Last updated by Joel Il y a 3 semaines.

Assigned support staff: Max.

Auteur Messages
mars 19, 2021 à 3:24 #8352919

Joel

j'essaye en vain de traduire des grilles construites sous WPBackery qui exploitent des images, leur titre et légende. Et en version traduite (UK) les titres et légendes ne remontent pas traduites, alors qu'elles le sont...

mars 19, 2021 à 4:01 #8353131

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Vous vous êtes déconnecté, j'ai donc converti le chat en ticket. Veuillez confirmer si vous avez toujours un problème après avoir fait cela: apportez une petite modification à la page (ajoutez un caractère au titre) et vérifiez si vous êtes maintenant en mesure de traduire la grille?

mars 29, 2021 à 3:06 #8423771

Joel

Bonjour Max et dsl pour la déconnection, mais mon souci de traduction de grille perdure. En fait cette grille est utilisée pour affichée des images, leur titre et description, mais en version UK tout reste en FR...

mars 30, 2021 à 7:29 #8434271

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci! S'agit-il d'un module de l'extension "Ultimate Addons for WPBakery Page Builder"?

Si c'est le cas, il peut être un module personnalisé qui n'est pas compatible avec WPML. Nous avons une liste des modules WPBakery qui sont supportés ici:

https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

La procédure suggérée est de le rendre compatible, puis de le traduire à l'aide de l'éditeur de traduction.

Nous vous suggérons de contacter l'auteur de l'extension pour obtenir de l'aide à ce sujet. Voici nos guides à leur sujet:

https://wpml.org/documentation/support/language-configuration-files/how-to-register-page-builder-widgets-for-translation/

avril 2, 2021 à 1:38 #8455251

Joel

Bonjour,
Je n'utilise pas de module personnalisé. J'utilise Masonry Media Grid avec un template je j'ai créé, mais le problème est le même si j'utilise un template générique de WPBackery comme Media Grid : Slide in title. Le titre et autre éléments des images restent en Français quelque soit la langue...
Avez-vous une idée d'ou peu provenir le problème ?
Bonne journée

avril 6, 2021 à 3:13 #8474857

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Ce problème peut survenir en raison de l'ancienne version de WPBakery Page Builder.

hidden link

S'il vous plaît:

1. Faites une sauvegarde complète du site (important).
2. Passez à la dernière version de WordPress (5.7) et de WPBakery Page Builder (6.6.0).
3. Désactivez temporairement les plugins de mise en cache (tels que WP Rocket).
3. Mettez à jour la page française et sa traduction, et vérifiez si le problème est toujours là.

avril 9, 2021 à 1:43 #8502539

Joel

Bonjour Max, WP et WPBackery sont tous les deux à jour (WP5.7 et WPBackery 6.6.0). La page Française à été mise à jour ainsi que sa traduction et rien n'y fait, le problème est toujours là...
cf hidden link
vs hidden link
C'est incompréhensible

avril 9, 2021 à 7:34 #8504367

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci! Afin de mieux cerner le problème, je vais avoir besoin d'accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir. Toutes les infos sont privées: seulement vous et moi y auront accès.

Je pourrais avoir besoin de reproduire votre site localement. Pour cela, je devrai installer temporairement un plugin appelé "All-in-One WP Migration" sur votre site. Cela me permettra de créer une copie de votre site et de votre contenu. Une fois le problème résolu, je supprimerai le site local. Faites-moi savoir si cela vous convient.

Important: Avant de procéder, assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site! Vous pouvez utiliser une extension comme All-in-One WP Migration:
hidden link

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.

avril 14, 2021 à 8:02 #8538937

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci pour les infos d'accès! Je vois que les grilles sont maintenant traduites (voir ma capture d'écran). Avec-vous réglé le problème?

Screen Shot 2021-04-14 at 16.59.26.jpg
avril 15, 2021 à 8:27 #8542141

Joel

Non pas du tout. En fait je me rend compte que le contenu est traduit si on est connecté au BO. Il. faut faire les tests déconnecté :-p

avril 15, 2021 à 4:28 #8547481

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Si ça fonctionne correctement lorsque connecté, il s'agit d'un problème de mise en cache.

Veuillez désactiver temporairement les extensions comme WP Rocket, Anti-Malware Security and Brute-Force Firewall, All In One WP Security, etc. et essayez de nouveau.

avril 20, 2021 à 10:28 #8580117

Joel

Bonjour,
Ben justement, il n'y à plus de cache d'activé. Je teste la désactivation des plugins.

avril 23, 2021 à 7:44 #8607015

Joel

Bonjour,
Pour faire le point et pr information :
Il n'y a aucun cache sur ce site.
Les plugins ont tous été désativés , excepté WPML et WP-Backery
Et rien n'y a fait
J'ai donc revérifié le paramétrage WPML et ai vu qu'il y avait une option de Filtrage de langues pour les opérations AJAX. Je l'ai activé.
Le problème est maintenant résolu.
Bonne journée

avril 23, 2021 à 7:45 #8607023

Joel

My issue is resolved now. Thank you!