Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Mots-clés : 

This topic contains 13 réponses, has 2 participants.

Last updated by Andrés il y a 4 semaines.

Assigned support staff: Andrés.

Auteur Messages
novembre 11, 2019 à 3:51

myleneG

Je tente de :
Régler les liens dans mon méga-menu du côté anglais.

Exemple avec la catégorie robotics sous "Tech & Math":
1. Toutes les images fonctionnent bien.
2. Les liens des textes: Lorsque je sauvegarde le lien "hidden link" celui-ci change automatiquement pour "hidden link". Le problème est que lorsque qu'on clique sur ce dernier, on est amené vers le français.
Donc, tous mes liens texte de ce menu sont défectueux.
Merci de votre aide
nb. l'accès du site fourni est une copie du site principal

novembre 11, 2019 à 6:37 #4922095

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et pour l'instant, je n'arrive pas à trouver comment a été créé votre mega menu principal ou l'extension dont vous avez utilisé pour le même. Pouvez-vous l'indiquer étape par étape ?

Par contre, j'ai remarqué que dans la traduction de votre menus, certain liens point correctement vers le répertoire /en/. Pouvez-vous vérifier si vous catégories ont été traduites ?

Cordialement,
Andrés

novembre 11, 2019 à 4:17 #4926567

myleneG

Bonjour, dsl j'auraiss dû vous l'indiquer, il faut cliquer dans la section Static blocks tout en haut du menu. Même si je mets l'url au long, après la sauvegarde, ça revient à l'utre url. Et oui, mais catégories sont traduites(sauf les livres qui sont qu'en francais et pas dans le menu anglais), merci

novembre 11, 2019 à 4:51 #4926747

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Si je comprends votre configuration, vous n'utilisez pas des menus mais une extension (?) pour créer des blocs de contenu. Par contre, vous n'avez pas marqués ces blocs de contenu comme "Traduire" et j'ignore comme vous avez traduit les étiquettes du même ou dans quel moment le liens dont vous ajoutez revenez au état initial.

Pouvez-vous m'indiquer étape par étape :
- Comment a été créé le menu problème.
- Comme a été traduit.
- Comme vous avez ajouté cette section dans votre menu.
- Le nom de l'extension dont vous utilisez.

Cordialement

novembre 11, 2019 à 5:04 #4926783

myleneG

Il y a 4 blocs de contenu en anglais et 4 en français, donc pas de traduction et j'ai vérifié ces blocs ne se retrouvent pas dans mes chaînes à traduire. comme vous voyez dans l'image, ces 4 static blocks sont dans un menu appelé orange (apparence).

L'extension venait avec le thème mais eux me disent que ceci est de votre ressort car peu importe si on change le thème, le problème demeure.
Donc, en bref, ce n'Est vraiemnt qu'une question d'empêcher la redirection vers le français des liens de catégorie et ceci, bizarrement, ne sse produit que pour les blocs de texte, les liens des images du menu ne changent pas automatiquement, merci

novembre 12, 2019 à 7:09 #4929215

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Votre thème Electro n'est pas dans notre liste de compatibilité. Cela n'implique pas forcément qu'il n'est pas compatible mais que notre équipe n'a pas effectué les tests correspondants.
https://wpml.org/documentation/theme-compatibility/

Or, merci de votre information mais en étant que votre thème n'est pas compatible et que je ne suis pas habitué au même, j'ai besoin de votre aide et plus d'information.

- Je suis allé au Bureau > Static Content.
- Édité le menu "Menu Tech & Math".
- Édité manuellement le lien du texte "Robotics" par:
x hidden link
Et tout semble de fonctionne correctement.

Pouvez-vous m'indiquer étape par étape comme reproduire votre problème, voire, ajouter une vidéo ?

novembre 13, 2019 à 2:53 #4935525

myleneG

Merci de votre patience, j'apprécie votre aide. Je vois que vous avez réussi, je me suis donc assurée que toutes les extensions étaient les mêmes et réessayer, en vain. Je ne comprends pas pkoi j'ai ce bug... voici un lien Youtube pour que vous me croyez, mais je ne suis plus quoi faire, pourtant ma copie de site est récente et devrais agir de la même façon?????? Tout un mystère! hidden link

novembre 13, 2019 à 7:15 #4936051

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci d'avoir partagé votre vidéo. La seul différence pour l'instant est que j'ai utilisé l'éditeur du WP Bakery Page Builder à la place de modifier directement le shortcode. Pouvez-vous essayer cette méthode ?

Cordialement

novembre 13, 2019 à 1:52 #4939685

myleneG

je l'avais aussi essayé et plusieurs autres choses, je suis ???

novembre 13, 2019 à 2:09 #4939869

myleneG

j'ai réussi à changer le lien de robotics sur le site Live mais même si je le clique, ça revient en français?

novembre 13, 2019 à 2:10 #4939875

myleneG

... et j'aio remarqué que ceci arrive même avec une page, par exemple, dans le menu teachers, le premier lien mène à une page, le id est le bon pour l'anglais mais toujours redirigé vers le français?

novembre 13, 2019 à 2:23 #4940031

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Pour l'instant je n'arrive pas à reproduire cette situation. Est-ce que si vous désactivez l'extension "WPML Sticky Links", vous arrivez à changes vos liens ?

novembre 13, 2019 à 2:38 #4940313

myleneG

Je peux maintenant changer les liens mais je me demande quel est le côté négatif de cette solution?

novembre 13, 2019 à 3:03 #4940529

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Si vous n'utilisez pas vraiment cette extension, vous pouvez la désactiver et supprimez de votre site.

Cordialement