Sauter la navigation

Ce sujet est résolu. Voici une description du problème et de la solution.

Problem:
user want to change the slug of the translated page
Solution:
user is using Yoast sea so suggesting to change the slug from there is a solution
https://monosnap.com/file/GPpTiu6FgMTOL4RbxfG2YzYWJn5cXr
Relevant Documentation:

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Marqué : 

Ce sujet contient 7 réponses, a 2 voix.

Dernière mise à jour par romainO-2 Il y a 1 an et 8 mois.

Assisté par: Johan.

Auteur Articles
Septembre 29, 2022 à 2:04 pm #12150213

romainO-2

Ah ok, je ne savais pas. Merci.
Je suis obligé de faire une recherche dans la source pour afficher ces liens ? Comment se fait-il que je ne les vois pas dans la liste des champs à traduire ?

Septembre 29, 2022 à 2:05 pm #12150215

Johan

Je viens de changer de ticket car il s'agit d'un autre sujet, mes réponses :

=> Je suis obligé de faire une recherche dans la source pour afficher ces liens ? Comment se fait-il que je ne les vois pas dans la liste des champs à traduire ?

Oui.

=> Pour l'URL de la page, ca depend si vous avez cocher l'option pour les afficher dans l'outil de traduction ou pas. C'est à dire soit vous les touchez pas et il prendront le nom de la page dans la secondes langue.

Exemple :
titre de la page : accueil
en anglais : vous allez traduire home page

Donc url par default ca sera home-page, ca sera automatique.
Si vous voulez les modifier, voici un guide qui vous explique comment faire : https://wpml.org/documentation/getting-started-guide/translating-page-slugs/

lien caché

Septembre 29, 2022 à 2:17 pm #12150383

romainO-2

Merci pour votre réponse.

J'ai activé la traduction des slug. J'ai pu en traduire un dans string translation mais l'url de la page en question apparait toujours comme ceci : lien caché

Capture d’écran 2022-09-29 à 16.15.06.png
Septembre 30, 2022 à 5:17 am #12153857

romainO-2

Je l'ai traduit manuellement. Mais voici une autre page avec le même problème : lien caché

Je ne sais pas si c'est la bonne chaine à traduire mais c'est la seule qui sort.

Septembre 30, 2022 à 9:49 am #12156031

romainO-2

Bizarrement, je n'arrive même plus à traduire ces URL manuellement : lien caché

octobre 2, 2022 à 8:20 am #12163617

Johan

Bonjour,

Je regarde, un instant.

Johann

octobre 2, 2022 à 8:27 am #12163651

Johan

Si je comprends bien vous souhaitez changer manuellement le slug de la page "About us" en anglais c'est ca?

Je viens de voir que vous utilisez Yoast SEO pour les url, est-ce que vous pouvez essayer de le changer directement dans le champs prévu ? Voir image lien caché

octobre 3, 2022 à 7:17 am #12167697

romainO-2

ok ça fonctionne avec Yoast, merci !

Ce ticket est maintenant fermé. Si vous êtes un client de WPML et que vous avez besoin d'aide, veuillez ouvrir un nouveau ticket d'assistance