Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 5 réponses, has 2 participants.

Last updated by Andrés il y a 2 years et 7 months.

Assigned support staff: Andrés.

Auteur Messages
janvier 19, 2018 à 7:18 #1490328

herveH-2

je travaille en localhost.
Voici ce que j'ai écrit ci-dessous à l'éditeur du thème qui me recommande de vous solliciter :
I had upload the string called « admin_texts_theme_mods_sohohotel »

And found the two lines below, so no problem as they fit with the boxes to fill in the theme option in french and in english. I had just to add the translation in english of the french sentences add through the theme options fields.

« [theme_mods_sohohotel][sohohotel_data]payment_success_message » and « [theme_mods_sohohotel][sohohotel_data]booking_success_message »

But It seams that there is no link with the pages concerned.

I’m wondering if it’s not due to the other string translation : « admin_texts_sohohotel_data » in which they are also the same two lines

« [sohohotel_data] payment success message » and «[sohohotel_data] booking success message »

But these are the same sentences included in the sohohotel_booking.pot file.

So the english version is the native one and in the french translation field I have add my text with my bank details.

So to say the truth I feel a bit lost at this time

Je m'attendais à voir : la version anglaise du message, mais elle apparaît en français dans la version anglaise du site. voir l'image jointe.

Merci pour vos éclairages

janvier 20, 2018 à 5:09 #1490782

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Je ne suis pas sur de comprendre votre problématique, mais si vous souhaitez traduire vos options de thème :
- Allez dans "WPML -> Localisation des thèmes et des extensions".
- Assurez-vous que " Traduire les thèmes et plugins uniquement à l'aide de la Traduction de chaîne WPML (ne pas charger les fichiers .mo)" est actif.
- Descendez vers la section "Chaînes du thème" et cliquez sur "Analyser les chaînes du thème".
- Une fois que vous avez suivi les étapes précédentes, allez dans WPML > Traduction des chaînes. Toutes les chaînes de caractères disponibles à la traduction devraient être là. Vous pouvez effectuer une recherche par mot/expression ou par contexte.

Est-ce que vous voyez la chaîne d’intérêt ? Si oui, cliquez sur le lien "traduction" et traduisez-la.

Documentation:
https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/string-translation/

2. Pouvez-vous mettre à jour tout votre paquet WPML ?

3. Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 256M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '256M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

Cordialement,
Andrés

janvier 29, 2018 à 8:17 #1499662

herveH-2

Bonjour,
Mon problème n'est pas encore résolu, car je travaillais en localhost. Je suppose que c'est la raison pour laquelle j'observe des disfonctionnements sans en avoir la certitude. J'ai donc décidé de transférer mes fichiers sur le serveur d'hébergement et vous tiens au courant ensuite.

Cordialement,

janvier 29, 2018 à 8:44 #1499701

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Si le problème persiste, n'hésitez à suivre les antérieurs instructions.

Cordialement

janvier 31, 2018 à 8:05 #1502426

herveH-2

Bonjour,
Je suis passée de localhost à l'hébergement en ligne.
J'ai augmenté dans le fichier default-constants.php la valeur de la mémoire comme suit :

en remplaçant 64 par 256 et 40 par 128

ainsi cette erreur est résolue.

Mais une autre apparaît :

2018-01-31 07:24:384081 index wp_error wpml-config/config-index.json
code: http_request_failed
message: cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Merci pour votre retour

Cordialement,

Marie-Elisabeth TAKACS

janvier 31, 2018 à 8:15 #1502436

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Marie-Elisabeth,

Je suis ravi de savoir que votre problème initial a été résolu. Par contre, par normes du support nous ne pouvons pas traiter des différents sujets sur un même ticket. Cela nous permet de vous donner un meilleur service et aux autres utilisateurs d'accéder à l'information ici exposé. Je dois vous demander d'ouvrir un autre pour nous concentrer sur cette nouvelle situation, vous pouvez me l'assigner directement et nous pouvons continuer à travailler ensemble sur ce sujet immédiatement.

Cordialement,
Andrés