Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : J'ai depuis quelques temps un message d'erreur en haut de page suite à une mise à jour wordpress. Malgré tout, le site fonctionne sans problème. "There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you."

La solution: Si vous n'avez pas des erreurs liés à WPML dans votre information de débogage : - Faites un backup de votre base de données. - Ouvrez la table wp_options. - Cherchez la ligne avec l'option_name "wpml_string_table_ok_for_mo_import". - Changez sa valeur "No" vers "Yes".

Mots-clés : 

This topic contains 5 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 5 mois.

Assigned support staff: Andrés.

Auteur Messages
mai 16, 2018 à 2:17 #2159490

frankR-13

Bonjour,

J'ai depuis quelques temps un message d'erreur en haut de page suite à une mise à jour wordpress. Malgré tout, le site fonctionne sans problème.

"There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you."

Je suis actuellement sur WordPress 4.9.5 hébergé chez OVH en mutualisé avec le thème the7. (tout mes plugins sont également mis à jours en permanence)

En cherchant sur le forum de WPML, je suis tombé sur le fait de fait une recherche et modif de wp-config.php:
define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Voici donc le résultats:
[16-May-2018 14:00:18 UTC] PHP Notice: Constant WP_MEMORY_LIMIT already defined in /home/.../.../wp-config.php on line 90

Et à la ligne 90 du wp-config.php j'ai:
define( 'WP_MEMORY_LIMIT', '128M' );

Je suppose que je dois modifier cette valeur ?
Quelle est la limite ?
En changeant cette valeur, l'erreur va t'elle partir du haut de page ?
Est ce que le fait de modifier cette valeur à d'autre impact sur le site ? (comme la rapidité ou autre...?)
Dois-je également m'orienter sur un plugin de nettoyage de cache pour wordpress ?

Merci d'avance.

Cordialement,

Guillaume

mai 16, 2018 à 3:28 #2160384

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Guillaume,

Bienvenue à l'assistance technique de WPML.

Il semble que cette alerte n'est pas affiché à l'erreur que s'affiche dans votre information de débogage de WordPress n'est pas lié aux erreurs de la base de données, il s'agit donc, d'un false positive.

Or, pour le résoudre :
- Faites un backup de votre base de données.
- Ouvrez la table wp_options.
- Cherchez la ligne avec l'option_name "wpml_string_table_ok_for_mo_import".
- Changez sa valeur "No" vers "Yes".
Est-ce que l'alerte disparaît ?

Cordialement,
Andrés

mai 20, 2018 à 3:24 #2197196

frankR-13

Bonjour André,

Merci beaucoup pour votre réponse.

Suite à cette modification, je vous confirme que l'erreur à disparue !!!

Puis-je laisser l'option sur YES ? Cela ne posera pas de complication ?

Merci encore.

Bien à vous.

mai 20, 2018 à 4:58 #2197285

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je suis ravi de savoir que ce problème a été résolut, Guillaume. 🙂
En effet, il s'agit d'un faux-positive et vous pouvez laisser ce champs comme "Yes".

N'hésitez pas à ouvrir un autre ticket si vous avez besoin d'aide.
Cordialement,
Andrés

mai 20, 2018 à 5:52 #2197370

frankR-13

C'est parfait, :p
Merci infiniment Andrés pour votre rapidité et votre professionnalisme. 😉
Cordialement,
Guillaume

mai 20, 2018 à 6:10 #2197492

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait, Guillaume ! 🙂
Je vous souhaite une belle soirée.