Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 6 réponses, has 2 participants.

Last updated by Jamal il y a 4 jours et 12 heures.

Assigned support staff: Jamal.

Auteur Messages
juillet 24, 2019 à 9:12 #4272055

benoitF-4

Bonjour Jamal merci pour votre réponse.

D'accord donc je pense que c'est sois le "auto commit" ou les "time out". En tout cas le principal c'est que cela fonctionne !

Maintenant, lors de ce ticket nous avons vu un autre problème qui reviens souvent : les endpoints en espagnols !
A chaque fois que je traduits mes enpoints, pas de soucis pour le français et l'anglais, mais si je les traduits en espagnols cela ne fonctionne pas : erreur 404.

Donc j'annule la traduction espagnol pour la laisser en anglais ce qui donne : hidden link

mais je souhaiterais : hidden link

juillet 24, 2019 à 9:25 #4272431

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Ce ticket est maintenant escaladé à l'équipe de compatibilité pour gérer ce conflit avec YITH WooCommerce Pending Order Survey Premium.

Je reviens vers vous dés que possible.

Cordialement,
Jamal

septembre 4, 2019 à 2:26 #4512009

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Pour le plugin en question "WooCommerce Pending Order Survey Premium" le problème est maintenant fixé avec la dernière version du plugin 1.0.12.
J'ai pu accéder à la page /mi-cuenta/editar-cuenta/ sans aucun problème.
Si vous voulez tester cela, je vous prie de désactiver les autres plugins qui pose toujours ce problème, supprimer les strings des enpoints woocommerce sur String Translation, visitez la page sur la langue principale pour faire enregistrer les urls, puis traduisez les et tester.

Je reste à votre disposition.

Cordialement,
Jamal

septembre 16, 2019 à 9:44 #4578029

benoitF-4

Bonjour, désolé pour le retard j'étais en vacances.
Lorsque je vais sur hidden link
Cela ne fonctionne pas.

Pour le site "developpement.natureetpartage.fr" c'est la version Englaise des liens qui pose problème, pour mon site officiel c'est la version espagnole.

Cordialement

septembre 16, 2019 à 1:27 #4580741

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je vous prie de supprimer la chaine "edit-account" depuis WPML->String Translation. Et désactiver toutes les autres extensions pour vérifier si ce n'est pas causé par une autre extension.

Cordialement,
Jamal

septembre 17, 2019 à 10:24 #4587667

benoitF-4

Bonjour Jamal, j'ai tenté vos solutions : sans succès.

TOUS les plugins de Yith sont désactivés !
Je me suis procuré un outil pour filmer mon écran, ce sera plus simple pour vous montrer le bug : hidden link
Ici on constate que lorsqu'on traduit l'endpoint "modifier-compte" en anglais et espagnol, la page s'affiche correctement en espagnol et mal en anglais.

septembre 17, 2019 à 10:38 #4587753

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour la vidéo, je vois très bien de quoi il s'agit.
Vous n'avez utilisé que les extensions WPML(beta), WooCommerce et Salient. Confirmez vous bien cela?
Je pense donc qu'il s'agit donc d'un autre problème que celui causé par l'extension "YITH WooCommerce Pending Order Survey Premium".

Soit c'est un problème causé par les extensions WPML(beta), ou par les extensions Salient ou bien le thème.

Dans ce cas, je suggère de gérer cela dans un autre ticket et de laisser ce ticket pour traiter le conflit avec "YITH WooCommerce Pending Order Survey Premium".

Qu'en dites vous? Si oui, je vous prie de charger votre thème sur le serveur suivant, installer juste les extensions Salient et vérifier si le problème surgit avec les versions Stables de WPML(qui sont déjà installé).
Ensuite, je vais installer les versions Beta et voir si le problème est généré par les versions Beta.
hidden link

Merci,
Jamal