Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 5 réponses, has 2 participants.

Last updated by Jamal il y a 5 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
avril 19, 2019 à 12:43 #3645777

morganC-4

Je tente de : Charger une page avec un produit traduit

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : La page produit

À la place, j'ai obtenu : Error 500

avril 19, 2019 à 12:47 #3645783

morganC-4

I have desactivated WooCommerce Multilingual on the website, so product pages are display now but without all the translation.

avril 19, 2019 à 1:14 #3645921

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Je viens de faire un test sur une nouvelle installation et je ne rencontre pas de soucis parreils.
Pourriez vous remettre la version précedente de WooCommerce Multilingual 4.5. Et vérifier si elle présente cette issue.
https://wpml.org/fr/download/woocommerce-multilingual/?section=changelog

Pourriez vous aussi activer le debugging PHP et partager le contenu du fichier debug.log avec moi.
https://codex.wordpress.org/fr:D%C3%A9bogage_dans_WordPress#Exemple_de_wp-config.php_pour_le_d.C3.A9bogage

Je reste à votre disposition.

Cordialement,
Jamal
Assistance WPML

avril 19, 2019 à 1:33 #3646107

morganC-4

Bonjour Jamal et merci pour votre rapide réponse.
J'ai activé le debug.log hidden link

J'ai installé le plugin en version 4.5 et j'ai toujours le même problème.
J'ai tenté d'utiliser l'assistance dans le plugin "Fix translated variations relationships" après avoir activé cette option le site fonctionne normalement puis quelques secondes après ce réglage se réinitialise.

Il passe de "Fix translated variations relationships 895 restant" à "Fix translated variations relationships 0 restant"
puis de nouveau à "Fix translated variations relationships 895 restant".

Merci pour votre aide.

avril 19, 2019 à 1:41 #3646135

morganC-4

Je vois juste ce message d'erreur pour ce plugin :
[19-Apr-2019 13:36:53 UTC] PHP Fatal error: Maximum execution time of 300 seconds exceeded in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-products.php on line 677

avril 19, 2019 à 2:02 #3646265

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Du moment que le problème survient aussi sur la version 4.5, je dirais que c'est un problème causé par le changement réalisé sur WooCommerce 3.6 ou 3.6.1.
Alors je vous prie de mettre à jour WCML à la version 4.6 et nous trouverons ensemble une solution.

Concernant votre dernier message, le script s'arrète de s'éxecuter après atteindre la limite temps de 300secondes. Voudriez vous désactiver la limite en ajoutant la ligne suivante au début du fichier wp-config.php après "<?" comme ça:


<?php
set_time_limit(0);

En consulant les erreurs sur le debug.log, je pense aussi que les actions de dépannage sur WPML->Assistance Technique->Dépannage, section nettoyage/cleanup) pourront corriger cette erreur.
Veuillez faire une sauvegarde de base de données avant de procéder.

Je reste à votre disposition.

Cordialement,
Jamal

Le sujet ‘[Fermé] WooCommerce Multilingual 4.6.0 made error 500 with WooCommerce 3.6.1’ est fermé à de nouvelles réponses.