Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Our next available supporter will start replying to tickets in about 3.30 hours from now. Thank you for your understanding.

This topic contains 25 réponses, has 3 participants.

Last updated by martinG-66 Il y a 2 semaines et 6 jours.

Assigned support staff: Max.

Auteur Messages
août 18, 2021 à 4:08 #9420185

martinG-66

Selon Automattic le problème que nous avons avec WooCommerce Payments viens de votre plugin... voir leur courriel ci-dessous:

Bill (Automattic)

Aug 3, 2021, 19:14 UTC

Hey there,

Thank you for your patience while we've been looking at this odd situation. While I was on the overview page, I noticed an error in the developer's console.

error
(Link to screenshot: hidden link)

WooCommerce Payments uses JavaScript to load some of the content on this page. It does that through the WordPress REST API. This particular REST API "endpoint" is giving us a 404 "not found" error.

hidden link
I compared that to the same "endpoint" on my test site and it's almost identical.

hidden link
The difference is the /en/ that's placed right after the domain name. What I found is when I load this URL into my browser, it'll give me a 401 error which means I'm not authorized to access that. This is the correct error message for that URL when it's opened in a browser window.

hidden link

If I add /en/ to that URL, I'll get a 404 error on my site too.

My suspicion is that the REST API URLs are being changed by WPML and that is breaking WooCommerce Payments. You could try temporarily disabling WPML and see if this works correctly. When you load the overview page, open up the developer's console and see if there are any 404 errors.

Developer Console
(Link to screenshot: hidden link)

If it works with WMPL you may want to reach out to them and see if there is a way to prevent this URL from adding the /en to it.

Let us know what you find out and we'll go from there.

Thanks!

Bill
Happiness Engineer at WooCommerce | Automattic

Simplify the payment process for you and your customers with WooCommerce Payments – now available in the U.S., Canada, UK, Ireland, Australia, and New Zealand.

août 18, 2021 à 4:41 #9420519

martinG-66

Il dise que c'est a cause du /en/ suite au domaine

... voici ma configuration >>> hidden link

août 18, 2021 à 7:03 #9421109

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Pouvez-vous aller à vos Settings > Permalinks (Réglages > Permaliens) et cliquer sur "Enregistrer les modifications"? Vous n'avez rien à modifier, simplement sauvegarder.

Si ça change rien, pourriez-vous désactiver l'option "use directory for default language", ensuite essayer de nouveau?

Veuillez me communiquer le résultat.

août 19, 2021 à 12:47 #9421713

martinG-66

1) Le problème se règle quand je désactive l'option "use directory for default language"
2) Mais j'ai besoin que chaque langue soit identifier différemment dans l'adresse pour que la prise en charge des langues par les navigateur fonctionne... si mon domaine en anglais n'a pas (/en) sa donne que quand une personne en France vient sur mon site elle va entré dans la langue de son navigateur le français mais si elle veut changer vers une autre langue manuellement sa reviens toujours a français c'est pas ca que je veux des /en, /fr, /de, etc.
3) si vous avez une autre solution je suis ouvert... en.wiibizz.com, fr.wiibizz.com

août 19, 2021 à 10:56 #9424651

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Afin de mieux cerner le problème, je vais avoir besoin d'accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir. Toutes les infos sont privées: seulement vous et moi y auront accès.

Je pourrais avoir besoin de reproduire votre site localement. Pour cela, je devrai installer temporairement un plugin appelé "All-in-One WP Migration" sur votre site. Cela me permettra de créer une copie de votre site et de votre contenu. Une fois le problème résolu, je supprimerai le site local. Faites-moi savoir si cela vous convient.

Important: Avant de procéder, assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site! Vous pouvez utiliser une extension comme All-in-One WP Migration:
hidden link

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.

août 19, 2021 à 8:49 #9427769

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci! Je vois qu'il manque le nom d'une page HTML dans la configuration dans WPML > Languages > Language URL format (voir la capture d'écran). Ce champ est obligatoire pour que cette option fonctionne, il ne peut pas être laissé vide. Vous pouvez aussi le changer pour l'option "A page".

Plus d'info: https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/

Veuillez corriger la configuration et me faire savoir si par la suite l'extension WooCommerce Payments commence à fonctionner correctement.

Screen Shot 2021-08-19 at 17.44.51.jpg
août 20, 2021 à 7:12 #9429755

martinG-66

J'ai ajouter la page HTML... Mais l'extension WooCommerce Payments ne fonctionne toujours pas correctement. !!??

août 20, 2021 à 4:07 #9431865

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci. J'espérais que cela résoudrait le problème, car cela affecte les URL du site.

Pourriez-vous reproduire ce comportement sur le site de test ici:

hidden link

WPML et WooCommerce Payments sont déjà installées et activées, je croix qu'il faut configurer WooCommerce Payments pour que sa page des paramètres avec une erreur puisse être visualisée.

août 20, 2021 à 4:27 #9431911

martinG-66

Le problème c'est que WooCommerce Payments me laisse pas faire une autre configuration car il me dit que les informations son déjà utilisé... c'est lier à nos compte bancaire et d'incorporation de la société.... mais vous pouvez utiliser directement notre site nous avons un back up.

août 21, 2021 à 5:48 #9435385

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Ok, merci. Je vais faire mon mieux pour reproduire ce problème en dehors de votre site, soit localement, soit sur le serveur de notre partenaire sous Cloudways. Dès que j'aurai plus de nouvelles, je répondrai ici.

août 21, 2021 à 11:51 #9435623

martinG-66

Ok... Merci MAX!

août 24, 2021 à 1:02 #9450535

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Finalement j'ai envoyé la question à nos développeurs du support de deuxième niveau. Dès que j'aurai plus d'informations, je répondrai ici.

août 24, 2021 à 2:25 #9451439

martinG-66

Merci MAX!

J'attend de vos nouvelles et je reste à votre disposition.

août 24, 2021 à 4:26 #9452237

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Merci! C'est maintenant transféré à l'équipe des nos développeurs.

août 26, 2021 à 3:27 #9465753

Max
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Nos développeurs ont trouvé une solution de contournement temporaire, j'ai inséré ce code dans le fichier functions.php du thème actif et cela fonctionne:

if (
	isset( $_GET['page'], $_GET['path'] )
	&& 'wc-admin' === $_GET['page']
	&& '/payments/overview' === $_GET['path']
) {
	add_filter( 'rest_url', function( $url ) {
		return str_replace( '/en/wp-json/', '/wp-json/', $url );
	} );
}

Maintenant la demande à /wp-json/wc/v3/payments/deposits/overview-all?_locale=user a le statut 200 (voir ma capture d'écran).

Ce n'est pas une solution permanente, mais cela devrait suffire pour progresser pour le moment.

Screen Shot 2021-08-26 at 12.18.41.jpg