Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 0.82 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Nous utilisons WP All import pour importer nos produits. Jusqu'ici tout se passait bien. Mais lors de la dernière importation les produits importés ne sont visible que par l'admin.

La solution: - Mettez à jour tout votre paquet WPML.

Documentation: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

This topic contains 14 réponses, has 2 participants.

Last updated by emmanuelM-8 il y a 1 mois et 2 semaines.

Assigned support staff: Andrés.

Auteur Messages
août 26, 2019 à 1:37 #4459259

emmanuelM-8

Bonjour,

Nous avons un site woocommerce en 2 langues (anglais + français). L'anglais est la langue principale.

Nous utilisons WP All import pour importer nos produits.

Jusqu'ici tout se passait bien. Mais lors de la dernière importation les produits importés ne sont visible que par l'admin.

J'ai "forcé" le statut public (Products/status) de chaque produit et cela fonctionne. Mais uniquement en anglais (langue principale). Comment faire la même chose pour la seconde langue ?

Merci

hidden link

août 26, 2019 à 1:53 #4459381

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à nouveau ! 🙂

Si vous souhaitez modifier l'état de vos produits dans des autres langues, s'il vous plaît, essayez le suivant :
- Allez au Bureau > Produits.
- Cliquez sur le sélecteur de langues que se trouve sur la barre supérieur et changez de langue.
- Ouvrez le produit d’intérêt.
- Modifier l'état.
Est-ce que cela fonctionne ?

Cordialement,
Andrés

août 26, 2019 à 2:12 #4459605

emmanuelM-8

Bonjour,

Merci pour votre retour.

Je ne peux pas éditer le produit dans la seconde langue. C'est la fenêtre de traduction qui s'affiche. Uniquement les champs de traduction. Pas d'accès à l'état.

Comment faire ? Je suis quasiment sûr que c'est le statut en FR qui pose problème.

Merci

août 26, 2019 à 2:23 #4459677

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre retour. 🙂

Je viens de essayer cette procédure dans mon site de test et cela fonctionne correctement. Par contre, si ce n'est pas toujours le cas pour vous, essayez de désactiver l'éditeur de WPML ( capture d'écran ) depuis le produit original, puis, modifier vos traductions.

Est-ce que cette fois il fonctionne ?

Cordialement

août 26, 2019 à 2:27 #4459719

emmanuelM-8

Je n'ai pas cette option 🙁

Je ne sais pas comment faire

août 26, 2019 à 2:32 #4459783

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Cette option est disponible depuis WPML 4.2. Pouvez-vous mettre à jour tout votre paquet WPML ?

Si cela n'est pas possible, il existe une option disponible dans WooCommerce > WooCommerce Multilingual > Settings.

Cordialement

août 26, 2019 à 2:37 #4459865

emmanuelM-8

Oui en effet j'ai vu cette option. J'ai peur de tout cassé 🙁

Je vais faire un backup

Merci

août 26, 2019 à 3:04 #4460001

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait, j'attends votre retour.

août 27, 2019 à 8:41 #4463777

emmanuelM-8

Bonjour Andrés,

Quand j'édite le produit dans la langue FR, je ne peux pas accéder au statut Visibilité. Il y a un cadena. 🙁

Je vais tenter les mises à jour.

août 27, 2019 à 8:55 #4463963

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Merci de votre retour. En effet, ce champ est bloqué par défaut, je croyais qu'on parlais de l'état de Publication, je suis désolé pour le malentendu.

Or, d'après votre capture d'écran l'état est correct, dont vous n'avez pas besoin de le modifier. Avez-vous essayer de tout simplement enregistrer la traduction du produit à nouveau ?

Cordialement

août 27, 2019 à 1:49 #4467429

emmanuelM-8

re bonjour,

apparemment les mises à jour résolvent le problème
Par contre, je ne comprends pas la chose suivante : je n'ai pas touché au site et nous avons bloqué les mises à jour pour que le site ne se retrouve pas dans ce type de cas.
Comment ça se fait qu'il faut faire des mises à jour ? Le site ne pourrait pas rester comme il est ?

Encore merci pour votre aide

août 27, 2019 à 2:38 #4467745

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je suis ravi de savoir que cela a fonctionné! 🙂

Or, dans ce cas, il pourrait s'agir d'une bogue en provenant de cette version. Aussi, il faudrait tenir en compte que vous devraient travailler avec tous les extensions, thème et version de WordPress qui a été publié dans ce moment et aucun pourrait changer.

Je comprends votre sentiment par rapport aux mises à jours, mais au long terme, je vous recommande de les faire car c'est la meilleure manière de continuer et profiter l'évolution de WordPress et plugins et, aussi, éviter des risques de sécurité.

Cordialement,
Andrés

août 27, 2019 à 2:58 #4467867

emmanuelM-8

Merci de votre retour.
Le site fonctionnait depuis 10 mois. Le bug est apparu sans modification de notre côté.

Encore merci pour votre aide

août 27, 2019 à 3:13 #4467913

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je comprends votre question mais par règles du support nous devons toujours travailler avec la dernière version de nos produits. Pour cette raison, nous ne pouvons approfondir dans votre situation, sauf si cela arrive à nouveau avec la dernière version de WPML.

Merci de votre compréhension.

Cordialement

août 27, 2019 à 3:26 #4467999

emmanuelM-8

My issue is resolved now. Thank you!