Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Les endpoints ne chargent toujours pas.

La solution: - Ajoutez les shortcodes de WooCommerce dans vos traductions.

Documentation: https://wpml.org/fr/documentation-6/projets-connexes/woocommerce-multilingual-operez-des-sites-de-commerce-electronique-en-plusieurs-langues/

This topic contains 10 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 10 mois.

Assigned support staff: Andrés.

Auteur Messages
octobre 29, 2017 à 10:55 #1414935

sebastienL-20

I am trying to:
Configure the shop in french (in addition of the english language)
Everything work fine (products, shop page, variations, multicurrency, etc.) but the endpoints of My account & My cart & Checkout pages doesn't appear and the pages are white.

Link to a page where the issue can be seen:
Website in production - I can give you the adresse and password in a private message.

I expected to see: My account & My cart & Checkout pages

Instead, I got: White pages.

Except this (endpoints in french i guess), all others elements are well charged on the page.

octobre 30, 2017 à 3:34 #1415232

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 512M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '256M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

Cordialement,
Andrés

octobre 30, 2017 à 11:44 #1416256

sebastienL-20

Hello Andrés,
Tout d'abord merci pour ton aide, en français en plus 🙂

J'ai bien suivi tes conseils dans le fichier wp-config (WP_Memory_Limit et Debug) :

- J'avoue ne pas retrouver de valeur égale à 40 MB comme toi (cf pièce jointe 1)
- J'ai bien l'info debug.log. Voici le lien pastebin : https://pastebin.com/1mMmKpYk

Malheureusement, les endpoints ne chargent toujours pas.
A noter que j'ai renseigné les mêmes en anglais et en français dans les paramètres WPML (cf pièce jointe 2).
Que penses-tu de la suite à mener pour résoudre ce problème 🙁

Merci encore et à très vite.

Cordialement,
Sebastien.

octobre 31, 2017 à 12:26 #1416270

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de cette information, Sebastien. 🙂
Par rapport à la valeur de la mémoire de la capture d'écran, il s'agit de la valeur du Memory Limit et pas la WP Memory Limit. Cependant, si vous avez ajouté la ligne de code antérieur, cette situation devrait être corrigé.

Or, dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML et WooCommerce sont actives. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

J'attend vos commentaires.
Andrés

novembre 3, 2017 à 11:21 #1420673

sebastienL-20

Hello Andrés,
Désolé pour ce temps de réponse assez long tout d'abord 🙁

J'ai suivi tes conseils :
- Désactiver tout sauf Woo et suite WPML
- Désactiver le thème pour tester avec twentyseventeen

Malheureusement, le problème persiste.

Sais-tu s'il est possible de donner un accès back-office au support pour regarder ? Ou quelle est la marche à suivre ensuite ?

Merci beaucoup.

novembre 4, 2017 à 4:13 #1420713

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Sebastien,

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

novembre 5, 2017 à 4:03 #1421129

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Sebastien,

Je viens de visiter votre site et j'ai reparé 2 situations différents :
- Pour votre page "My account", il vous manquez la traduction du shortcode. Une fois je l'ai fait, cela fonctionne correctement.
- Pour la page "Checkout" par contre, j'ai du la recréer de puis les options de WooCommerce > Tools. Désormais, cela fonctionne aussi correctement.

Pouvez-vous le vérifier ?

Cordialement,
Andrés

novembre 6, 2017 à 4:51 #1422274

sebastienL-20

Fantastic Andrés 🙂

Merci beaucoup pour ton intervention !

J'ai un dernier réglages qui fait des siennes.
Un shortcode PHP qui n'est pas appelé dans les fiches produits en français.
Sais-tu comment remédier à cela ?

Un grand merci Andrès.

novembre 6, 2017 à 5:07 #1422291

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Super, Sebastien! 🙂

Par contre, je viens de visiter un parmi vos produit et je pense qu'il s'agit d'une situations different. et par normes du support nous ne pouvons pas traiter des différents sujets sur un même ticket. Cela nous permet de vous donner un meilleur service et aux autres utilisateurs d'accéder à l'information ici exposé.

Je dois vous demander d'ouvrir un autre pour nous concentrer sur cette nouvelle situation, vous pouvez me l'assigner directement et nous pouvons continuer à travailler ensemble sur ce sujet.

Au moment de le faire, pouvez-vous me dire, comment a été ajouté cette fonctionnalité ?

Cordialement

novembre 6, 2017 à 5:08 #1422295

sebastienL-20

Ok. Je vais ouvrir un autre ticket, c'est mieux en effet.
Merci encore.

novembre 6, 2017 à 5:27 #1422319

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait! 🙂
Je reste à l'attente.