Skip Navigation

זהו פורום התמיכה הטכנית עבור WPML - התוסף הרב-לשוני של WordPress.

כל אחד יכול לקרוא, אבל רק לקוחות של WPML יכולים לכתוב כאן. הצוות של WPML עונה בפורום 6 ימים בשבוע, 22 שעות ביום.

אין היום תומכים זמינים לעבודה בפורום Hebrew. הרגש חופשי לפתוח קריאות ונטפל בהן ברגע שנהיה מקוונים. תודה על הבנתך.

This topic contains 15 תגובות, has 2 משתתפים.

Last updated by Yvette לפני 4 חודשים.

Assigned support staff: Yvette.

מאת תגובות
דצמבר 27, 2021 at 4:48 am #10248575

nitzanB-2

This is staging of littlepenguin site: Admin Page Link: hidden link

This is the page I want help with.
When I try to go to Analytics > Products and click on a product link then it shows number of orders but when I click on orders number it shows me empty list but the total below has all details needed. hidden link This is the screenshot of page.

But this shows results if we disable the "WPML Multilingual CMS - plugin"

Here are the login details:
Site url:
hidden link
Browser pass:
zdjdsswmbb
kmK2aYdf43
Admin :
hidden link

דצמבר 27, 2021 at 11:29 am #10250025

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello

Can you please check if you have set the post type "Orders" to be "Translatable" here:
WPML > Settings > Post Type Translation

The correct setting should be " Do not translate".

I wait for your feedback on this.

דצמבר 27, 2021 at 1:07 pm #10251127

nitzanB-2

Hi Yes.
Those setting are default. (Not Translate). hidden link

דצמבר 27, 2021 at 2:49 pm #10251515

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello

There have been a number of reports with similar issues of Analytics, order listings and WCML. Please do the following. Login here:
hidden link

This is a sandbox site that is preloaded with WCML/WPML/Wooocommerce and sample translated products. Please make some orders and see if you are able to replicate this issue there.

Then write back to let me know.

Thankas

דצמבר 28, 2021 at 4:09 pm #10256637

nitzanB-2

It looks fine on the test site you sent but not on ours.
Can you guide me with any other helpful direction?

דצמבר 29, 2021 at 10:30 am #10259781

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

OK! So the next step would be to temporarily set the setup of your site to be the same as the sandbox. This means to use the Storefront theme and only have Woocommerce and WCML/WPML plugins activated.

Then make the same test and see if you get the same results as before. Does it work in this setup or not?

If it does not, then please send us a copy of your site using the Duplicator plugin and with it in this new configuration. I can then install the copy on one of our local servers to see if the problem is server related. If it is not, and I cannot troubleshoot it, then I will escalate the issue and your site in this state to our 2nd tier support group.

Here is the article on how to use Duplicator to make a copy of your site. When you write back, please only send us a downloadable link form a file sharing service like WeTransfer or, better yet, just leave the package on your site and I can go in and download it myself.

https://wpml.org/faq/provide-supporters-copy-site/
Thank you for your collaboration.

דצמבר 30, 2021 at 8:43 am #10263667

nitzanB-2

I have changed the theme and enabled only wpml related plugins and the issue still exists.
When I try to create a copy of site for you am getting issues with duplicator plugin as my site
(5GB)is large.
Is it possible that you can check it to create or check it on our site itself? As this is already the staging version of our live site.

you can check site details on the first comment:
Here are the login details:
Site url:
hidden link
Browser pass:
zdjdsswmbb
kmK2aYdf43
Admin :
hidden link

Let me know if you need anything more.

דצמבר 30, 2021 at 12:27 pm #10264799

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

OK - I can do this if it is a sandbox/staging site. However, the "secret" is already gone so could you please provide a new/alternative password for admin access?

THanksw

דצמבר 30, 2021 at 1:31 pm #10265097

nitzanB-2

Here it is: hidden link

דצמבר 30, 2021 at 1:46 pm #10265151

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

Please update the versions of WPML plungins on your site to the latest releases.

You should be at: CMS 4.5.2 and String Translation 3.2. With this level WPML CMS, you will no longer need Tranlsaiton Management and it will be deactivated

Please let me know when this is completed so I can continue

ינואר 5, 2022 at 7:00 am #10289281

nitzanB-2

Now most of the issues are solved after updating but still there are few left.

First regarding the same product on different language showing 2 items on analytics, I checked and found that there is already a ticket regarding this: https://wpml.org/forums/topic/analytics-different-language/
it is the exact same issue we are facing.
Same Product Same SKU - just translation of title and they are 2 different items on analytics.

Another one is regarding the order by of SKU field, when I click on the SKU title to sort by it , then all the order vanishes and shows NO DATA TO DISPLAY.

You can check on staging.
This with orderby sku will give no data: hidden link

But this without orderby sku or with order by product name and other columns gives data:
hidden link

ינואר 10, 2022 at 8:20 am #10315835

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello
I am happy to hear that most of your issues are resolved.

I am sorry for the delay. I have checked the status of the "fix" fo the same SKU problem that you cited. The fix version was released last year. If this is still happening for your site, please create a NEW forum thread for the issue. Please be prepared to try to recreate the issue on a new installation.

Thank you for your understanding on this point.

ינואר 11, 2022 at 7:43 am #10324201

nitzanB-2

Meanwhile can you check with the second issue I mentioned?
====
SKU title to sort by it , then all the order vanishes and shows NO DATA TO DISPLAY.

You can check on staging.
This with orderby sku will give no data: hidden link

But this without orderby sku or with order by product name and other columns gives data:
hidden link

==============

I tried on sandbox site but its working there, but not on our site ,.
Can you check and help me?
Its only happening with order by SKU, all other columns working fine.

Although it works fine if I deactivate the WPML Multilingual CMS plugin.

ינואר 14, 2022 at 12:59 pm #10352315

Yvette
Supporter

Languages: אנגלית (English ) ספרדית (Español )

Timezone: Europe/Paris (GMT+02:00)

Please open a new ticket for this. If it is working on the sandbox site, then I can recommend that you try reproducing the same configuration on your staging site (only WPML plugins with Woocommerce and standard Storefront theme). If it is working on your site (as it should) in this configuration, then you can step-by-step restore your original setup first with the theme and then with the plugin. Go step-by-step until you find which element is causing the problem to happen.

Then open a ticket with this problem and the element that causes the issue and a supporter will help you. I am no longer on Support Team and cannot continue with this ticket.

ינואר 18, 2022 at 9:02 am #10371443

nitzanB-2

https://wpml.org/he/forums/topic/sort-by-sku-not-working-on-analytics/
Created new ticket here, thanks.