This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 9 risposte, has 2 voci.

Last updated by Alejandro 2 settimane, 4 giorni fa.

Assigned support staff: Alejandro.

Autore Post
September 20, 2019 at 9:01 am

simoneM-8

Salve,

da quando ho installato Elementor Pro se salvo una pagina (ad esempio "Progetti speciali") che abbia già una traduzione, Elementor mi dice "Access denied" )hidden link).
Ho visto questo thread https://wpml.org/forums/topic/using-elementor-wpml-blocks-me-from-save/ e sembrava poter risolvere, ma il problema è che non riesco a impostare a "copia" i campi personalizzati _elementor_css e _elementor_data perchè "grigi", vedi qui: hidden link
Come risolvere?
Grazie, saluti

September 21, 2019 at 6:46 am #4615481

simoneM-8

Anybody there?

September 24, 2019 at 7:53 am #4628739

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Prima di tutto scusaci per averti risposto un po' lenti, proverò a velocizzare al massimo i tempi d'ora in poi.

Sto controllando il problema e a breve ti aggiornerò.

September 24, 2019 at 7:59 am #4628775

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Allora, come prima cosa, ho visto che c'è questo da sistemare: hidden link

Come vedi devi aggiornare le tassonomie, per evitare problemi in futuro.

Poi, ho visto che alla fine ce l'hai fatta a cambiare i campi personalizzati a "copia".

Mi puoi dire se il problema si è risolto? se invece non è ancora risolto, fammi sapere dove posso vedere il problema, per continuare a controllare cosa sta succedendo.

September 24, 2019 at 8:58 am #4629303

simoneM-8

Ciao,

ho risolto parzialmente, nel senso che ho capito che il problema si verifica quando c'è una traduzione, ma è vuota (ovvero esiste la pagina corrispettiva in altra lingua, ma senza contenuti). Il mio cliente l'aveva preparata, ma non riempita.
Se si mette un qualsiasi contenuto nella traduzione il problema della pagina originale non si verifica più.

Quanto ad aggiornare le tassonomie sono un po' confuso/perplesso. Se seguo le istruzioni che dicono "go over each of them from the following list and click the "Update taxonomy hierarchy" button."
1. non è possibile andare sopra "each of them..." ma sembra che l'aggiornamento ia generale con il grosso bottone in fondo
2. inoltre mi spaventa il fatto che gli elementi in rosso vengano cancellati perchè sono genitori delle tassonomie verdi... Vedi hidden link

Puoi darmi chiarimenti?

Grazie, saluti
Simone

Quanto al

September 24, 2019 at 3:42 pm #4632897

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Vediamo:

Tu dici:

Se seguo le istruzioni che dicono "go over each of them from the following list and click the "Update taxonomy hierarchy" button."
1. non è possibile andare sopra "each of them..." ma sembra che l'aggiornamento ia generale con il grosso bottone in fondo
2. inoltre mi spaventa il fatto che gli elementi in rosso vengano cancellati perchè sono genitori delle tassonomie verdi... Vedi

1) "Each of them" significa per ogni tassonomia, cioè immagina che hai i tag e le categorie. queste qui sono 2 e quando dice "each of them" si riferisce ai tag e poi alle categorie.

Nel tuo caso, in realtà ce n'è solo 1.

Per quanto riguarda "Quartets" puoi controllare che nella traduzione (Inglese) questa categoria sia correttamente collegata con quella originale e che sia anche una "parent" di quelle di sotto? (v-w-x, y-z, etc)?

Poi, ancora non mi è molto chiaro quello che intendi quando parli della risoluzione parziale del access denied di elementor, o meglio ti capisco ma non riesco a riprodurlo.

Mi potresti elencare i passi per cercare di vedere se si tratta di un bug? io proverò a riprodurre il problema su un sito di sandbox se riesco a riprodurlo allora parliamo di un bug e quindi potrò chiedere aiuto ad un nostro sviluppatore per cercare di risolvere il problema.

Saluti.

September 25, 2019 at 2:19 pm #4639775

simoneM-8

Ciao,

1. effettivamente sembra che non ci sia corrispondenza tra QUARTETTI e QUARTETS
Chiedo: se lo inserisco qui hidden link viene creata la corrispondenza oppure si fa confusione perchè viene creata un'altra categoria QUARTETS?

2.
con elementor
a. crea una pagina con qualsiasi contenuto nella lingua x
b. crea la corrispettiva in lingua y ma lasciala vuota di qualsiasi contenuto
c. torna sulla pagina in lingua x e prova a modificare, dovresti avere l'errore ACCESS DENIED
d. per controprova metti del contenuto in pagina con lingua y
e. riprova il punto c, NON dovresti avere errore.

Questo è quel che ho potutto verificare. Per risolvere ho fatto dal punto d in poi.

September 25, 2019 at 3:09 pm #4640265

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

1) io rinominerei il "quartets" che c'è ora tanto per riconoscerlo (insieme al suo slug), poi procederei a tradurre hidden link altrimenti non potrai usare lo slug originale perché già esiste.

poi proverei a sincronizzare tutto da qui: hidden link

Proverò a fare quello che mi hai detto su elementor per vedere se riesco a riprodurre il problema.

Ti aggiorno a breve.

September 26, 2019 at 7:03 am #4643795

simoneM-8

Mhm...
Il fatto di rinominare QUARTETS mi preoccupa.
Cosa succede ai figli?
La maggior parte dei menu del sito sono organizzati su queste tassonomie...

September 26, 2019 at 7:20 am #4643821

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Potresti vedere questo video? hidden link

Penso di aver seguito i tuoi passi correttamente (però mi sono registrato proprio per chiederti conferma) ma a me non ha dato questo problema.

Saluti.

The topic ‘[Closed] Access denied con Elementor’ is closed to new replies.