This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.47 hours from now. Thank you for your understanding.

This topic contains 31 risposte, has 3 voci.

Last updated by Vincenzo 8 mesi, 3 settimane fa.

Assigned support staff: Vincenzo.

Autore Post
November 21, 2017 at 7:28 am #1436535

robertoB-31

I am trying to: Sto cercando di ripristinare il funzionamento del sito: dopo l'aggiornamento di WPML non funziona più la duplicazione della ACF gallery nel post type progetti

Link to a page where the issue can be seen:
hidden link
Il problema esiste in tutti i custom post type di questa pagina hidden link
L'italiano funziona correttamente, mentre la traduzione nelle altre lingue non riporta la gallery.

Ho letto questo Thread https://wpml.org/forums/topic/acf-gallery-field-doesnt-work-with-wpml-media/ ma pare ci fosse un bug che non è più stato risolto.

Ho verificato tutto quanto indicato da Francesco, in un vecchio thread.
#1416972
Ciao,
scusami se ti pongo una domanda scontata ma mi serve per inquadrare meglio il tuo problema e per aiutarti al meglio.
Nel tradurre i tuoi CF creati con ACF, hai seguito tutte le istruzioni presenti nel documento Translate sites built with ACF che puoi trovare a questo link:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/?
Hai seguito soprattutto le istruzioni ai paragrafi
Making the ACF fields translatable e
Translating ACF Fields?
Per quanto riguarda le Gallery, c'è un paragrafo dedicato alla loro traduzione
How to handle images and other post object fields
dove è precisato che ogni immagine aggiunta alla Gallery deve essere tradotta prima di poter essere aggiunta alla Gallery che poi verrà tradotta.
Nel creare le tue Gallery tradotte, hai seguito queste indicazioni?
Aspetto tue notizie, grazie.
Francesco

E' tutto come indicato.
Ho creato un'area testa, quella a cui fa riferimento il link, nella quale ho aggiornato tutti i plugin e wordpress 4.9

November 21, 2017 at 11:53 am #1436843

Francesco Di Candia

Ciao,
grazie per le tue puntualizzazioni.
A questo punto avrei bisogno delle credenziali di accesso al tuo sito per controllare meglio.
La tua prossima risposta sarà privata e potrai fornirmele senza alcun problema.
Grazie, Francesco

November 22, 2017 at 6:25 pm #1438574

Francesco Di Candia

Ciao Roberto, ti scrivo per informarti che sto lavorando per risolvere il tuo problema.
Appena avrò notizie, ti informerò immediatamente.
Grazie per la pazienza,
Francesco

November 23, 2017 at 4:15 pm #1439570

Francesco Di Candia

Ciao,
controllando il tuo sito, ho visto che, come puoi controllare dall'immagine allegata, il CF 'gruppi di campi' era settato su 'Nessuna azione' mentre dovrebbe essere su 'Traduci' e l'ho modificato (image001.png).
Successivamente ho creato un nuovo ACF 'Galleria' con una gallery e l'ho assegnato ai CPT 'Projects'.
Come puoi vedere dal video qui hidden link, ho creato un nuovo Project, ho aggiunto una foto nella gallery (fai attenzione che il media deve essere già esistente nella lingua in cui vuoi tradurre), l'ho tradotto e la traduzione funziona.
Ho provato con un Project già esistente hidden link ed anche questo funziona.
Effettua un controllo anche tu e fammi sapere.
Francesco

November 24, 2017 at 8:52 am #1440144

robertoB-31

Ciao Francesco,
grazie per la tua assistenza.
Io ho moltissime immagini già presenti negli altri progetti, la cui traduzione funzionava prima dell'aggiornamento a wpml che però ha cambiato varie impostazioni.
Ora per risolvere dovrei reinserire e tradurre tutti i progetti? E nel caso di un nuovo aggiornamento potrebbe ricapitare il problema?

November 24, 2017 at 9:48 am #1440207

Francesco Di Candia

Ciao,
purtroppo è un malfunzionamento noto al quale i nostri developer stanno lavorando e per il quale, al momento, non esiste altro workaround che ricreare il post.
Mi spiace per questo malfunzionamento ma ti assicuro che sarà risolto quanto prima.
Francesco

December 5, 2017 at 8:39 am #1449324

robertoB-31

Buongiorno Francesco.
Finalmente ho avuto l'ok dall'azienda per mettere il sito in manutenzione e fare tutti gli aggiornamenti e le modifiche nel sito ufficiale.
- Ho aggiornato wordpress, ho aggiornato tutti i plugin all'ultima versione
- Ho verificato nelle impostazioni del contenuto multilingua che il CF 'gruppi di campi' fosse settato su 'Traduci' ed effettivamente è già settato, non ho dovuto fare modifiche
- Le traduzioni del campo gallery non funzionano.
- Ho riprodotto un nuovo campo gallery per i progetti e ho seguito le tue stesse impostazioni. Nelle traduzioni non funziona la copia nè del vecchio campo gallery, nè del nuovo. Dovrei comunque ricopiare le immagini in ogni singolo progetto, però proprio non vedo funzionare il campo

Posso inviarti i codici di accesso?
Ora la cosa è abbastanza urgente.

Grazie

December 5, 2017 at 3:58 pm #1449952

Francesco Di Candia

Ciao,
mandami gli accessi al sito di produzione in maniera tale che io possa ritestare in locale.
Francesco

December 7, 2017 at 11:41 am #1451784

Francesco Di Candia

Ciao,
ho effettuato dei test con il tuo sito ed ho dovuto scalare il problema al nostro 2° livello di assistenza.
Ti faccio sapere quanto prima l'evolversi della situazione.
Grazie, Francesco

December 11, 2017 at 9:22 am #1453907

robertoB-31

Grazie, rimango in attesa!

December 13, 2017 at 8:29 am #1456372

robertoB-31

Buongiorno, ci sono aggiornamenti? Sono ancora in attesa.

December 14, 2017 at 8:10 am #1457485

Francesco Di Candia

Ciao Roberto, mi spiace al momento non ho aggiornamenti.
Ti farò sapere appena possibile, grazie Francesco.

December 19, 2017 at 8:43 am #1461117

robertoB-31

Buongiorno Francesco,
è passato molto tempo e il cliente inizia a spazientirsi. Non ho scelta e con un sito così corposo non posso cambiare completamente il plugin e reinserire tutti i contenuti, cosa posso fare? A chi mi posso rivolgere?

December 19, 2017 at 5:12 pm #1461906

Francesco Di Candia

Ciao Roberto, ti chiedo scusa per il ritardo. Ho sollecitato il team di sviluppo. Ti faccio sapere appena possibile. Grazie Francesco

December 22, 2017 at 8:41 am #1464268

robertoB-31

Buongiorno Francesco,
in attesa di risolvere il problema originale, devo trovare un modo per mostrare i project soltanto nella lingua italiana, senza perdere i contenuti nelle altre lingue, in attesa che il problema sia definitivamente risolto. La pagina in questione è quella del singolo progetto hidden link tra le varie lingue cambia pochissimo quindi per ora mostriamo soltanto l'italiano.
Che modifiche devo fare per non perdere il resto delle traduzioni?
Grazie!