This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.49 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: after changing the IP of the server, the second language homepage redirects to the default language

Solution: there is a 301 redirect on the second language homepage. Since WPML doesn't handle redirects, you should investigate what caused it.

This topic contains 5 risposte, has 2 voci.

Last updated by mauroB-10 2 settimane, 6 giorni fa.

Assigned support staff: Laura.

Autore Post
October 1, 2019 at 5:25 pm #4674361

mauroB-10

Hi , just migrate the IP of my hosting and my english subdomain has stopped working

hidden link

is offline...

Do I have to replace Ip on my domain? tnks.

see thi thread to see what I have do some time ago...

https://wpml.org/it/forums/topic/option-different-domain-per-language-not-valid/
tnks!

October 2, 2019 at 11:17 am #4679637

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Sul dominio hidden link c'è un redirect 301 verso hidden link

WPML non crea redirect quindi ci sono alcune ipotesi:
- un plugin SEO come Yoast potrebbe averlo creato
- è inserito a livello di .htaccess visto il cambio dell'IP
- lo ha aggiunto il tuo hosting

Una volta eliminato il redirect, il sottodominio dovrebbe funzionare correttamente.

October 2, 2019 at 11:46 am #4679863

mauroB-10

Ecco! a questo non avevo pensato... (oltretutto vinci il bonus per aver decifrato quello che ho scritto pessimamente in inglese ieri che riletto oggi mi da le veritigni!)
Questo spiegherebbe molte cose. indago: grazie mille dello spunto!

October 2, 2019 at 11:47 am #4679873

mauroB-10

per adesso ho risolto abilitando l'estensione /en e rifacendo i link sulla home... 😉

October 3, 2019 at 8:56 am #4685953

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Può essere una soluzione in effetti, anche se ti consiglierei di capire da dove arriva il redirect.

Possiamo considerare il ticket risolto o hai bisogno di ulteriore aiuto?

October 3, 2019 at 4:04 pm #4689667

mauroB-10

My issue is resolved now. Thank you!