This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problema: I prodotti tradotti restituiscono errore 404 Soluzione: Si trattava di un problema con l'impostazione e la traduzione della base dei Permalink in Impostazioni -> Permalink

This topic contains 4 risposte, has 2 voci.

Last updated by davideG-16 2 anni, 1 mese fa.

Assigned support staff: Vincenzo.

Autore Post
January 17, 2018 at 10:54 am #1487171

davideG-16

ITA: Non so cosa stia succedendo, tutti i prodotti sono in Italiano ed hanno traduzione in inglese. Ora, nella pagina SHOP inglese se clicco su un qualsiasi prodotto mi ritorna l'errore 404. Cosa posso fare per sincronizzarli?

EN: I do not know what's going on, all the products are in Italian and have English translations. Now, on the English SHOP page, if I click on any product I get back the error 404 . What can I do to synchronize them?

January 18, 2018 at 8:45 am #1488178

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML!
Mi occuperò di questo ticket.

Dalle informazioni di debug vedo che il nostro plugin WooCommerce Multilingual non è aggiornato.

❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
⌥ Io uso spesso il plugin Duplicator per questo scopo.
Vedi: https://wordpress.org/plugins/duplicator/

Prova ad aggiornare WooCommerce Multilingual ed a salvare nuovamente i Permalink da Impostazioni -> Permalink

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

January 18, 2018 at 8:54 am #1488214

davideG-16

Grazie per la risposta, il ticket è stato "spostato" da un suo collega e le confermo che ho sempre lo stesso problema, WPML Multilingual è alla Versione 3.9.1 ma non riesco comunque a vedere i prodotti in inglese. Ecco il link del nuovo post: https://wpml.org/forums/topic/product-category-url-returns-error-404/ . Ho lasciato al suo collega i dati di accesso, avrei bisogno di capire cosa non funziona...

January 18, 2018 at 10:35 am #1488367

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

sembra che il problema sia stato risolto dal mio collega qui:
- https://wpml.org/forums/topic/product-category-url-returns-error-404/#post-1488340

Puoi confermare che è risolto?

Grazie

January 18, 2018 at 10:50 am #1488376

davideG-16

Sì, risolto. Grazie!!!!