This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.92 hours from now. Thank you for your understanding.

This topic contains 3 risposte, has 2 voci.

Last updated by Vincenzo 1 anno, 1 mese fa.

Assigned support staff: Vincenzo.

Autore Post
February 8, 2019 at 1:19 pm #3175270

albertoP-18

Hello,

This warning came out: OTGS Installer, responsible for receiving automated updates for WPML and Toolset, requires the following PHP component(s) in order to function:cURL
Learn more: Minimum WPML requirements

How can I solve it?

February 8, 2019 at 1:56 pm #3175472

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

cURL è un software gratuito che permette il trasferimento tra i server.
- hidden link

Senza queste librerie, non è possibile scaricare gli aggiornamenti di WPML.

Puoi chiedere al supporto del tuo hosting provider di installare queste librerie sul tuo server.
In alcuni casi questo problema potrebbe essere causato da una versione di PHP non aggiornata.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

February 8, 2019 at 2:27 pm #3175678

albertoP-18

Posso non installare questa libreria ?

Oppure potrebbe causare problemi ?

February 8, 2019 at 2:35 pm #3175711

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

libcurl è una libreria installata in maniera predefinita nella maggior parte dei server web che ho visto finora.

Potresti provare ad installare manualmente gli aggiornamenti di WPML, ma altre funzionalità del plugin, e di WordPress, richiedono Curl.
Vedi: hidden link
Senza queste librerie, si interrompe la comunicazione con l'esterno e WPML non può, per esempio, caricare i file di compatibilità del tema e dei plugin che trova installati sul sito.

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie