This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problem: Non riesco a tradurre i link personalizzati del menu

Solution: devi andare su WPML > Traduzione di stringhe e poi tradurre i link (Se è necessario, fammi sapere se compaiono oppure no) per ultimo dovrai sincronizzare di nuovo i menu (WPML > Menu Synchronization).

Relevant Documentation: https://wpml.org/it/documentazione/guida-introduttiva/tradurre-i-menu/#tradurre-link-personalizzati

This topic contains 8 risposte, has 2 voci.

Last updated by lorenzoM-16 2 mesi, 4 settimane fa.

Assigned support staff: Alejandro.

Autore Post
July 19, 2019 at 6:51 am #4244271

lorenzoM-16

Buongiorno, il sito ciasabruescia.com tradotto in 3 lingue funziona perfettamente. Ho solo un problema nella pagina in tedesco dove un anchor link non funziona; il link è relativo a Zimmer.

Ho modificato diverse volte l'ID per verificare che non fosse quello il problema ma non sono mai riuscito a farlo funzionare. Tutti gli altri anchor link, sia nella pagina in inglese che in tedesco, funzionano. Solo quello non ha mai funzionato.

July 19, 2019 at 7:01 am #4244363

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Ho visto che tutti i link (o quasi) sono anchor link. mi potresti dire come li hai creati? cioè li crea il tema automaticamente o sono stati creati manualmente (e come).

Questo mi aiuterà meglio a capire come procedere.

July 19, 2019 at 12:53 pm #4246535

lorenzoM-16

Ciao Alejandro, tutti gli anchor link sono stati creati da me in modo manuale e non automatico. Ho assegnato a ogni sezione che volevo linkare un ID univoco. Poi, nel menu ho creato dei link personalizzati dove la destinazione è l'ID.

Allego immagine

July 19, 2019 at 1:24 pm #4246737

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ah ecco.

Potresti provare a leggere in particolare questa sezione della nostra documentazione: https://wpml.org/it/documentazione/guida-introduttiva/tradurre-i-menu/#tradurre-link-personalizzati

In poche parole devi andare su WPML > Traduzione di stringhe e poi tradurre i link (Se è necessario, fammi sapere se compaiono oppure no) per ultimo dovrai sincronizzare di nuovo i menu.

In quel link potrai vedere come fare tutto ciò che ho appena menzionato.

Provaci e fammi sapere come va.

July 19, 2019 at 1:34 pm #4246749

lorenzoM-16

Ho fatto quanto descritto, tutto funziona tranne il link "ZIMMER" che non funziona

July 19, 2019 at 2:03 pm #4246913

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

A questo punto, ti chiedo gentilmente di darmi accesso al tuo sito.

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

July 19, 2019 at 2:28 pm #4247009

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

L'errore era che nella traduzione del link, hai inserito uno spazio extra (errore quasi impercettibile!)

ecco perché copiava automaticamente il link che c'era sulla barra di navigazione anziché usare il link giusto!

L'ho sistemato e il problema è sparito (per essere più preciso, sono andato su WPML > String Translation > Ho cercato il link e ho rimosso gli spazi che c'erano prima di "hidden link" e poi ho salvato la traduzione"

Saluti!

July 19, 2019 at 3:57 pm #4247419

lorenzoM-16

Alejandro! Sei stato fantastico...mi hai risolto un problema che non riuscivo a risolvere fin dall'inizio. Grazie mille. Buona giornata.
Lorenzo

July 19, 2019 at 3:59 pm #4247421

lorenzoM-16

My issue is resolved now. Thank you!