This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 6 risposte, has 2 voci.

Last updated by paoloR-15 3 settimane, 5 giorni fa.

Assigned support staff: Alejandro.

Autore Post
September 17, 2019 at 9:10 am #4586871

paoloR-15

Sto tentando di:
All'interno di un articolo sto tentando di assegnare dei link a degli articoli (già tradotti in lingua).
Ma quando si prova a visualizzare l'articolo in inglese e si clicca sul link, questi porta sempre alla versione italiana invece che all'articolo in inglese.

Link a una pagina dove è possibile vedere il problema:
hidden link
(articolo in lingua inglese)

Se si clicca sui link nell'articolo alle voci:
London Design Festival: Festival Commissions and Special Projects
hidden link

Si viene portati su:
hidden link
(articolo in italiano)

Invece che su:
hidden link
(stesso articolo ma in inglese)

September 18, 2019 at 8:12 am #4593553

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao e benvenuto sul supporto WPML,

Mi potrebbe dire se questo blocco dove si trovano i Link è fatto con un shortcode, page builder oppure manualmente?

Perché a seconda del caso, potrebbe esserci un modo da fare diverso e non vorrei confonderti.

Fammi sapere.

September 18, 2019 at 8:59 am #4593995

paoloR-15

Sia con editor di testo "Classico".
Sia con con un "Page builder" del tema.

September 18, 2019 at 3:36 pm #4598239

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ho capito.

Per caso mi permetteresti di accedere al tuo sito per poter controllare meglio di cosa si tratta? perché da come lo describi potrebbe trattarsi di una incompatibilità con forse un shortcode o qualcosa nel page builder ma vorrei prima esserne sicuro.

Se accetti, ti chiedo di aggiungere le credenziali direttamente sui campi che ho attivato per te, così manterremo i tuoi dati sicuri e privati.

Saluti.

September 19, 2019 at 6:48 am #4601715

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Per quello che vedo hai bisogno di una estensione creata dagli autori del plugin per rendere questo plugin compatibile con WPML: https://www.relatedpostsforwp.com/wpml-compatibility/

Prova ad installare il plugin e vedi se questo risolve il problema.

Saluti.

P.S: ho letto che questo plugin serve soltanto con la versione premium quindi forse devi anche fare l'upgrade dal piano gratis

September 26, 2019 at 8:01 am #4644169

paoloR-15

Grazie Alejandro

installando quel plug in il problema è stato risolto!

September 26, 2019 at 8:01 am #4644177

paoloR-15

My issue is resolved now. Thank you!