This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 risposte, has 2 voci.

Last updated by Alejandro 1 mese fa.

Assigned support staff: Alejandro.

Autore Post
September 6, 2019 at 11:24 am #4525031

alessandroL-4

Ciao ricevo spesso un problema di connessione con il server. Il sito riporta molte volte Bad Gateway. Devo dire che questo problema è iniziato dal momento in cui ho installato e utilizzato WPML Translation Management e WPML String Translation.

Se disattivo WPML Translation Management e WPML String Translation il problema non esiste più.

Cosa posso fare per capire se il problema è nel plugin wpm o lato server?

Grazie
Alessandro

September 6, 2019 at 12:55 pm #4525395

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Il bad gateway potrebbe succedere per tante cose, quindi la prima cosa che dovremo fare è capire quale è l'errore esatto e sopratutto dove sta succedendo.

Per questo motivo ti chiedo di seguire le istruzioni che trovi in questo link per creare un registro di debug: https://wpml.org/documentation/support/debugging-wpml/

Dopo di aver inserito nel tuo file wp-config.php il codice presente nel link di sopra, cerca di ricreare il problema (cioè, di trovare l'errore Ba Gateway) e poi vai alla cartella "wp-content" della tua installazione WordPress. Se ci saranno stati problemi nel sito comparirà un file "debug.log"

Se lo trovi, per favore caricalo nella piattaforma di archiviazione di tua preferenza (Google Drive, Dropbox, ecc) e poi incolla il link nella tua risposta (assicurati che sia condivisa con i permessi giusti altrimenti non potrò accedere al suo contenuto).

Dopodiché darò una occhiata al file e determinerò quale strada prendere.

September 6, 2019 at 1:06 pm #4525435

alessandroL-4

Ok ho inserito nel file config.php il codice debug.
Sto cercando di ricreare il problema ma ancora nulla.

I primi avvisi che ho ricevuto sono questi, sono gravi?:

[06-Sep-2019 13:00:20 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

[06-Sep-2019 13:01:24 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/plugins/woocommerce-minmax-quantity/main.php on line 429

[06-Sep-2019 13:01:24 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/plugins/woocommerce-minmax-quantity/main.php on line 429

[06-Sep-2019 13:01:36 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

September 6, 2019 at 1:18 pm #4525449

alessandroL-4

Altri avvisi:

[06-Sep-2019 13:00:20 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

[06-Sep-2019 13:01:24 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/plugins/woocommerce-minmax-quantity/main.php on line 429

[06-Sep-2019 13:01:24 UTC] PHP Warning: A non-numeric value encountered in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/plugins/woocommerce-minmax-quantity/main.php on line 429

[06-Sep-2019 13:01:36 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

[06-Sep-2019 13:05:34 UTC] PHP Notice: Undefined index: scadenza_pan in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/plugins/cartasi-x-pay/includes/class-wc-gateway-nexi-xpay-order-payment-info.php on line 66

[06-Sep-2019 13:05:39 UTC] PHP Notice: Undefined index: scadenza_pan in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/plugins/cartasi-x-pay/includes/class-wc-gateway-nexi-xpay-order-payment-info.php on line 66

[06-Sep-2019 13:10:52 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

[06-Sep-2019 13:13:44 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

[06-Sep-2019 13:14:22 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-
content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

[06-Sep-2019 13:16:44 UTC] PHP Notice: Undefined index: width in /var/www/vhosts/h632032.linp066.arubabusiness.it/riccicurbastro.it/web/wp-content/themes/Avada/includes/lib/inc/class-fusion-images.php on line 390

September 6, 2019 at 1:36 pm #4525555

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, prova a disattivare "woocommerce-minmax-quantity"
e vedi se le cose cambiano e smette di fare questi errori.

Poi vedo anche 2 errori extra:

Uno con il Cartasi Pay (che se non sbaglio è un errore che non dovrebbe farti crashare il sito però)

e poi uno con Avada.

Quindi se disattivando il plugin che menziono sopra non funziona e ti fa crashare il sito, prova a disattivare il cartasi pay e prova di nuovo.

Se ancora ti da l'errore, prova a cambiare il tema da avada ad un altro e vedi se ti crasha il sito.

Ti consiglio di rinominare o cancellare il file debug.log ogni volta che fai un cambiamento e di controllare ogni volta quale errore ti fa.

Se noti bene, negli errori vedrai quasi sempre un directory quale wp-content/plugins(oppure "themes")/nome-plugin-tema, ecc.

Molte volte gli errori sono nascosti e compaiono soltanto quando disattivi certi plugin quindi ogni volta che disattivi i plugin controlla se ci sono errori che non abbiano a che fare con avada o con i plugin menzionati sopra.

Fammi sapere come va.

September 6, 2019 at 1:38 pm #4525587

alessandroL-4

Dopo aver effettuato il login e logout sul sito ho ricevuto Bad Gateway.
hidden link

September 6, 2019 at 2:22 pm #4525915

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Gli errori sono gli stessi anche in questo debug.log.

Posso chiederti gentilmente accesso al tuo sito tanto di WordPress come di FTP, per favore?

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

September 6, 2019 at 2:34 pm #4526007

alessandroL-4

Grazie ma il sito ha uno shop online che non voglio smettere di farlo funzionare disattivando i plugin. Preferisco creare un copia del sito su altra cartella per fare tutte le verifiche del caso. Poi ti passo gli accessi... Cosa ne pensi?

September 6, 2019 at 2:56 pm #4526131

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Certamente, figurati, è anche meglio così!

Ti lascio attive le credenziali, così le puoi inserire quando le avrai.

September 6, 2019 at 4:07 pm #4526497

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Per caso mi sapresti dire quale hosting stai usando? questo errore che menzioni mi ha fatto ricordare alcuni errori creati da hosting quale godaddy, inmotion o bluehost per via di una restrizione che ha il server nel database, dove soltanto fino ad un certo di chiamate fatte per minuto erano disponibili e se andava oltre (e con string translation di solito si va oltre un paio di query in più) il sito andava in tilt per un attimo.

Ti chiederei un po' di pazienza perché questo problema verrà risolto nella prossima versione. diciamo che le versioni beta di WPML/String Translation e Translation Management sono pronte e sembrano abbastanza stabili ma quella di WooCommerce Multilingual arriverà a breve (tra una settimanella più o meno).

Poi vedo che usi Loco translate, immagino sia per usare le feature di String Translation.

Fammi sapere per conoscere come continuare.

Saluti.

September 9, 2019 at 10:28 am #4535925

alessandroL-4

Ciao l'hosting è Aruba.
Vorrei eliminare tutti i dati wpml translation management e string translation dal database e lasciare solo wmpl. In supporto ho visto che posso azzerare tutti dati dal db. Come posso lasciare solo le traduzioni? O è meglio che svuoto tutto e ricomincio le traduzione da capo?

September 9, 2019 at 1:46 pm #4537711

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I file tradotti rimarranno sul sitocomunque, cioè rimarranno tutti come se fossero tutti parte di una lingua, quindi penso che ti conviene prima cancellare i contenuti che non ti interessino e poi cancellare tutto WPML.

Se poi lo ricrei puoi provare a ricollegare le traduzioni. altrimenti rischierai di crashare il sito (se cancelli soltanto alcune tabelle)

September 9, 2019 at 1:58 pm #4537785

alessandroL-4

Grazie ho già eliminato tutto.
Alla fine comunque per stare sicuro penso che farò tutto ex novo su una installazione pulita, ci metterò un pò ma sto più tranquillo.

Grazie di tutto
Alla prossima

September 9, 2019 at 1:59 pm #4537787

alessandroL-4

My issue is resolved now. Thank you!

September 9, 2019 at 5:38 pm #4539481

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Va benissimo. se riscontri qualche problema, non esitare a contattarci, saremo contenti di essere d'aiuto!