This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.53 hours from now. Thank you for your understanding.

This topic contains 6 risposte, has 2 voci.

Last updated by Vincenzo 9 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
February 19, 2019 at 11:42 am #3216371

giulianaT

Buongiorno,

il sito in questione è stato realizzato con la lingua principale impostata sull'italiano ed una seconda lingua in Inglese.
Ora si è reso necessario cambiare tale preferenza andando a configurare l'Inglese come lingua di partenza.

Dal menù di WPML > Lingue ho impostato ENG come lingua principale ed ITA come secondaria.
Fin qui tutto OK, il problema sta nel Front-end che mi restituisce un comportamento davvero strano:
1) se digito "www.rato-europe.com" il browser carica la pagina, ma sembra che vada a reindirizzarsi (la barra di avanzamento arriva a fine corsa e poi riprende) immediatamente su "www.rato-europe.com/it"
2) senza cancellare cache e cronologia, se ridigito "www.rato-europe.com" il browser mi carica correttamente la versione ENG.

Ho disattivato il plug-in SG Optimizer di Siteground per eliminare la gestione della SuperCache e contestualmente ho anche provato a cancellare la cache di WPML, ma il risultato rimane il medesimo.

In seconda battuta ho pure cercato di gestire il redirect sull'inglese utilizzando l'opzione "Usa la directory per la lingua predefinita" (file html) andando poi ad implementare un file "lang.php" che mi gestisce il redirect. Anche in questo caso ho dei problemi, infatti il sistema al momento di salvare la configurazione mi restituisce un errore 530.

Avete qualche suggerimento?

NB.
visto che il sito in questione "www.rato-europe.com" è già online, dopo aver fatto le prove soprascritte ho dovuto ripristinarlo in origine perchè altrimenti gli utenti avrebbero riscontrato dei malfunzionamenti.

February 19, 2019 at 12:21 pm #3216507

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML!

Ci sono diverse cause possibili per questo problema.

1. Puoi dirmi se hai salvato nuovamente i Permalink dopo aver cambiato la lingua predefinita?

2. Prova a selezionare l'opzione "Disabilita reindirizzamento in base alla lingua del browser" da WPML -> Lingue, nella sezione "Reindirizzamento in base alla lingua del browser".
- Prova inoltre a pulire la cache del tuo browser ed eliminare i cookie perché quella funzionalità salva un cookie nel browser che dura 24 ore.

3. La disattivazione del plugin SG Optimizer non disattiva la Memcache e la Dynamic cache, che rimangono comunque attive.
- Prova a riattivare il plugin SG Optimizer e a cancellare la cache (Purge).
- Se necessario, prova a disattivare temporaneamente la Memcache e la Dynamic cache, utilizzando i controlli del suddetto plugin.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

February 19, 2019 at 4:51 pm #3218177

giulianaT

Ciao Vincenzo,

grazie mille per la veloce assistenza.

Alla fine il problema stava proprio nel flag abbinato al "Reindirizzamento in base alla lingua del browser" che stranamente risultava selezionato.

February 19, 2019 at 4:54 pm #3218186

giulianaT

L'unico aspetto che non siamo riusciti a risolvere è la gestione del reindirizzamento sulle due lingue (..../IT e .../EN) tramite il file "html".
Il sistema ci restituisce sempre un errore 530.

In ogni caso per questa volta non abbiamo utilizzato tale metodo, quindi per ora siamo OK.
Eventualmente indagheremo anche con l'assistenza di Siteground sul motivo di questo errore 530.

February 19, 2019 at 4:58 pm #3218242

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sono contento che il problema sia risolto.

Se lo desideri puoi mandarmi il codice utilizzato.
Ti basta inserirlo all'interno dei tag code come mostrato nelle Formatting instructions.

Dai anche un'occhiata a questo ticket:
https://wpml.org/forums/topic/how-to-show-default-language-url-tag/

Grazie

February 20, 2019 at 11:24 am #3221249

giulianaT

Ciao Vincenzo,

il codice l'ho prelevato proprio dal link che mi hai suggerito.
Il problema però credo non sia tanto nel codice ma in qualche configurazione, perchè l'errore mi appare al momento del salvataggio delle preferenze di WPML (vedi allegato).

Il codice che ho inserito è il seguente:

<?php
   header( 'Location: <em><u>hidden link</u></em>' ) ; 
?>

Grazie e buona giornata

February 20, 2019 at 11:28 am #3221315

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

grazie per gli screenshot.

Come accennavi, sembra proprio un problema di permessi.
Puoi chiedere aiuto al provider. Verifica inoltre se i proprietari e i permessi del file lang.php sono gli stessi degli altri file della cartella root di WordPress.

Infine, prova a rinominare il file in lang.html

Grazie