This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 10 risposte, has 2 voci.

Last updated by lucianoC-13 5 mesi fa.

Assigned support staff: Alejandro.

Autore Post
May 15, 2019 at 12:44 pm #3816559

lucianoC-13

Sto tentando di:

Link a una pagina dove è possibile vedere il problema: hidden link in fondo alla pagina

Mi aspettavo di vedere: città d'arte

Invece ho ottenuto:città d�™arte

Set di caratteri impostato su wp-config: define('DB_CHARSET', 'Utf8mb4'); define('DB_COLLATE', 'utf8mb4_general_ci');

Charset su mysql:
Variable_name
Value
character_set_client
utf8mb4
character_set_connection
utf8mb4
character_set_database
utf8mb4
character_set_filesystem
binary
character_set_results
utf8mb4
character_set_server
utf8
character_set_system
utf8
collation_connection
utf8mb4_unicode_ci
collation_database
utf8mb4_unicode_ci
collation_server
utf8_general_ci

info di sistema: WordPress 5.2 | PHP 5.6.40 | Apache | MySQL 5.5.54

May 15, 2019 at 4:14 pm #3818667

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Prova a cambiare questo codice:

define('DB_COLLATE', 'utf8mb4_general_ci');

così:

define('DB_COLLATE', '');

poi, prova a cancellare questo apostrofo e invece prova a scriverlo manualmente (a volte questo problema capita quando incolli da sistemi quali microsoft word o google docs)

Fammi sapere come va.

May 15, 2019 at 6:39 pm #3819621

lucianoC-13

Ciao, questa soluzione l'avevo già provata senza esito. La configurazione sul server mysql secondo te è corretta?..

May 16, 2019 at 7:20 am #3822551

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In teoria sonno corretti, si.

Potresti darmi acesso al tuo sito e darmi i passi per poter riprodurre il problema? vorrei vedere da vicino se ci sono altre cose che potrebbero stare causando questo problema.

Ho attivato dei campi che sono privati e sono fatti apposta per le credenziali. mi basterebbero soltanto quelle di WordPress (al meno per ora), non pubblicare nessuna password/utente nel campo "risposta" perché è pubblico!

May 16, 2019 at 4:06 pm #3827877

lucianoC-13

Aggiornamento: ho sistemato i caratteri speciali, però col plugin attivo ho dei problemi nel salvare le modifiche alle pagine/articoli nel senso che si blocca sul salvataggio di wordpress e da errore. Ho provato anche a ripristinare la versione precedente del plugin la 3.4.0 ma il problema sui salvataggi sussiste. Hai qualche suggerimento?....

May 17, 2019 at 6:32 am #3831631

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sto controllando il problema del salvataggio.

Nel frattempo mi potresti dire come hai risolto il problema dell'apostrofo?

May 17, 2019 at 7:00 am #3831695

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi potresti dare una pagina di riferimento per questo problema del savataggio? perché ho provato a salvare alcune pagine (aggiungendo solo un carattere alla pagina) e non mi ha dato nessun errore, ma potrebbe essere anche perché è disattivato String Translation, Translation management.

Se per caso il problema succede con l'editor di traduzione allora è possibile che si tratti di un problema di MaxInputVars (devi incrementare il valore da 1000 ad al meno 4000, a seconda di quanti elementi tu aggiunga nelle pagine) ma al momento sembra che tu non stia lavorando con l'editor di traduzione.

Fammi sapere.

May 17, 2019 at 7:39 am #3831867
lucianoC-13

Ciao, succede su qualsiasi pagina. se il plugin è attivo il salvataggio va come in time out e wordpress da errore. se attivi i plugin aggiuntivi di WPML Translation Management, WPML String Translation e Yoast SEO Multilingual l'editor di wordpress si blocca completamente non caricando le pagine.
Con MaxInputVars intendi il codice php del plugin?

I nuovi thread creati da Alejandro e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/split-caratteri-speciali-errati-tipo-lapostrofo-che-appare-come-%ef%bf%bd/

May 17, 2019 at 4:13 pm #3835961

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, ho diviso questo ticket, visto che il problema originale di questo ticket è stato risolto. tra un po' risponderò anche l'altro ticket.

Ti ringrazierei se potresti condividere con noi la soluzione al problema dell'apostrofo, in modo che in futuro anche altre persone con lo stesso problema sappiano come l'hai risolto.

Grazie mille.

Saluti.

May 20, 2019 at 6:26 pm #3849677

lucianoC-13

ciao, i caratteri errati li ho sostituiti nel db di mysql con una query di sostituzione testo.

May 21, 2019 at 7:55 am #3852845

lucianoC-13

My issue is resolved now. Thank you!