This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.16 hours from now. Thank you for your understanding.

This topic contains 7 risposte, has 2 voci.

Last updated by manuelM-50 12 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
October 18, 2018 at 2:44 pm #2828387

manuelM-50

Salve,

Ho provato a tradurre un prodotto e nel dettaglio visualizzo le categorio duplicate (es UOMO UOMO) e anche i prodotti correlati. Mentre per i prodotti non tradotti le categorie e i prodotti correlati non sono duplicati.
Quale può essere il problema?
Grazie,
Manuel

October 18, 2018 at 3:01 pm #2828417

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve Manuel, grazie per aver contattato il supporto WPML!

Per poter essere d'aiuto avrei bisogno di maggiori dettagli.

In particolare avrei bisogno di vedere il problema. Visto che il sito è in modalità manutenzione, se fosse possibile, vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito solo per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

Grazie

October 19, 2018 at 9:06 am #2831302

manuelM-50

Questo è link del prodotto
hidden link

October 19, 2018 at 3:48 pm #2832609

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Manuel,

ho visto il problema nel tuo sito.

Ho provato a riprodurlo nella mia installazione locale utilizzando una versione precedente del tema (1.22.1) ma non ci sono riuscito.

Nel mio sito, la categoria non viene raddoppiata e compare in questo modo:
CATEGORY: CATEGORIA TEST 3

1. Puoi dirmi se hai effettuato delle modifiche al template per fare scomparire la stringa "CATEGORY: "?

2. Per accelerare il processo di risoluzione del problema, potresti replicare il problema in questa installazione di prova creata appositamente?
Per accedere ti basta cliccare su questo link:
hidden link
Troverai nome utente e password nella Dashboard del sito.

Sarebbe molto utile se potessi inviarmi una lista dettagliata dei passaggi utilizzati per replicare il problema.

Grazie

October 22, 2018 at 7:36 am #2836981

manuelM-50

Ciao Vincenzo ,
Ho notato che ora i prodotti nuovi non vengono duplicate le categorie se tradotti.
L'unico prodotto che ho riscontrato il problema è questo:
hidden link

October 22, 2018 at 1:09 pm #2838173

manuelM-50

Comunque ho provato a replicarlo nel sito di test , ma le categorie che io intendo sono con il woocommerce

October 22, 2018 at 4:16 pm #2838897

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Manuel,

se il problema riguarda un solo prodotto, puoi provare a rimuoverlo e crearlo nuovamente?
Ovviamente è meglio effettuare prima un backup del sito e, meglio ancora, provare prima su una copia di sviluppo.

Per quanto riguarda la riproduzione del problema, il sito fornito, dispone di tutti i plugin necessari. Ti basta attivarli e configurarli.
Se per riprodurre il problema è necessario qualche altro plugin o tema, potrai caricarlo da Plugins -> Add new

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 23, 2018 at 1:25 pm #2842603

manuelM-50

Grazie Vincenzo, eliminando il prodotto sono riuscito a risolvere il problema. Probabilmente si è creato quando ho portato il sito da locale a online. Grazie