This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 12 risposte, has 2 voci.

Last updated by Vincenzo 4 mesi, 4 settimane fa.

Assigned support staff: Vincenzo.

Autore Post
October 21, 2018 at 8:45 am #2835279

Giulio

Buongiorno Vincenzo,

vorrei chiedere come mai su Google Search Console mi appaiono URL con ?clang=all. Per caso non è impostato automaticamente il nofollow?

Grazie.

October 21, 2018 at 9:43 am #2835372

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

il parametro clang si riferisce alla lingua dei commenti/recensioni.

Le segnalazioni nella Search Console avvengono probabilmente perché il parametro non viene preservato nelle traduzioni.

Per risolvere, prova ad utilizzare l'opzione per preservare gli argomenti URL.
- Vai su WPML -> Lingue
- Scorri fino alla sezione "Opzioni selettore di lingua"
- Clicca su "Preserva gli argomenti URL"
- Aggiungi clang nel box

In questo modo le segnalazioni nella Search Console dovrebbero sparire.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

October 21, 2018 at 9:49 am #2835374

Giulio

Grazie Vincenzo, ho aggiunto "clang" e adesso vediamo che succede.

October 21, 2018 at 9:52 am #2835376

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Perfetto,

rimango in attesa dei risultati.

Buona Domenica

October 21, 2018 at 9:55 am #2835378

Giulio

Un attimo, non so su Google Search Console, adesso è troppo presto per saperlo. Ma adesso vengono solo visualizzate le recensioni delle rispettive lingue, nonostante si clicchi su "Show reviews in all languages".

Mi spiego meglio: se nella pagina prodotto in italiano clicco su "visualizza tutte le recensioni per questo prodotto (numero recensioni totali)" mi appaiono solo le recensioni in italiano, anche se il numero di recensioni totali si riferiva a "recensioni IT" + "recensioni EN".

October 21, 2018 at 10:06 am #2835383

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Credo si tratti di un problema diverso. Forse causato dal sistema di cache.

Da quello che posso vedere infatti, il parametro clang non viene attualmente preservato quando si cambia lingua.

1. Puoi mandarmi uno screenshot che mostri il box "Preserva gli argomenti URL"?

2. Puoi verificare l'esistenza del problema sia quando il parametro viene aggiunto al box sia quando viene rimosso?
- Suggerisco di ripulire ogni forma di cache durante le varie prove.

Se il problema si presenta in entrambe le situazioni, ti chiedo di aprire un nuovo ticket al riguardo.

Grazie

October 21, 2018 at 10:14 am #2835401

Giulio

Ecco fatto. Ho provato sia con, che senza. Resettando sempre la cache (usiamo WP Rocket), ma niente. Che faccio, devo aprire un nuovo ticket?

October 21, 2018 at 10:21 am #2835413

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie per lo screenshot.

Da quello che posso vedere nel sito, adesso il parametro viene preservato correttamente durante i passaggi fra le lingue.
Questo dovrebbe risolvere il problema nella Search Console.

I commenti però vengono visualizzati in tutte le lingue in ogni caso.
Per questo problema ti chiedo di aprire un nuovo ticket.

Se disponi di una copia di sviluppo del sito, prova questi passaggi prima di aprire il nuovo ticket:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Disattiva tutti i plugin tranne WPML e i suoi addon, WooCommerce e WooCommerce Multilingual.
- Imposta un tema predefinito (per es. Twenty Sixteen).
- Se il problema dei commenti si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.
Infine riattiva il tema.

- Puoi segnalare quando torna il problema nel nuovo ticket in maniera da accelerare il debug?

Grazie

October 21, 2018 at 10:29 am #2835414

Giulio

Caro Vincenzo, a parlare con le varie assistenze - ti parlo di supporti importanti come il vostro o quello di WooCommerce - dovremmo stare tutti i giorni a disattivare e ri-attivare plugin uno ad uno. Oppure avere siti con solo 3 plugin ? Insomma... tra l'altro disattivando e ri-attivando tutto sballano menù, widget e quant'altro. Per questo ti pregherei di avanzare qualche ipotesi. Potrebbe trattarsi di un problema di cache? E qualora non sapessi cosa rispondermi ti chiedo, c'è un modo per disattivare completamente questa "nuova" feature, a mio parere ancora in fase un po' embrionale? Grazie.

October 21, 2018 at 11:25 am #2835482

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Capisco quello che dici anche perché molto spesso sono io stesso ad effettuare queste operazioni nella copia locale dei siti dei clienti.
Il fatto è che questa procedura di troubleshooting è veramente efficace e permette quasi sempre di isolare la causa del problema, accorciando così i tempi di risoluzione.

Ovviamente si tratta di un operazione non consigliabile in un ambiente di produzione, ma che dovrebbe sempre essere fatta nella versione staging del sito.

La causa del problema potrebbe essere la cache oppure qualche conflitto con altri plugin o con del codice aggiunto al tema che, per esempio, imposta 'suppress_filters' su 'TRUE'.

Senza un debug approfondito non ho modo di saperlo.

Per rimuovere la possibilità di mostrare le recensioni in tutte le lingue, puoi usare questo codice CSS:

a#lang-comments-link {
    display: none;
}

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie

October 21, 2018 at 2:34 pm #2835607

Giulio

My issue is resolved now. Thank you!

May 21, 2019 at 12:32 pm #3855133

Giulio

Ciao Vincenzo, c'è un modo per eliminare del tutto il link con clang? Si tratta di una funzione non utile per noi.

May 21, 2019 at 3:18 pm #3856571

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

questo ticket è chiuso e non è facile seguirne l'andamento.

Potresti per favore aprirne uno nuovo?
Puoi farlo da questo indirizzo: https://wpml.org/it/forums/forum/supporto-in-italiano/
- Ti basta cliccare su "Apri un nuovo ticket di assistenza"

Grazie