This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 7 risposte, has 2 voci.

Last updated by Alejandro 1 settimana, 5 giorni fa.

Assigned support staff: Alejandro.

Autore Post
October 7, 2019 at 3:04 pm #4708729

marcoZ-26

Ciao Alejandro, ho provveduto a fare la migrazione, attendo tue direttive in merito.
A questo punto, visto che dovrai disattivare tutti i plugin per capire il tipo di errore, ti allego anche tutti gli altri problemi che ho avuto in merito alle traduzioni. Di seguito screenshot e descrizioni:

3- lato responsive, non riesco a modificare lo sfondo da trasparente a nero (come nella lingua inglese) del menu. Praticamente ho del testo bianco con background trasparente! vedi file allegato : brothesign_menuresponsivo.jpg

Ti ringrazio e attendo tue novità a riguardo.
a presto

October 7, 2019 at 3:10 pm #4708797

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Non so se questo problema è già stato risolto ma non riesco a riprodurlo. sembra che nel mobile funzioni bene e nel sito desktop è messo in modo inline.

Mi potresti dare più informazioni a riguardo?

Grazie!

October 7, 2019 at 3:23 pm #4708855

marcoZ-26

No questo non è stato risolto. ho appena controllato sia su mobile che nel sito (tramite la funzione apparence/customize) Il menu a tendina si vede bene per la sola lingua inglese mentre per la versione in italiano (funziona bene per la versione desktop, male per tablet e mobile) continuo a vedere il testo bianco e lo sfondo trasparente, invece che sfondo nero e testo bianco). attendo tue. grazie

October 7, 2019 at 4:34 pm #4709477

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hai ragione, scusami, ora si che sono riuscito a riprodurre il problema.

Mi potresti dire come hai fatto per aggiungere questo colore al menu? e sopratutto da dove l'hai fatto?

Il problema è che il colore di sfondo che hai inserito è per l'id "ul#menu-main-menu" ma per qualche ragione, quando traduci la pagina, l'ID diventa invece "ul#menu-main-menu-it"

Se hai fatto questo cambiamento manualmente prova ad usare una classe anziché un ID oppure puoi usare il Regex nel CSS. penso che nel tuo caso si vedrà così:


ul[id^='menu-main-menu']{
   background-color: black;
}

Saluti.

October 7, 2019 at 4:48 pm #4709523

marcoZ-26

tranquillo. Non ho impostato io il colore, ma altre persone prima di me che hanno gestito il sito. quindi non saprei indicarti dove e come è stato aggiunto. Non ho capito cosa dovrei fare a questo punto, se aggiungere il codice che mi hai indicato (e dove esattamente?) o cosa altro...
attendo tue, saluti.

October 8, 2019 at 10:28 am #4714225

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Prova ad inserire il codice che ti ho dato su Appearances > Customize > Custom CSS.

Se vedi che non cambia niente, prova invece ad aggiungere un "!important" alla fine del parametro background-color. si vedrebbe così:

ul[id^='menu-main-menu']{
   background-color: black !important;
}
October 8, 2019 at 10:37 am #4714351

marcoZ-26

Perfetto Alejandro. questo problema è stato risolto con il tuo codice aggiunto.
Grazie mille, passiamo al prossimo problema relativo il punto 4?

October 8, 2019 at 2:45 pm #4716423

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sono contento che il problema sia risolto, procedo a chiudere questo ticket e andrò a controllare il punto numero 4.

Saluti