This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.86 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problema: L'elemento media masonry grid non funziona nelle lingue tradotte

Soluzione: Devi assicurarti di avere il campo "_vc_post_settings" come "Non tradurre"

Questo campo lo trovi in 2 posti: 1) Nella pagina dove si trova questo elemento, scendendo su "Multilingual Content Setup", premendo il pulsante "Show System Fields" nella zona dove si trovano tutti i campi personalizzati

2) Su WPML > Impostazioni > "Traduzione campi personalizzati" > premi "Show System Fields" e poi li troverai.

Etichettato: 

This topic contains 10 risposte, has 2 voci.

Last updated by Alejandro 3 mesi, 2 settimane fa.

Assigned support staff: Alejandro.

Autore Post
June 20, 2019 at 5:05 pm

nerodecoT

Buonasera, sto utilizzando WPML nel sito hidden link. Nelle pagine tradotte in inglese, in cui è presente il masonry media grid (del visual composer), vedo il loader ma non viene caricata alcuna immagine.

June 21, 2019 at 11:11 am #4066511

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Ho provato ad accedere al sito però il link che mi hai dato sembra che non sia giusto (mi da errore 404)

Potresti verificare e darmi accesso di nuovo, per favore?

Grazie in anticipo.

June 21, 2019 at 4:02 pm #4068285

nerodecoT

[Deleted by supporter]

June 24, 2019 at 11:54 am #4076955

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Ho visto il sito e tutto ma non riesco a capire dove posso trovare il masonry grid. mi puoi dare più dettagli (penso si trovi nella homepage pa come si chiama l'elemento? )

Fammi sapere per poter continuare.

Saluti.

June 24, 2019 at 11:55 am #4076959

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ti chiedo più dettagli proprio perché io non vedo nessun loader nella lingua inglese, quindi non so a cosa ti riferisci.

Grazie in anticipo.

June 24, 2019 at 1:28 pm #4077489

nerodecoT

Ciao, una pagina che contiene il bug è la seguente: hidden link
La pagina corrispondente in italiano funziona correttamente: hidden link
Il problema sussiste per tutte le pagine tradotte che contengono il masonry media grid.

June 24, 2019 at 1:59 pm #4077807

nerodecoT

My issue is resolved now. Thank you!

June 24, 2019 at 2:26 pm #4077967

nerodecoT

Ciao Alejandro, ho notato che se duplico la pagina in Inglese sembra funzionare tutto. Il masonry media grid inizia a dare problemi solo dopo che traduco alcuni elementi (per esempio un testo) della pagina in inglese.

hidden link (qui ho solo duplicato la pagina e non ci sono errori)
hidden link (qui ho lo stesso errore a cui facevo riferimento in precedenza)

Grazie in anticipo per l'aiuto.

June 24, 2019 at 5:13 pm #4078909

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Il problema è che la galleria non traduce mai le immagini.

Ho provato a cambiare la configurazione di uno dei campi di WP Bakery, chiamato "_vc_post_settings", da "copia" a "Non tradurre" e poi ho aggiornato la pagina che ti dava problemi e ora il problema è risolto.

Il problema qui è che la galleria stava cercando di copiarsi ma non cambiava L'ID delle immagini, e quindi per quello non caricava. Il problema si risolve facendo quello che ho spiegato qui sopra.

Saluti.

June 24, 2019 at 7:18 pm #4079421

nerodecoT

Grazie mille per la rapidità ed i chiarimenti, sembra che il problema sia risolto.
Vorrei capire dove hai cambiato la configurazione del campo del WP Bakery "_vc_post_settings", poichè non riesco a trovarlo dal pannello di amministrazione di wpml.

June 25, 2019 at 2:00 pm #4085251

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Certamente!

Questo campo lo trovi in 2 posti:

1) Nella pagina dove si trova questo elemento, scendendo su "Multilingual Content Setup", premendo il pulsante "Show System Fields" nella zona dove si trovano tutti i campi personalizzati

2) Su WPML > Impostazioni > "Traduzione campi personalizzati" > premi "Show System Fields" e poi li troverai.

Questo vale per tutti i campi con il prefisso "_"

Saluti.