This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 6 risposte, has 2 voci.

Last updated by mariaP-18 1 anno, 5 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
May 11, 2018 at 1:07 pm #2089064

mariaP-18

Sto tentando di: tradurre alcune pagine del sito

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: l'immagine header in alto

Invece ho ottenuto: dopo aver tradotto la pagina in lingua inglese non riesco a vedere l'immagine header come nella pagina in italiano.

May 11, 2018 at 2:02 pm #2089713

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Il tema che stai usando nel sito supporta opzioni diverse a seconda della lingua.

1. Puoi verificare se impostando le opzioni del tema anche in Inglese il problema si risolve?

2. Verifica inoltre se l'immagine risulta tradotta.
Vedi: https://wpml.org/documentation/getting-started-guide/media-translation/

❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

3. Potrebbe trattarsi di un problema di aggiornamenti.
Puoi provare ad aggiornare WordPress, il tema e, se necessario, i nostri plugin?

Grazie

May 14, 2018 at 1:05 pm #2120259

mariaP-18

Ciao Vincenzo
il sito su cui ho riscontrato problemi è un multisito. Ci sono differenze di impostazione e funzionamento per il multisite? Nella tua esperienza i problemi di conflitto di codice possono derivare da ciò?

Grazie
Maria

May 14, 2018 at 6:05 pm #2125544

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Maria,

di solito non dovrebbe cambiare nulla nel caso del Multisito.

Questa è la lista di passaggi che uso di solito per copiare le impostazioni del tema da una lingua all'altra:

❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Vai su Avada -> Theme options -> Import/Export
- Seleziona la lingua Italiana nella bacheca utilizzando il selettore lingue nella barra in alto
- Premi il pulsante "Download Data File" e salva una copia delle opzioni per sicurezza
- Premi il pulsante "Copy Data"
- Copia il testo che appare (CTRL +C)
- Cambia la lingua della bacheca su Inglese
- Premi il pulsante "Import contents from File"
- Incolla il testo precedentemente copiato nel box che appare (CTRL +V)
- Premi il pulsante "Import"
- Attendi il completamento dell'operazione di importazione.

Verifica nel sito che le opzioni del tema siano state correttamente copiate dall'Italiano all'Inglese.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

May 15, 2018 at 7:10 am #2129803

mariaP-18

Buongiorno Vincenzo,
il problema persiste. Ti allego i link di versione italiana e inglese della stessa pagina. Nella prima è visibile l'immagine header. Nella seconda no.

hidden link
hidden link

Translation Media è stato installato ed è attivo. Ho seguito le indicazioni sull'uso del plugin.

Dove sta l'errore?

Grazie

May 15, 2018 at 8:31 am #2131541

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

hai già effettuato la procedura di duplicazione delle immagini da WPML -> Traduzione file multimediali?

Come inserisci quell'immagine? Si tratta di un'opzione del tema o è inserita con uno slider?

Se si tratta di uno slider, dai un'occhiata a questi articoli:

https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translating-avada-sliders

https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/

Se il problema non si risolve, vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
- hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

Grazie

May 21, 2018 at 8:32 am #2199531

mariaP-18

Ciao Vincenzo,
grazie della tua risposta precisa e dettagliata. Ho seguito scrupolosamente le tue indicazioni e mi sono accorta, strada facendo, che il problema non era nel plugin WPML, ma nasceva nelle impostazioni del tema utilizzato per il sito, e in un problema di aggiornamento di un altro plugin utilizzato per le immagini.

Senza il tuo aiuto non ci sarei arrivata comunque.

GRAZIE MILLE 🙂