Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.34 hours from now. Thank you for your understanding.

This topic contains 3 risposte, has 2 voci.

Last updated by Vincenzo 4 anni, 1 mese fa.

Assigned support staff: Vincenzo.

Autore Post
June 10, 2016 at 4:15 pm #906991

fabioF-7

Salve,

da installazione nuova e pulita ho installato la versione più aggiornata di Bridge Theme e di WPML ma una volta attivati entrambi lato front-end mi viene visualizzata una pagina totalmente bianca, senza errori. C'è modo di risolvere questo inconveniente senza dover tornare a versioni precedenti? Grazie

June 10, 2016 at 4:19 pm #906993

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!
Mi occuperò di questo ticket

Dietro una pagina bianca c'è quasi sempre un errore PHP.
Per sapere qual'è l'errore bisogna attivare la modalità di debug di WordPress.

Per attivare la modalità di debug di WordPress bisogna:

- aprire il file wp-config.php e cercare la riga:

define('WP_DEBUG', false);

Cambiarla in:

define('WP_DEBUG', true);

Per scrivere il debug su un file nel server bisogna aggiungere una riga simile:

define( 'WP_DEBUG_LOG', true );

In questo modo gli errori verranno salvati nel file debug.log all'interno della cartella /wp-content/

Se desideri che gli errori non rimangano solo nel file di log ma vengano visualizzati anche sullo schermo puoi aggiungere questa linea immediatamente dopo quella summenzionata:

define( 'WP_DEBUG_DISPLAY', true );

Il file wp-config.php si trova nella root della tua cartella WordPress.

Una volta attivata la modalità di debug si deve provocare nuovamente la pagina bianca in maniera da registrare il problema nel file di log.

A questo punto puoi postare il contenuto del file wp-content/debug.log qui sul forum o, se è troppo grande, su pastebin.com

Documentazione relativa:
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress
- https://wpml.org/faq/500-error/

-----------

Dalle informazioni di debug vedo che il valore di WP Memory Limit è inferiore ai requisiti minimi.
- https://wpml.org/home/minimum-requirements/

Per incrementare il WP Memory Limit aggiungi questa riga nel mezzo del file wp-config.php (IMPORTANTE, inserire la riga prima del commento riguardo la fine delle modifiche):

define( 'WP_MEMORY_LIMIT', '256M' );

Maggiori informazioni qui:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

June 10, 2016 at 4:24 pm #907009

fabioF-7

Ecco svelato il problema:

Fatal error: __clone method called on non-object in /var/www/vhosts/kifadesign.it/newelgon/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 2928

Risolvibile? Grazie

June 10, 2016 at 4:56 pm #907095

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie per il debug.

Alcuni temi utilizzano funzioni di WPML prima che il plugin sia configurato e questo può portare a questo tipo di errori.

Prova questi passaggi:

Seleziona un tema predefinito (per es. Twenty Sixteen)
Completa la configurazione di WPML
Riattiva il tuo tema

Fammi sapere se così il problema si risolve.

Grazie