This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problema: Ho 100 post in portfolio in Italiano e volevo creare/duplicare questi elementi in Inglese e successivamente in altre lingue. Soluzione: Per ottenere questo risultato, imposta il "tipo di contenuto" Portfolio su "Traducibile: se disponibile, usa la traduzione, altrimenti lascia la lingua predefinita" da WPML -> Impostazioni -> Traduzione dei tipi di contenuti In questo modo tutti i portfolio aggiunti nella lingua predefinita, e non tradotti, saranno visibili nelle altre lingue. Documentazione utile: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Etichettato: 

This topic contains 28 risposte, has 2 voci.

Last updated by Vincenzo 1 anno, 1 mese fa.

Assigned support staff: Vincenzo.

Autore Post
October 9, 2018 at 8:42 pm #2802098

guidoD-4

Ciao,
ho creato traduzioni, pagine e item... tutto dovrebbe essere come il mio sito. Anche qui non funziona.
Attendo tue, buon lavoro.

October 11, 2018 at 6:22 pm #2809456

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

un aggiornamento sul ticket.

Ho passato tutti i dati necessari al nostro Compatibility team.

Ti aggiorno non appena ho novità.

Grazie per la pazienza

October 11, 2018 at 9:17 pm #2809753

guidoD-4

Perfetto, grazie. Attendo vostre.

October 12, 2018 at 9:15 am #2811370

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Imposto il ticket nello stato corretto (Demandato al team di compatibilità)

October 17, 2018 at 3:22 pm #2825120

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

il nostro Compatibility Team ho trovato una soluzione al problema.

Prova questi passaggi:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Apri il file \wp-content\plugins\live-search-and-custom-fields\_controllers\http_requests_controller.php
- Vai alla riga 530
- Trova questo codice:

$filter_fields_data[ $count ]['options'][]['opt'] = __( $opt, 'lscf' );

- Sostituiscilo con questo:

$filter_fields_data[ $count ]['options'][] = array( 'value' => $opt, 'opt' => __( $opt, 'lscf' ) );

- Salva il file

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 17, 2018 at 7:34 pm #2825776

guidoD-4

Ciao!
Grazie per la risposta. Però il mio sito alla linea 530 del file indicato, non ho questa stringa:

$filter_fields_data[ $count ]['options'][]['opt'] = __( $opt, 'lscf' );

ma questa:

$filter_fields_data[ $count ]['options'][]['opt'] = __( $opt, 'lscf' );

forse cambia qualcosa anche avendo riprodotto due item nel vostro spazio di prova.
Come si dovrebbe correggere la mia stringa?

October 17, 2018 at 7:45 pm #2825808

guidoD-4

Ops scusa Vincenzo!
Non so perché ma nella mail erano presenti quei codici strani.
La stringa corrisponde, l'ho cambiata e funziona!
Lo testo per un giorno e poi ti do la conferma che tutto sia ok.

Ora per far partire il sito in lingua inglese come faccio?
Grazie moltissimo per la risposta!!!!! e per tutto il supporto dato! veramente professionali!

October 18, 2018 at 8:46 am #2827207

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

sono contento che il problema sia risolto.

Puoi darmi maggiori dettagli su questa domanda?
Ora per far partire il sito in lingua inglese come faccio?

Se intendi impostare l'Inglese come lingua che appare per prima quando visiti il tuo sito, allora devi cambiare la lingua predefinita del sito da WPML -> Lingue

Rimango in attesa di conferma.

Grazie

October 18, 2018 at 10:26 am #2827597

guidoD-4

Ciao, ho selezionato la lingua di partenza come EN ma non vedo gli items portfolio.
Credo sia dovuto al fatto che dall'IT ho creato gli items e poi avevo fatto questa procedure da te suggerita... quindi in EN non risultano.

1. Impostando il "tipo di contenuto" Portfolio su "Traducibile: se disponibile, usa la traduzione, altrimenti lascia la lingua predefinita" da WPML -> Impostazioni -> Traduzione dei tipi di contenuti
In questo modo tutti i portfolio aggiunti nella lingua predefinita, e non tradotti, saranno visibili nelle altre lingue.

C'è modo di correggere?

October 18, 2018 at 10:38 am #2827631

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

il problema è che la lingua originale dei Portfolio è l'Italiano.
L'opzione "Traducibile: se disponibile, usa la traduzione, altrimenti lascia la lingua predefinita" funziona solamente quando la lingua originale del post type è uguale alla lingua predefinita del sito.
In questo caso, i portfolio sono in Italiano ma la lingua predefinita è diventata l'Inglese.

Quando hai cambiato la lingua predefinita, WPML dovrebbe averti avvisato di questo con un link alla documentazione relativa.

Per risolvere, puoi cambiare la lingua predefinita dei vari portfolio su Inglese.

October 19, 2018 at 1:07 pm #2832156

guidoD-4

Ciao, intendi da qui?

October 19, 2018 at 1:11 pm #2832172

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

si esatto.

In questo modo dovrebbe funzionare

October 19, 2018 at 1:18 pm #2832208

guidoD-4

Grazie. Per ora lascio ITA se in futuro ci dovessero essere problemi vi contatterò.
Ti ringrazio molto per la professionalità e la pazienza.
Considero risolto. Grazie!

October 19, 2018 at 1:58 pm #2832281

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Grazie per la risposta.

In caso di altri problemi o domande non esitare ad aprire un nuovo ticket.

Buon lavoro