This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 6 risposte, has 2 voci.

Last updated by Laura 5 mesi, 2 settimane fa.

Assigned support staff: Laura.

Autore Post
May 31, 2019 at 6:28 pm #3932651

pasqualeD

Buongiorno è da diversi giorni che riscontro alcuni problemi sul mio sito, forse sono connessi tra di loro.

1) Visualizzo questa schermata in WPML>Lingue>Formato degli URL per le lingue
2) utilizzo il plugin Rank Math Seo, anche per generare la Site Map. Funzionava tutto ma ad un certo punto, non so bene a seguito di cosa......il link della sitemap (www.miosito.com/sitemap_index.xml) restituisce una pagina bianca (relativamente alla versione italiana del sito : hidden link), mentre per la versione inglese (www.miosito.com/en) la site mao è attiva e visibile (www.miosito.com/en/sitemap_index.xml) Il mio provider mi ha clonato il sito in una sotto cartella e ho fatto dei test. Ho rilevato che disattivando il plugin di WPML, la sitemap ritorna visibile, ma non sempre, riattivando torna visibile ma non sempre. Infatti avevo precedentemente fatto dei test nell'area di staging e non avevo rilevato dei plugin che generassero questo errore.

May 31, 2019 at 9:54 pm #3933497

pasqualeD

In particolar modo il pluginin questione è WPML Multilingual CMS. Ovvero : attivo una alla volta i seguenti plugin : WooCommerce Multilingual,WPML CMS Nav, WPML Media, WPML Sticky Links, WPML String Translation, WPML Translation Management e.....la sitemap di Rank Math seo è visibile, poi attivo : WPML Multilingual CMS e la site map nno è più visibile.

June 1, 2019 at 8:46 am #3934625

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Salve,

grazie per averci contattato.

1. hai verificato se effettivamente le directory funzionano oppure no? Spesso quel messaggio è un falso positivo, l'unico modo per verificare è fare un test reale.

2. vedo che abbiamo un ticket di compatibilità per il plugin Rank Math Seo e le sitemap effettivamente non funzionano correttamente. L'autore ne è al corrente ma si tratta di una funzionalità che deve aggiungere lui. A breve pubblicheremo un annuncio a questo proposito, ma al momento possiamo solo suggerire di non utilizzare questa funzione.

June 2, 2019 at 4:07 pm #3937703

pasqualeD

Le directory funzionano. Ma non mi potresti fare la cortesia di verificare ulteriormente e più approfonditamente?

June 2, 2019 at 5:32 pm #3937781

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

se le directory funzionano direi che è un falso positivo, quindi non so esattamente cosa dovrei controllare.
Nel messaggio di errore ci sono dei suggerimenti sul perché potrebbe non funzionare, il tuo sito incontra una di queste condizioni?

June 5, 2019 at 12:10 pm #3960289

pasqualeD

Ho contattato Site Ground e dicono che è tutto ok. Quindi sarà un falso positivo. però la cosa che non capisco è il perchè lo visualizzo solo ora.....non ho mai visualizzato quell'avviso.

June 5, 2019 at 3:05 pm #3962201

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

potrebbe essere causato da un qualche aggiornamento (del server o sul tuo sito) che ha portato alla modifica dell'.htaccess per esempio.
Ho visto parecchi casi del genere e finché non si verificano errori di solito funziona tutto correttamente.