This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 4 risposte, has 2 voci.

Last updated by 01sistemib 6 mesi, 2 settimane fa.

Assigned support staff: Noman.

Autore Post
April 3, 2019 at 9:21 am #3523947

01sistemib

Salve,
ho creato un wp multilaguage multisite, e impostato da wmpl Formato degli URL per le lingue->Directory con lingue diverse

Questo comporta che ilmiosito.it diventa ilmiosito.it/en/, però non funziona per la lingua predefinita che it, rimane ilmiosito.it invece vorrei diventasse ilmiosito.it/it/

Come posso fare?
Grazie
Luca

April 3, 2019 at 10:03 am #3524375

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to answer this in English, I hope that is ok, if you still need help in Italian please let me know.

Could you please try below steps and let me know how it goes?
- Please make sure you have selected ‘Use directory for default language’ checkbox from WPML >> Languages > Language URL format

- Please re-save permalink by pressing ‘Save Changes’ button from Settings >> Permalinks and see if this resolve your issue:
https://codex.wordpress.org/Settings_Permalinks_Screen

- Please clear all sorts of caches in your site plugin cache / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

- Please note, after above settings all dynamic links and language switcher will show url with /it/ for default language but static links will still show default language without /it/.

If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Thank you

April 3, 2019 at 10:50 am #3524817

01sistemib

Salve,
ho inserito:
Usa la directory per la lingua predefinita->Cosa mostrare nell'url della root:->file html->it
In fase di salvataggio appare quetso errore
http_request_failed - cURL error 28: Resolving timed out after 5516 milliseconds

p.s. il mio sito non è installato in una cartella it, può essere questo il problema?

Grazie
Luca

April 3, 2019 at 5:31 pm #3529359

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 5, 2019 at 12:22 pm #3543947

01sistemib

wmpl mi dice It looks like languages per directories will not function. e nel campo html non rimane scritto it, però il sito funziona tutto con cartelle per ogni lingua e anche l'italiano funziona con it.
Tnx