Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 23 risposte, has 3 voci.

Last updated by Alejandro 1 mese fa.

Assigned support staff: Alejandro.

Autore Post
July 28, 2021 at 5:53 pm #9302415

vincenzo-roccoC

sto cercando di impostare le directory di destinazione delle lingue ma non funziona.

hidden link

Vorrei che le lingue siano destinate a sottodomini:
en.lapietrataurina.it
es.lapietrataurina.it

non riesce a leggere le directory

c'è una guida da seguire?
Grazie e buona giornata

WPML.JPG
July 28, 2021 at 6:12 pm #9302581

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Se vuoi utilizzare i sottodomini, non devi selezionare la prima opzione, ma la seconda, "dominio diverso per lingua".

I sottodomini devono essere prima configurati nel tuo hosting, seguendo questa documentazione
https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/how-to-use-wpml-with-different-domains-per-language/

Saluti.

July 29, 2021 at 4:39 pm #9310737

vincenzo-roccoC

mi spiace ma non ho risolto
DNS sono configurati come da richiesta
allego foto
Posso darle un accesso diretto per poter controllare dall'amministrazione?
Dove posso inviare i dati?

dns2.JPG
dns.JPG
July 29, 2021 at 5:16 pm #9310945

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Io vedo ancora WPML configurato sul parametro (la terza opzione). Cosa succede scegliendo la seconda?

July 29, 2021 at 5:56 pm #9311113

vincenzo-roccoC

succede che non riconosce i sottodomini
come pure non riesce a scrivere nelle sottocartelle
allego foto

wpml 3.JPG
July 30, 2021 at 9:39 am #9314585

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

il messaggio per le directory può essere un falso positivo, se invece persiste allora c'è effettivamente qualche blocco, che però non può essere risolto da noi, perché WPML non può controllare i permessi delle cartelle. Dovresti verificare cosa succede con il tuo hosting.

Prova a togliere la spunta su "valida al salvataggio" e verifica se così funziona.
Prova anche a disabilitare WPML e verifica che aprendo i sottodomini si visualizzi il dominio principale, se così non fosse c'è un problema nella configurazione.

July 31, 2021 at 8:51 am #9319473

vincenzo-roccoC

ho fatto quello che ha detto
i sottodomini puntano al principale
ma wpml non funziona
cosa devo fare?
Allego foto

wpml 4.JPG
July 31, 2021 at 9:31 am #9319663

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Abilito una risposta privata per le credenziali.

July 31, 2021 at 10:11 am #9319735

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

WPML funziona, c'è un redirect 301 su tutte le pagine, chiedi al tuo hosting di controllare per favore.

Cattura.JPG
August 1, 2021 at 6:13 am #9321641

vincenzo-roccoC

Cara Laura
questo è l'ennesimo scarica barile!
La risposta del mio hosting è la seguente:

"Gentile Rocco Vincenzo,

hoting in questo caso non c'èntra assolutamente nulla. Deve contattare il loro supporto tecnico è chiede maggiori dettagli in merito la configurazione di quel plugin. Non non forniamo il supporto tecnico per plugin di terze parti e non possiamo intervenire in nessuno dei modi.

Come potrà assicurarsi lei stesso da qui hidden link e da qui hidden link

i sottodomini sono correttamente funzionanti è sono raggiungibili. Il server funziona correttamente. Verifichi le impostazioni di quel plugin.

Rimaniamo a sua disposizione

Cordiali Saluti"

Sembra che funzioni correttamente
Mi faccia sapere... Grazie.

August 3, 2021 at 9:30 am #9334055

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

i sottodomini sono configurati correttamente, infatti se guardi i link a cui punta il selettore di lingua sono giusti.

Il problema è che ci sono dei redirect 301, come ti ho fatto vedere nel post precedente, per cui tutti i sottodomini puntano al dominio principale.

WPML NON crea redirect, quindi devi capire cos'è che li genera. E' questo che dovresti chiedere all'hosting, perché se dici loro che i sottodomini non sono configurati correttamente ti diranno che non è vero.

Solitamente questi redirect vengono creati da plugin come Yoast o direttamente nell'htaccess.

August 3, 2021 at 3:46 pm #9336551

vincenzo-roccoC

Cara Laura
le ho fornito gli accessi, perchè non ha controllato?
Ho caricato due file index uno per ogni sottodominio e sono correttamente visibili. Non vedo alcun tipo di redirect.
Per altro ho controllato il htaccess e al momento risulta vuoto.
Provi a visionare e vedrà che funziona:
hidden link
hidden link

Intanto le traduzioni non sono visibili.
Attendo sue, grazie.

August 3, 2021 at 4:16 pm #9336645

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

veramente sono entrata sul sito, è così che ho visto il redirect 301.

E non ho detto che i sottodomini non funzionano, ho detto che c'è un redirect, ed è questo il motivo per cui le traduzioni non si vedono.

Ti chiederei di fare un test di compatibilità
- fai un backup del sito
- disattiva tutti i plugin tranne WPML e le sue componenti
- passa ad un tema di default come TwentySeventeen
- controlla se il problema si presenta nuovamente
- se non lo fa, riattiva i plugin uno alla volta fino a trovare quello che causa il problema
- per ultimo, riattiva il tema

August 4, 2021 at 4:55 pm #9345087

vincenzo-roccoC

Ho fatto le procedure richieste ma le traduzioni non sono visibili con le prime due opzioni, nemmeno con il template di base.
Appena si attiva wpml cms il problema persiste.
Mentre con la terza opzione funziona.
Il problema non si è risolto.

August 5, 2021 at 5:25 pm #9352233

vincenzo-roccoC

ok, migrazione avvenuta.