This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problema: Alcune pagine tradotte usando l'editore di traduzione avanzato non cambiano lo stato della traduzione e quindi le pagine non vengono pubblicate

Soluzione: Aggiorna WPML e Translation Management alla versione più recente. Se il problema continua, per favore segui questi passi: 1) Vai su WPML > Translation management > Translation jobs 2) cancella qui i lavori delle pagine che presentano questo problema 3) Riaggiungile di nuovo in WPML > Translation management > Translation Dashboard 4) Prova a tradurle di nuovo (preferibilmente tramite WPML > Translations)

This topic contains 19 risposte, has 2 voci.

Last updated by Alejandro 7 mesi, 2 settimane fa.

Assigned support staff: Alejandro.

Autore Post
January 28, 2019 at 10:13 am #3134872

teresaG-7

Sto tentando di: Completare una traduzione

Link a una pagina dove è possibile vedere il problema:

Mi aspettavo di vedere: lo stato della traduzione cambiato in "complete"

Invece ho ottenuto: La traduzione dell'articolo non passa a completa, rimana il tasto "traduci"

January 29, 2019 at 10:05 am #3139070

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Mi potresti dare più dettagli sul problema che riscontri?

Per quello che capisco hai provato a tradurre una pagina, ma dopo non compare completata, quello che mi domando è:

1) Hai provato a fare la traduzione tramite il gestore di traduzioni (WPML >Translations / WPML > Translation management) oppure direttamente sul post/pagina in questione?

2) Dove vedi che dice "traduce" invece di dire "completato"? mi potresti mostrare uno screenshot di questa schermata?

Appena mi risponderai saprò come procedere. Nel frattempo ti saluto e ti auguro un'eccellente giornata lavorativa.

January 29, 2019 at 8:45 pm #3141619

teresaG-7

Le traduzioni vengono fatte dal traduttore che ha una sua utenza, entra e va sul menù TRADUZIONI, allego foto della pagina traduzioni dove viene cliccato il tasto "Complete", che prima cambiava lo stato nell'elenco traduzioni e da qualche giorno non funziona più. Grazie

January 30, 2019 at 7:25 am #3142414

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie, ora capisco meglio.

Prima di continuare, avrò bisogno di accesso al tuo sito e accesso come traduttore e come gesore di traduzioni in modo di poter vedere la traduzione e conoscere cosa succede con essa.

Se è possibile vorrei avere una pagina di riferimento in modo tale di poter assegnarmi la traduzione e fare alcuni test.

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

January 30, 2019 at 11:04 am #3143429

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In effetti lo stato non cambia mai, neanche quando finisci di tradurla. questo però potrebbe anche trattarsi da un problema di cache. mi sapresti dire se il server dove stai lavorando al momento offre l'opzione di server caching (varnish, Memcache, OPcache, ecc)?

Poi potresti controllare la cartella wp-content/cache e cancellare tutto il contenuto per vedere se così lo stato si aggiorna?

Fammi sapere come va.

January 30, 2019 at 1:11 pm #3143990

teresaG-7

Al momento usiamo il plugin WP Super Cache, sul server non è attivata la cache.
Ho svuotato la cartella wp-content/cache e ho effettuato l'accesso con browser anonimo da tuo account temporaneo, ho tradotto ma il problema persiste, lo stato delle traduzioni non cambia.
Posso dirti che ha funzionato regolarmente con la stessa configurazione, le uniche operazioni effettuato sono state l'aggiornamento regolare dei vari plugin, però non posso dopo quale aggiornamento è apparso il problema perché mi è stato segnalato in ritardo dai traduttori.

January 31, 2019 at 3:02 pm #3148439

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao! ho chiesto ai nostri responsabili del traduttore avanzato e risulta che si tratta di un bug che è già stato risolto e sarà rilasciato con la prossima versione di WPML e Translation Management. cambierò lo status di questo ticket a "Risolto nella versione Successiva" così ti potrò avvisare appena uscirà questa nuova versione.

Nel frattempo ti consiglio di cambiare all'editore di traduzione classico così puoi andare avanti con il tuo progetto, anche se dovrai ritradurre le pagine che presentano questo problema.

Se invece puoi aspettare, meglio ancora, perché la nostra nuova versione è dietro l'angolo. (anche se al momento non possiamo darti una data più precisa)

January 31, 2019 at 3:44 pm #3148618

teresaG-7

Il traduttore sta andando avanti con le traduzioni nonostante il problema, quando uscirà la nuova versione di WPML dovrà tradurre di nuovo le pagine tradotte che presentano questo BUG? Se è così devo avvisarlo di farsi una copia delle traduzioni completate con questo problema. Per favore fammi sapere.

February 1, 2019 at 9:35 am #3150944

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In teoria non dovrà ritradurre tutto, sopratutto se tutto è stato fatto con il traduttore Avanzato direttamente (anziché tradurre tutto manualmente oppure con l'altro editore) ma se è possibile fare un backup è meglio farlo per poter coprire ogni possibile situazione che possa sorgere (anche se, di nuovo, non dovrebbe essere un problema).

February 13, 2019 at 8:50 pm #3196150

teresaG-7

Ciao Alejandro,
sto provando a togliere i lavori assegnati al traduttore ma non mi è possibile, mi dice "puoi eliminare solo i lavori eseguiti localmente"

February 13, 2019 at 8:51 pm #3196153

teresaG-7

E comunque anche con l'ultimo aggiornamento, anche levando i lavori dalla coda e riassegnandoli lo stato non diventa mai "completo", esce l'avvisto "lavoro completato" ma nell'elenco appare sempre "in corso", non è stato risolto il problema.

February 18, 2019 at 12:15 pm #3211987

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi potresti dare accesso al tuo sito? penso di sapere di cosa si tratti ma dovrei guardare per bene per confermare il problema.

Saluti.

February 18, 2019 at 12:56 pm #3212293

teresaG-7

Ti segnalo che il traduttore ha continuato a lavorare, questo per dirti che molte traduzioni che risultano non complete in realtà lo sono, cerchiamo di no perdere il lavoro fatto. Grazie mille

February 20, 2019 at 8:42 am #3220262

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Mi hanno informato che il problema con ATE non si è sistemato totalmente, infatti ci sono alcuni problemi che stanno sistemando al momento (come quelli che stai avendo tu al momento). Ho visto che con Itamar hai deciso di cambiare al l'editor classico.

Ci hanno detto che stanno lavorando al fix anche se ancora non sappiamo in quale versione verrà introdotto il fix.

Per ora terrò questo ticket con uno status "risolto nella versione successiva" così rimarrà aperto e ti potrò aggiornare.

Saluti.

February 20, 2019 at 8:53 am #3220314

teresaG-7

Ciao Alejandro, non capisco perché la tua risposta arrivata per email non è anche qui.
Comunque il problema persiste, non ho scelto io di passare all'editor classico ma le nuove traduzioni che ora si aprono tutte con il classic editor, il traduttore vede un messaggio "non sei stato abilitato all'editor Avanzato" e si apre il classico, ma io l'ho abilitato l'avanzato, ho provato anche a togliere e mettere l'editor a quel traduttore ma nulla, le nuove traduzioni si aprono tutte con il classic. La buona notizie è che con il classic editor è possibile cambiare lo stato su completato. Invece le traduzioni vecchie fatte con l'advanced continuano e non passare allo stato "completato".
A questo punto sarei tentato di passare tutte le traduzioni all'editor classico, mi sembra che dia meno problemi, è possibile convertire tutte le traduzioni all'editor classico?
Considera che tutte le traduzioni che ho mandato al traduttore e che non sono state ancora lavorate, il traduttore ha dovuto rinunciare e io riassegnarle in modo che si aprissero con l'editor classico, è stato un grande lavoro perché non cambiando stato in complete sono tutte mischiate e vanno aperte una per una per capire quali sono tradotte o no.
L'importante è non perdere le traduzioni già fatte ma non cambiano stato in complete.
Sono felice del supporto che date e vi ringrazio, però ho questo problema dello stato che non cambia da 2 settimane e sta rallentando molto il lavoro.
Giulio