This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problema: La homepage in Inglese viene reindirizzata a quella Italiana Soluzione: Il problema è causato dal fatto che la homepage selezionata al momento, esiste solo in lingua Italiana e non è stata tradotta in Inglese. Per risolvere il problema, tradurre in Inglese la homepage attuale

Etichettato: 

This topic contains 7 risposte, has 2 voci.

Last updated by Lorenzo Salvatori 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
September 27, 2018 at 3:38 pm #2771091

Lorenzo Salvatori

Buonasera, il sito è stato creato in lingua inglese e ho acquistato WPML per avere la doppia lingua e lavorare anche in Italia, ho appena ri-attivato WPML (era disattivato per alcuni aggiornamenti di wodrpress e cambio tema del sito), ora però non riesco più a vedere l'home page in inglese.

Ovvero la pagina principale è solo in Italiano, mentre se navigo all'interno del sito le pagine sono in inglese e appena clicco sulla bandiera in inglese mi reindirizza nella home page italiana, cosa posso fare?

Grazie mille per l'aiuto

September 27, 2018 at 4:28 pm #2771222

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buonasera, grazie per aver contattato il supporto WPML!

Da quello che posso vedere nel sito, sembra che sia stato impostato un redirect 301 dalla homepage Inglese a quella Italiana.

1. Puoi verificare se esiste un redirect impostato all'interno delle opzioni di qualche plugin o nel file .htaccess?

2. Verifica se la traduzione della homepage esiste e se per caso necessita di aggiornamenti.

3. Controlla la correttezza delle opzioni sulla homepage statica da Impostazioni -> Lettura

4. Verifica se esiste qualche opzione del tema che riguarda la URL della homepage

Grazie

September 27, 2018 at 4:39 pm #2771231

Lorenzo Salvatori

Grazie per avermi risposto.

1.Il file .htaccess non è stato modificato, è originale generato da wordpress.

2.Ho verificato la traduzione in homepage e non necessita di aggiornamneti

3.Le opzioni sembrano corrette

4.Il tema non ha opzioni per la lingua

September 28, 2018 at 12:26 pm #2773765

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

Se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

Grazie

September 28, 2018 at 5:35 pm #2774523

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buonasera,

da quello che posso vedere nel sito, il problema è causato dal fatto che la homepage selezionata al momento, esiste solo in lingua Italiana e non è stata tradotta in Inglese.

La homepage attuale è stata selezionata da Settings -> Reading, dalla versione Italiana della bacheca.

Per risolvere il problema puoi provare una di queste opzioni:

1. Tradurre in Inglese la homepage attuale (Home Page)

2. Impostare la pagina "Home" come homepage visto che è già tradotta

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

September 30, 2018 at 8:09 pm #2776729

Lorenzo Salvatori

Buonasera, ora la pagina principale funziona, ho però questo nuovo problema, ovvero devo abilitare lo slider nella lingua inglese e riesco a farlo dalle impostazioni del template (aspetto > personalizza) il problema è che appena clicco mi dà la pagina con l'errore 500 e ho provato sia con firefox che con chrome.

Da cosa può dipendere?

Grazie mille

October 1, 2018 at 3:18 pm #2778596

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buonasera,

sono contento che il problema principale sia risolto.

Visto che il problema originale è risolto, posso chiederti di chiudere questo e aprire un nuovo ticket per l'altro problema?
- La politica di assistenza prevede che si posti un solo problema per ciascun ticket.
Puoi farlo da questo indirizzo: https://wpml.org/it/forums/forum/supporto-in-italiano/
- Ti basta cliccare su "Apri un nuovo ticket di assistenza"

Questo aiuterà altri utenti con problemi simili a trovare le soluzioni quando cercano nel forum.

Prima di aprire il nuovo ticket, ti consiglio di aumentare il valore di WP Memory Limit e di abilitare la modalità di debug di WordPress in maniera da capire la causa dell'errore 500.

Grazie

Documentazione relativa:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
- https://wpml.org/it/documentazione/informazioni-per-gli-sviluppatori/eseguire-il-debug-di-wpml/
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress
- https://wpml.org/faq/500-error/

October 4, 2018 at 6:35 pm #2788567

Lorenzo Salvatori

My issue is resolved now. Thank you!